24bit flac music playback everywhere on Audirvāna Studio even on 16bit flac music

My dac on Audirvana Studio (Windows 10) upsumpling everything into 24bit, but this is only happening on Audirvana Studio (Windows 10). Everything normal on Windows 10 Roon with it’s 16bit, Windows 10 Tidal 16bit flac is 16bit and Qobuz 16bit is 16bit. I tried USB Audio Player on my both Android phones (Nokia 5.3 and Redmi Note 8T) and on there 16bit is whats needs to be 16bit.
So the problem isnt whit my external DAC which is an Sharkoon Gaming DAC Pro S V2.

How can I solve this problem, please help. I dont want anything to be upsample which is originally 16bit.
My external DAC is an Sharkoon Gaming DAC Pro S V2.
Current version: 1.5.6 (10506)

SIGNAL PROCESSING:

Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

UPSAMPLING:
SoX not in use
SoX filter parameters
Bandwidth at 0dB = 99.5%
Filter max length = 30000
Anti-aliasing = 100
Phase = 66%

AUDIO VOLUME:
Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

LIBRARY SETTINGS:
Sync list: 0 folders
Library database path: C:\Users\Joci új\AppData\Local\Audirvana\Audirvana\AudirvanaDatabase.sqlite

Remote Control server:
Listening on 192.168.0.198 on port 58200

ACTIVE STREAMING SERVICES
Qobuz: Connected as Qobuz Studio
TIDAL: Connected as HIFI

=================== AUDIO DEVICE ========================

Max. memory for audio buffers: 6090MB

Local Audio Engine: WASAPI

Preferred device:
Fejhallgató (Sharkoon Gaming DAC Pro S)
Model UID:MMDEVAPI\AudioEndpoints
UID:\?\SWD#MMDEVAPI#{0.0.0.00000000}.{3637de5b-dce6-4991-a28a-f49a27bab313}#{e6327cad-dcec-4949-ae8a-991e976a79d2}

Active Sample Rate: 44.1kHz

Bridge settings:
Sample rate limitation: none
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:
Local audio device
Fejhallgató (Sharkoon Gaming DAC Pro S)
Manufacturer: Microsoft
Model Name: Fejhallgató (Sharkoon Gaming DAC Pro S)
Model UID: MMDEVAPI\AudioEndpoints
UID: \?\SWD#MMDEVAPI#{0.0.0.00000000}.{3637de5b-dce6-4991-a28a-f49a27bab313}#{e6327cad-dcec-4949-ae8a-991e976a79d2}

3 available sample rates up to 96000Hz
44100
48000
96000
Volume Control
Physical: Yes
Virtual: No
MQA capability
Auto-detect MQA devices: Yes
Not a MQA device, user set to not MQA
DSD capability: Unhandled
Device audio channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: No

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1
2 ch Integer PCM 24bit little endian 44.1kHz
2 ch Integer PCM 24bit little endian 48kHz
2 ch Integer PCM 24bit little endian 96kHz

Local devices found : 2
Device #0: Hangszórók (Realtek High Definition Audio) Manufacturer: Microsoft Model UID: MMDEVAPI\AudioEndpoints UID: \?\SWD#MMDEVAPI#{0.0.0.00000000}.{d213e861-896e-471b-bef0-f9a5bfc6bf5f}#{e6327cad-dcec-4949-ae8a-991e976a79d2} Model Name: Hangszórók (Realtek High Definition Audio)
Device #1: Fejhallgató (Sharkoon Gaming DAC Pro S) Manufacturer: Microsoft Model UID: MMDEVAPI\AudioEndpoints UID: \?\SWD#MMDEVAPI#{0.0.0.00000000}.{3637de5b-dce6-4991-a28a-f49a27bab313}#{e6327cad-dcec-4949-ae8a-991e976a79d2} Model Name: Fejhallgató (Sharkoon Gaming DAC Pro S)

UPnP devices found : 0



Why do you use Wasapi instead of Asio or Kernel?

1 Like

I will think about the kernel one, Asio not supported by my dac.
Do you know soluton about my problem?

To get an Asio driver for your DAC, you should contact the Support of the company that builds it, and they will send you a link to download it. The difference in sound quality with Wasapi is day and light.

1 Like

Ok, but can it be solve my everything 24bit problem?

No, it has nothing to do with the fact that AS output your tracks at 24 Bit. It does the same on my Mac, and output in 32 Bit.
But a 24 Bit or 32 Bit output is not an upampling, and is not a problem. AS just outputs the sound to the bit depth of your DAC.

EDIT
Correction, in your case it outputs the sound at the Bit depth of your sound card, since you are playing in Wasapi.

1 Like

So if I am understanding you correctly, it is totally normal? But another quastion then, not every dac needs to support 16bit 44,1kHz and not just 24bit because my laptop internal dac supports 16bit 44,1kHz and my previous “now dead” external dac supports too on the same AS?

Read my correction in my previous post. Since you use Wasapi, AS outputs to the bit-depth of the sound card of your computer. It has nothing to do with the Dac.

1 Like

Now I switched to kernel playback and it is still happening, but thanks for your replies and helps.

Audirvana show the data differently from other players…
it shows on the right side, you DAC bitdepth

mine is 32/384, so if i play a 16/44 song it will show bitperfect playing on the right 32/44
If i play a 24/96 track it will show 32/96
if i upsample all to max of my dac a 24/96 file will show on the right 32/384
32/ stay always there as my DAC is 32 bits

So, you all good bit perfect playing since your upsampling is OFF as in your picture

1 Like

It is the same for me, except that despite what Studio shows on the right, a 16/44 track is actually sent as 16/44 to my DAC (according to my DAC). Studio’s display is confusing!

Does your DAC give you an indication of the bit depth of the sound that it receives?
Which DAC do you have?

Yes, it does. DAC is Mytek Brooklyn DAC+.

I found it. It has a very useful display. It should also sound great.

EDIT
So your DAC indicates that AS displays wrong information regarding its output. Interesting to know.

1 Like

Can you send a screenshot of your Studio settings while you see this on your Brooklyn?

Here are the settings:

Here is what the screen shows when I play a 16bit/44.1Hz track:

Studio (on the bottom right) shows track playing at 32/44.1. However, DAC indicated it is receiving 16/44.1.

If you disable the volume control, do you get 16 bit?

You are using a ASIO driver, this is why you get your output as 32 bit.

Can you send us a copy of the “Debug Info” when you have this issue? You can get it in Audirvana Settings>My account

Note: By clicking on the Debug Info button, Audirvana automatically copies all its content, all you have to do is paste it in response to this message

Note that while Studio reports sending 32bit/44.1kHz, my DAC is receiving 16bit/44.1kHz.

Debug Info:


Current version: 1.5.6 (10506)

Connected account: [email protected] (firstname lastname)

SIGNAL PROCESSING:

Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

UPSAMPLING:
r8brain not in use
r8brain filter parameters
Bandwidth = 99.5%
Stop band attenuation 218dB
Phase linear

AUDIO VOLUME:
Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

LIBRARY SETTINGS:
Sync list: 1 folders
AUTO: F:\Music
Library database path: F:\StudioDatabase\AudirvanaDatabase.sqlite

Remote Control server:
Listening on 192.168.2.24 on port 51639

ACTIVE STREAMING SERVICES

=================== AUDIO DEVICE ========================

Max. memory for audio buffers: 13404MB

Local Audio Engine: ASIO ASIO 2 driver version 1069

Preferred device:
Mytek USB Audio
Model UID:Mytek USB Audio
UID:Mytek USB Audio

Currently playing in Integer Mode:
Device: 2ch 32bits Integer, 8 bytes per frame 44.1kHz

Active Sample Rate: 44.1kHz

Bridge settings:
Sample rate limitation: 384kHz
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:
Local audio device
Mytek USB Audio
Manufacturer:
Model Name: Mytek USB Audio
Model UID: Mytek USB Audio
UID: Mytek USB Audio

11 available sample rates up to 11289600Hz
44100
48000
88200
96000
176400
192000
352800
384000
2822400
5644800
11289600
Volume Control
Physical: No
Virtual: No
MQA capability
Auto-detect MQA devices: No
Not a MQA device, user set to not MQA
DSD capability: Raw DSD (MSB)
Device audio channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: Yes
Simple stereo device: Yes

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1
2 ch Integer PCM 32bit little endian 44.1kHz
2 ch Integer PCM 32bit little endian 48kHz
2 ch Integer PCM 32bit little endian 88.2kHz
2 ch Integer PCM 32bit little endian 96kHz
2 ch Integer PCM 32bit little endian 176.4kHz
2 ch Integer PCM 32bit little endian 192kHz
2 ch Integer PCM 32bit little endian 352.8kHz
2 ch Integer PCM 32bit little endian 384kHz
2 ch DSD 8bit big endian in 8bit chunk 2822.4kHz
2 ch DSD 8bit big endian in 8bit chunk 5644.8kHz
2 ch DSD 8bit big endian in 8bit chunk 11289.6kHz

Local devices found : 3
Device #0: JRiver Media Center 28 Manufacturer: Model UID: JRiver Media Center 28 UID: JRiver Media Center 28 Model Name: JRiver Media Center 28
Device #1: Magix Low Latency 2016 Manufacturer: Model UID: Magix Low Latency 2016 UID: Magix Low Latency 2016 Model Name: Magix Low Latency 2016
Device #2: Mytek USB Audio Manufacturer: Model UID: Mytek USB Audio UID: Mytek USB Audio Model Name: Mytek USB Audio

UPnP devices found : 0


I observed this behaviour on ASIO mode.

In Kernel, which sounds better for me, the info is displayed correctly (the same in left and right).