After 3.5.40 update, Audirvana becomes completely non-functional

Audirvana was perfectly fine. But after 3.5.40 update, it opens empty. My library is gone. Connections to Qobuz & Tidal are also gone. All my settings are also gone. Tried to add back my library. Every time after I specified the network or local folder, I got an error “Fatal error adding folder to watchlist…”. Signing in to Qobuz returned “Error loggin to Qubuz”. I can only connect to Tidal. But once I close Audirvana and reopen it. even Tidal is lost again. Also, shortly after I launch Audirvana, I would see my DAC that is connected to my network bridge. A few seconds later, it no longer see it. It only see the HEOS enabled Marantz AVR.

The software has become completely useless now. Please help.

I removed 3.5.40 and installed 3.5.35. The same problems remained. Used check for update and installed 3.5.40 again. Same problems persist.

I am unable to post the debug info as it says new user cannot post more than 5 links. It counts the contents of the debu info are links.

Correction. The DAC was not lost. It sticks.

Maybe your preferences got corrupted somewhere.

Try to trash them and start again…
before trashing them, you can copy by dragging them out with the alt key pressed while dragging, that way you can put back them where they are if mine doesn’t cure it. but nothing works now, so no big loss…

if you know how to take pictures on your mac… photo your preferences to put them back easy after if you don’t know all of them.

Close Audirvana.

Apple hide the Home Folder in User Library at some time depending on OS System…
When you have clicked your Home Folder, and cannot see the Library Folder in there,
just do a ‘‘cmd J’’ to show the folder settings preferences and see at the bottom…
click Show Library Folder and then you’ll have access to the rest forever.

Go to User… Home Folder… Library… Preferences…
trash com.audirvana.Audirvana-Plus.plist and
com.audirvana.Audirvana.plist in that folder
(those are A+ software preferences, back them up or not).

Restart Mac, Open Audirvana… you will need your serial number i think…
will see your DAC, add a folder of music and wait till it finishes syncing.
Then put back all your preferences like they were…

Maybe you won’t have to add music folder since your database will be in the same place,
but it will surely sync at first…

Thanks RunHomeSlow! I deleted the files, etc. as suggested. It did ask for the key. Unfortunately, all the issues I described persist.

Hello @catbb,I changed your account settings, you should be able to post your debug info.

Thanks you Damien3.
Here’s my debug info:
Audirvana Mac Version 3.5.40 (3570)
macOS 10.11.6 with 8192MB RAM

Registered to Stephen Lee


Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

SoX not in use
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000
Anti-aliasing = 100
Phase = 66

Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

Sync list: 0 folders
iTunes/Music library synchronization: not synchronized
Library database path: /Users/catbb67/Library/Application Support/Audirvana/AudirvanaPlusDatabaseV2.sqlite


=================== AUDIO DEVICE ========================

Direct Mode audio path, buffer I/O frame size: 512

Max. memory for audio buffers: 5120MB

Local Audio Engine:
Exclusive access: Enabled
Integer mode: Enabled

Preferred device:
Built-in Output
Model UID:

Active Sample Rate: 44.1kHz
Hog Mode is off

Bridge settings:
Sample rate limitation: none
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:
Local audio device
ID 0x26 Splashtop Remote Sound Manufacturer:Splashtop Inc.
Model UID:com_splashtop_driver_RemoteSound:SplashtopRemoteSoundDevice UID:SplashtopRemoteSoundEngine:0

6 available sample rates up to 192000Hz
Audio buffer frame size : 14 to 4096 frames
Current I/O buffer frame size : 512
Volume Control
Physical: No
Virtual: No
MQA capability
Auto-detect MQA devices: No
Not a MQA device, user set to not MQA
DSD capability: Unhandled
Device audio channels
Preferred stereo channels L:1 R:2
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: Yes

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1

Stream ID 0x27 2 channels starting at 1
6 virtual formats:
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 192kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 176.4kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 96kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 88.2kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 48kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 44.1kHz

6 physical formats
2 ch Mixable linear PCM Interleaved 32 big endian Signed Integer 192kHz
2 ch Mixable linear PCM Interleaved 32 big endian Signed Integer 176.4kHz
2 ch Mixable linear PCM Interleaved 32 big endian Signed Integer 96kHz
2 ch Mixable linear PCM Interleaved 32 big endian Signed Integer 88.2kHz
2 ch Mixable linear PCM Interleaved 32 big endian Signed Integer 48kHz
2 ch Mixable linear PCM Interleaved 32 big endian Signed Integer 44.1kHz

Local devices found : 2
Device #0: ID 0x38 Built-in Output Manufacturer: Apple Inc. Model UID: AppleHDA:65 UID: AppleHDAEngineOutput:8,0,1,1:0
Device #1: ID 0x26 Splashtop Remote Sound Manufacturer: Splashtop Inc. Model UID: com_splashtop_driver_RemoteSound:SplashtopRemoteSoundDevice UID: SplashtopRemoteSoundEngine:0

UPnP devices found : 0

Try to reduce pre-load memory. Maybe your system is running out of memory.

I tried reducing the pre-load memory to 2 GB and 1 GB and closed and re-launched each time, the issues are still there. The Mac has 8GB RAM and Audirvana is the only program I launch on it.

Which method you use, monitored folder or iTunes sync? Where is your music stored, external drive, NAS, …?

Can you try add a synced folder again and check in the System Logs for any error from Audirvana?

For this, you can use the Console application. On any macOS before Sierra, select All messages on the left column. Then enter “audirvana” in the top right search field to keep only the lines from Audirvana.

If you have one, can you do a screenshot of the error line?

I don’t sync with iTunes. I monitor a local drive on the Mac.

Here’s a screenshot of the Console after I tried and failed to add a sync folder.

Can you reboot your computer and try to access to your files using Finder?

I tried that multiple times prior to posting here. Also tried after deleting the com.audirvana… files. I retried anyway just now and the issues still remain. I have not been able to play any music since 3.5.40 update. Any suggestions are much appreciated!

You can try to copy a subset of your library to some other external drive and try to map that. If that works you’ll know that’s an issue with the current drive.

It looks like a system issue to me.

As my original post indicated that I tried local drive as well as network drive. But I retried anyway to map to my other local drive and a network drive both with a very small subset of files. Got the same error in both cases. My storages are fine. The 3.5.40 messed up something on my Mac. Even older version of Audirvana does not work anymore while things were fine right before the update.

Have you tried to add this folder to iTunes ?

Probably the easiest way to fix this is to reinstall your Mac from scratch.

I am able to add a subset of as well as the whole folder to iTunes.

I had to burn down the Mac a few months ago after another update to the then latest Audirvana where I could no no longer connect to Qobuz nor Tidal. I could only play my own library. Due to the Mac OS installation files issue and some Apple restrictions, it took a lot of work to get this old Mac back to El Capitan. I am not about to go through the same trouble again. Since then I have been very apprehensive of any Audirvana updates. This last ordeal got me to buy the Elac Discovery Music Server running Roon Essential which has been a great and trouble free experience. But Audirvana is still my only means to stream my DSD files at home. Plus the Audirvana remote app runs on my phone while the Roon Essential remote app is not compatible with my phone.