Audirvana 3.5.37 freezes at startup

Interesting on the Album View vs Artist View thing. It does seem to work fine on Album view thus far on startup. I just have to remember to switch back to Album View when I exit the application each time…

Have you tried adding music to your music folder? Audirvana refuses to see any new albums I add. I have to do a full scan for the album to be added. It used to see new music at start up, but since the crash bug, it doesn’t anymore…And a re-scan takes forever.

I use to love this program…The only reason I come on this forum is in the hope that the dev gets it together and fixes this issue. I hate to think my money I paid was just thrown away.
.

1 Like

Hello Everyone,

We made a specific version for this issue, can you uninstall the version of Audirvana you have (Special Warning : It will delete the file AudirvanaPlusDatabaseV2.sqlite, you will lose all the Playlists you created in Audirvana. However, you can back-up the database file by copying it in a different directory)

The database is by default located here:

C:\Users\yourusername\AppData\Local\Packages\Audirvana.Audirvana-randomnumbers\LocalCache\Local\Audirvana\AudirvanaPlus

After doing the back up of database and uninstall Audirvana, can you install this special version and try reproduce your issue? https://audirvana.com/delivery/wintest/AudirvanaSetup_3.5.39.0_x64.appxbundle

1 Like

Hi Damien

Just installed the new version and the problem (for me) seems to be resolved. I can now start up in Artist view and no lock up or excessive CPU consumption is to be seen.

I’ll post back if more thorough testing shows any issues.

1 Like

Hi Damien,

The new version also appears to fix the issue for me as well. I can start up in Artists view without the application freezing/locking up. Thanks for your help with this issue. Please let us know if/when we need to transition back to a non-testing version (or if it will automatically occur during next update).

1 Like

Having witnessed the paroxysms of despair posted about this subject, I really thought that his thread would be packed with users looking for this modification! How wrong I was.

A little further information. The only downside I can find of this mod is that the existing tendency of Audirvana to start without displaying its UI, which might be completely down to my hardware, is somewhat worse now than with previous versions. Previously maybe one start in ten showed that issue, now it’s maybe one in three.

I don’t find this a serious issue. I only have to kill AV in Task Manager and restart. Hardly onerous.

1 Like

When you have this behavior with Audirvana, do you see Audirvana in background in Task Manager?

1 Like

Hi Damien

Yes. Audirvana displays as a Background Process instead of an App

1 Like

We had other feedback about it, can you check if you have this feature pack?: https://support.microsoft.com/en-us/help/4562569/media-feature-pack-for-windows-10-n-may-2020

1 Like

Hi Damien

My Windows is Window 10 Pro (2004). It is not the ‘N’ version, and the pack to which you refer is therefore not applicable and is not installed.

1 Like

Damien,
Is there a chance now that a workaround has been acknowledged that it can be fixed in an upcoming regular update? The sound is too beautiful, to be in experimentation mode.

Have you experienced the UI issue, where it appears Audirvana is operating in the background and not an app? You can probably tell I’m hesitant to install workarounds while the sound is so good right now.

I have not experienced the issue with it running in the background. However, I never experienced that problem with my installation, and based on Damien’s response it sounds like it is a separate issue not directly related to the original issue in this thread with regards to the freezing at startup in Artist view. I ran the application multiple times today without any issues.

Since the ‘starting as background task’ is not the main subject of this thread, I’ll start another one.

Here

https://community.audirvana.com/t/audirvana-starts-as-background-process-with-no-ui-displayed/17713

Hello @pieronip, @ljmarxen, @Partman and everyone who made the test for this issue, thank you for your test.

The fix we made is now available with the latest update we made for Audirvana 3.5.40 for Windows 10.

To be able to make the update you will need to uninstall the test version we sent to you and install the latest version using our website: https://audirvana.com/try/

Thank you.

New version installed and working perfectly.

Can you give us any insight as to thge nature of the problem? Just curiosity.

It’s a bit technical, it was a res condition that was present since a lot of time and was revealed recently. We couldn’t reproduce the issue until we had a crash report that had the exact error.

Thanks for the reply. Like everybody else here I believe the problem is solved. Life is good! Thanks again.

Beautiful again. That bugger was tough, but you and Audirvana were better. Love that sound! Thanks again.

Finally working for me…

Thanks!

Feel free to delete my pissed off comments. :smiley: