Audirvana 3.5.44 crashes immediately on commencing Audio Dynamics Analysis

As soon as beginning “Audio Dynamics Analysis”, selecting all or just a few albums the program crashes. I have tried rolling back to previous version but it just uninstalled so could only reinstall. It then repeated this behaviour.

How do I prevent this from occurring?

See debug info:

Audirvana 3.5.44

SIGNAL PROCESSING:

Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

UPSAMPLING:
SoX not in use
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000
Anti-aliasing = 100
Phase = 66

AUDIO VOLUME:
Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

LIBRARY SETTINGS:
Sync list: 2 folders
AUTO: I:\Music
AUTO: G:\Music
Library database path: C:\Users\XXXXX\AppData\Local\Audirvana\AudirvanaPlus\AudirvanaPlusDatabaseV2.sqlite

ACTIVE STREAMING SERVICES

=================== AUDIO DEVICE ========================

Max. memory for audio buffers: 8326MB

Local Audio Engine:WASAPI

Preferred device:

Model UID:
UID:

Active Sample Rate: 48kHz

Bridge settings:
Sample rate limitation: none
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:
Local audio device
Speakers (Sound Blaster Audigy 5/Rx) Manufacturer:
Model UID:Speakers (Sound Blaster Audigy 5/Rx) UID:\?\SWD#MMDEVAPI#{0.0.0.00000000}.{b041ee81-5eb8-496b-8642-89e4d8c24b76}#{e6327cad-dcec-4949-ae8a-991e976a79d2}

4 available sample rates up to 192000Hz
44100
48000
96000
192000
Volume Control
Physical: Yes
Virtual: No
MQA capability
Auto-detect MQA devices: Yes
Not a MQA device, user set to not MQA
DSD capability: Unhandled
Device audio channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: No

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1
2 ch Integer PCM 16bit little endian 44.1kHz
2 ch Integer PCM 24bit little endian aligned high in 32bit chunk 44.1kHz
2 ch Integer PCM 16bit little endian 48kHz
2 ch Integer PCM 24bit little endian aligned high in 32bit chunk 48kHz
2 ch Integer PCM 16bit little endian 96kHz
2 ch Integer PCM 24bit little endian aligned high in 32bit chunk 96kHz
2 ch Integer PCM 16bit little endian 192kHz
2 ch Integer PCM 24bit little endian aligned high in 32bit chunk 192kHz

Local devices found : 1
Device #0: Speakers (Sound Blaster Audigy 5/Rx) Manufacturer: Model UID: Speakers (Sound Blaster Audigy 5/Rx) UID: \?\SWD#MMDEVAPI#{0.0.0.00000000}.{b041ee81-5eb8-496b-8642-89e4d8c24b76}#{e6327cad-dcec-4949-ae8a-991e976a79d2}

UPnP devices found : 0

Hello @berwhale,

How many album are you analysing? Are they stored in a NAS?

It occurs when analysing either one album or many.

They are stored on local SATA III drives.

In revision, I think it seems to occur most often when selecting all then analysing.

Can you send us your dmp and log file at [email protected]?

It can be in two different locations :
C:\Users[your login]\AppData\Local\Packages\Audirvana.Audirvana-[… id number that can vary]\LocalCache\Local\Audirvana\Audirvana
C:\Users[your login]\AppData\Local\Audirvana\Audirvana

I’ve sent the contents of the first dir to the support email as a zipped file attachment.

On further troubleshooting it appears one file in particular, a lossy iTunes AAC file was somehow causing the program to crash when it was selected individually or as part of the “select all” action to analyse audio dynamics. I then converted it to an mp3 file of similar bitrate, which I then put in the former’s place. On analysing that file, the program proceeded without error.

There may be more offending files like it to come. Do you want me to send you the AAC file?

Hello @berwhale, yes please, we can then try to reproduce the crash on our side.