Audirvana stops end of first track UPnP: KEF LSX

Hi there,

I have issues with Audirvana and KEF LEX over UPnP/DLNA and QoBuz as Hi-Res streamed source.

The player stops after the first track…
I tried different ways to solve this issue with our results.

Is there anything I could do to solve / to get support?

Thank you
Vincent


Audirvana Mac Version 3.5.38 (3568)
macOS 10.15.5 with 32768MB RAM

SIGNAL PROCESSING:
Polarity Inversion:
Globally: OFF
Per track: ON
Effects plugins NOT ACTIVE

UPSAMPLING:
SoX not in use
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000

Hello @vincent1, I don’t see the whole debug info, can you click on the button in Audirvana settings (it automatically copy all of the content) and post it here again?

Dear Damien,

You will find relevant debug file here.
Hope this will help.
This issue is really annoying.
Thank you for your support.

Hello @vincent1, sorry for the delay, do you experience the same issue when are playing 16/44 track?

Hello @Damien3, sorry for this delay.
Yes, I have the same issue while playing 16/44 tracks.
The behaviour is not clear but the fact is that sound stops playing randomly at the end of a track.

Hello,

I also have the problem with the KEF LSX that only one track is played. You can skip the tracks, but even then the tracks won’t continue (also 16/44). It makes me despair.

I also have a KEF LS50 wireless where this problem does not occur.

Any ideas?

Thank you
Sebastian

Hello,

Same problem here, when it doesn’t read the music at all. Sometimes it works flawlessly. Here is the debug file generated after clicking plan and nothing happens. Cannot listen to music for now… It would be great to have a fix, thank you very much!

Tom

Hello @Tomah, I can see in your debug info that you are using ASIO, have you tried using WASAPI instead?

Hello @Damien3, thank you for your message.

Yes, unfortunately it does the same thing. As a side note, isn’t WASAPI inferior in terms of sound quality compared to ASIO? Because I was astonished by the gain in sound quality when I tried Audirvana after their dreadful “KEF Stream” app. I wouldn’t like to lose that.

I’d add that when everything is freezed (for example right now I cannot play any track, even the first one I select doesn’ launch), the volume control is perfectly responsive between Audirvana and the KEF LSX.

Tom

Their is no difference in sound quality, it’s more on the quality you can play with it. You need a ASIO driver to play DSD track at the maximum frequency possible for your DAC.

So even if you try with WASAPI Audirvana is freezing when you want to control the audio playback?

I have all those problems with WASAPI.

Thank you for the clarification. Yes, when I try with WASAPI I have the same problems but I tried less times with WASAPI than with ASIO.

To resume, it seems that I have three kind of situations:

  1. Everything runs smoothly, I even have a gapless playback. I was very happy when I listened for the first time to a DJ mix in its total continuity with enhanced sound quality after three months of playback with this suspicious “KEF Stream” app. Even downsampled DSD playback goes smoothly too, amazing sound quality and responsiveness. It’s just perfect.
  2. Everything runs smoothly as descrided above in (1) but the songs do not follow on from one another. When a song is finished, everything stops. I have to push on the stop button and click play on the next song everytime the previous song is finished.
  3. I try to launch a song but nothing works, the play/pause button freeze. When I push the stop button and retry to play the song or try another song, nothing works. But I can see that the communication between Audirvana and the KEF LSX exists because when I adjust the volume in Audirvana, the light on the KEF LSX tells me it receives the information. Similarly, when I adjust the volume with the KEF LSX remote, the volume is adjusted in Audirvana.

I really cannot tell why one or the other situation occurs and tried with another computer with exactly the same pattern. I have the feeling that it happens randomly and in no particular order, with the same proportions: one time (1), the other time (3), the other time (2), etc. When I shut everything off and restart everything, it doesn’t solve the problem.

Thank you,

Tom

Okay,so the issue is only the play back possibility of the LSX. Do you have a Android device to try if you have the same issue using Bubble UPnP?

OK, thank you. I don’t know Bubble UPnP but I will try and keep you updated.

Tom

I’ve just tried with a few albums and it runs OK but not gapless and it’s not as responsive as the (1) situation described above with Audirvana. I will continue tonight and give you a feedback tomorrow - maybe the other situations will pop up later.

With Bubble Upnp it worked yesterday for two hours as described above (I would say it worked like the KEF Stream App), but this morning I’m in situation (2), it stops whenever each song is finished.

Okay, that fact is the issue you have is erratic and do not happens every time you try to play a song. It can be a network issue with your LSX, have you contacted KEF about it?

Hello,

Since yesterday, I’ve disable every firewall on all my devices and have been in the situation (1) ever since. I cross my fingers for it to be the issue. Is it possible for that to be the problem?

If so, I will have to find exactly what happens with the firewall because I cannot live with it disabled all the time.

I have not yet contacted KEF.

I keep you posted,

Tom

Hello,

Today I’m in situation (3) unfortunately, here is the debug file.

I will try to contact KEF but if someone has some insights, it would be great.

Thank you,

Tom

Hello,

After some experiments, I can say that whenever the problems occur, if I shutdown the KEF LSX and unplug them (so they are fully shut down), right after that everything comes back to normal.

So the KEF seem to be the problem.

Tom