Audirvana studio and DietPi - Problem playing Tidal HD

Hi

I’m having some issues playing Tidal HD tracks on my RP4 running DietPi and Audirvana studio. RP4 is connected to my Denafrips DAC using I2S.
Regular tracks on Tidal play fine.

Any idea how to solve this?
As a workaround, is there a way to limit playback to 16/44.1?

Thanks

You use last version ? The last version seems having same issue with GentooPlayer…
With the previous one I had no issues with Hi Res
It’s linux version isn’t it?

Hi @simon12,

Can you send us a copy of the "Debug Info“ when you have this issue? You can get it in Audirvana Settings>My account.

Note: When you click on the Debug Info button, Audirvana automatically copies all its content. Please paste it in response to this message.

It’s headless installation on DietPi.
Maybe a file somewhere?

You have it in the remote app :wink:

Wasn’t able to copy paste from my Android app
Attaching screenshots





Last one

Ok, you mention issue playing TIDAL HD, can you please describe more what is going on?

There is noise coming out instead of music. It’s basically the same noise resulting from a poor handshake via I2S between the DAC (Denafrips Pontus II) and the Raspberry Pi 4 I2S HAT (Ian Canada TransportPi Digi).
With Volumio I was able to fix this by selecting the right preset in the DAC. With Audirvana, none of the preset work… So I suspect it’s a software issue

Can you go into the Audirvāna settings and in the My Account section? You will see a ‘Start Log Session’ button; click on it and reproduce your issue. After you reproduce it, click 'Stop Log Session’ and click the 'Open Log Folder’ button.

Do you see an error displayed?

Hi… Select another overlay in the config file or from Dietpi, go to audio settings, and select the correct hat type. This is most probably due to an incompatible hat selected in Dietpi.

This issue is not in AS but in the HAT configuration. If you use Roon, for example, you will notice the same issue of being unable to play HD (Roon does downsample to 44.1, but AS does not play it at all).

1 Like

As per the Transport pi Digi II documentation the Hifiberry Digi pro is the one to choose.

Also tried Allo Digi one but that didn’t help…