Audirvana Studio on GentooPlayer

Hello;
I have just installed AS on GentooPlayer.
Audirvana Remote on Android connects to this GentooPlayer Linux instance (for sure) but instead of going to the login site it says: “Unable to connect to the device. Please use the same WiFi network on both devices to make the connection possible".
Is it really the case that in the case of GentooPlayer both instances must be on the WiFi network? Because in the case of Ubuntu there is no such problem - Linux is on Ethernet, Android is on WiFi and everything works without a problem.

I see that no one has responded so far, probably not much people use AS on GentooPlayer installed on RBPi4.
And let it stay that way - because it might not work…

Hi @lwojtulewicz,

No, both instances don’t need to be on the WIFI network but they might be on the same Network.
Are you sure you have enabled Audirvana Studio on GentooPlayer?

Thanks for response.
Yes Aydirvana is enabled, as in the attached image. Android sees this Linux instance but Audirvana Remote does not connect to AS. The network is OK, another Audirvana installed on PC sees UPnP renderer enabled on this gentooPlayer. I wonder what the problem is? No firewall on tne Lan.

Check if the version of the remote is up-to-date, otherwise it won’t see Audirvana.

Good idea!!

Yes, is up-to-date. It was also reinstalled

Testing this problem on several phones, with different Android versions (including Android for Windows emulation), I see that AR does not connect to GentooPlayer only on Samsung Android 14 (16 was by mistake) One UI 6.0 and 6.1.
I don’t know what’s the reason - maybe some setting on Android 14 or maybe the fact that there are so many “if” in AR that maybe one of them inadvertently blocks the connection to GP on Android 14?
This is such a niche issue that I will end the topic here and thank everyone for their help.

But maybe @Damien will take a look at it in his free time?

Maybe it’s related to Android 16. We do not have a phone with it to try it out. Have you asked on the Gentooplayer forum if others users get the same behavior as yours?

Sorry - of course Android 14; 16 was by mistake.
Runs OK on 12 and 9

I talked directly with the author of the software but he was unable to generate this error - he probably doesn’t have Samsung Android 14

By the way - Could AR not check WiFi if the phone is connected to the network with an Ethernet cable?

Hi see, anyway, we are on the same case, we do not have an Android 14 phone but we plan to have one for such cases.

Can you please describe your scenario? You would like to connect to ethernet a smartphone and use it with the Remote?

In order to exclude the possible influence of WiFi on problems with AR communication with AS installed on the GP, I connected my Samsung Android 14 to the network using an Ethernet cable and turned off WiFi on the phone - but AR demanded that WiFi be turned on.

ATTENTION !
However, the problem does not only affect GentooPlayer - unfortunately AR on Android 14 does not communicate with AudioLinux either.
I’m more and more curious why?

Because of some Android 14 feature probably. Which is unrelated to GentooPlayer.

Yes, for sure. So it follows that this matter ought to be dealt with by Audirvan and not the Linux distros developers.
We move the chair to the piano, not the other way around :wink:

If the chair is Linux and the piano is Audirvana, which one should move? :joy:

And if Grandma stood on her head, it would be a piggy bank… :rofl: :joy: :rofl: :joy:

:scream: :rofl: :rofl: :rofl: