Cannot switch off shuffle

I am on v 3.5.50 for Mac, and I cannot seem to toggle off shuffle on a playlist. It doesn’t seem to matter whether the interlaced arrow symbol is white or dark, the songs always play in a random order. I’d like the playlist to start and the beginning and proceed in the order the songs are listed in. Thanks!

Is this a Smart Playlist or Manual? If the latter you have additional options to set and apply the actual order of the view and order of play when you are viewing in track view.