Direct Mode enable in macOS High Sierra

maybe katsu will read all that tomorrow or today and might give you clues as he wrote the thing first…


OK, I think I MIGHT know what’s wrong. The unzipped Repair Permissions file I downloaded and used was from this link: …

It was not from this link:

I just dowloaded the link from the firewolf link and it gave me a totally different file that looks like the one you had in your photo. It is a Unix executable file (black with the green “exec” on it). The other file I downloaded from your dropbox and used was a zip-file (Repair Permissions 3.7.2320). Do you think that s the problem? Am I supposed to use the exec file and not the zip-file?

Man! yes you have to unzip it, not put the .zip in the bin…

the good working link is in page 2 here…

you unzipped what you downloaded and there you have 3 files… the text the .ktext extension and the repairpermissions soft that you have to unzip to put in the bin as written in the text…

Arrrrrrrrggggggghhhhhhh!! I am SUCH a dork!!! I don’t know WHY, but… The instructions say, “Then put the unzipped file of Repair Permissions in that folder.” My mind kept reading it as, “keep the file unzipped, as in…don’t unzip it!” I have no idea why I kept reading/interpreting it that way??? Ugh. OK, I got this now. So sorry to waste all your (and my) time! Really, truly I am. !@#$%^&*

Thanks a million times over!

so it worked? :slight_smile:

Yep! Just finished re-doing everything and it sounds great! Nothing like spending 5 hours on something that should have taken 15 minutes to accomplish. Man do I feel dumb. Dumb, but…satisfied. Thanks yet again for all the help! Have an excellent rest of the weekend! Time for a drink…


Blow your mind with some Zappa, like The Grand Wazoo :slight_smile:

Good idea! Actually, the new 8 CD Roxy set just appeared on TIDAL. Think I’ll dig into that for a while. ; )

Of course NOW…A+ is not working! !@#$%^&* Worked fine at first. Switched from TIDAL to my library and then back and then…TIDAL won’t play. Switched back to my library and it won’t play either. Both stuck on, “Loading first track…” Quit A+ and restarted and same deal: “Loading first track…”

Guess I’m gonna call it a night and try again tomorrow. Argh!

Try to make it simple since you succeeded for the Direct mode at last…
I can’t remember that error: first song loading… might be the SysOpt not well installed at first…

Start fresh A+ by deleting those files…

If you have Playlists that are important export them first to desktop and
save them in a folder… when A+ is reset, you can re-import them back.
sadly to this day, the folders they were in is not back, you have to do it again…
Importing can be done with capital key but exporting is done one by one till now.

Before doing this, maybe you should not connect after deleting those files to Roon, Tidal or others…
Install A+ alone with your database…

Apple hide the Home Folder in User Library at some time depending on OS System… When you have clicked your Home Folder, and cannot see the Library Folder in there, just do a ‘‘cmd J’’ to show the folder settings preferences and see at the bottom… click Show Library Folder and then you’ll have access to the rest forever.

Starting for new A+:
Go to the Main Library Folder… PrivilegedHelperTools folder…
Trash All the files in that folder from A+ (that folder install SysOptimizer)
Go to the Main Library Folder… LaunchDaemons Folder…
Trash All the files in that folder from A+ (SystemOptimizer and prefs files)
Go to User… Home Folder… Library… Applications Support… Audirvana Folder…
Trash All the files in that folder (that is your database of music, back it up!)
Go to User… Home Folder… Library… Preferences…
trash com.audirvana.Audirvana-Plus.plist in that folder (those are A+ software preferences)
Go to User… Home Folder… Library… Caches… com.audirvana.Audirvana-Plus
trash the files of A+ in that folder.

Restart MAC. This will reset pretty much Audirvana like new.

When choosing library at first it will sync in top right main window under the logo…
LET IT GO, even better don’t try to adjust windows or edit files, even playing music
while it is not finished… you’ll see the progress bar going… Could be long the first time
depending on how large your library is, and MAC is fast or not…

When loading go to prefs panel and put your preferences, then try to play a song after your library is fully finish scanning, system optimizer will be installed on first time playing. If it works, and you see Direct Mode on also, quit A+. Restart Mac, that will seal all your preferences and library as a working soft. You can also go in A+ Menu: File… Library… Optimize Database there, do the 3 steps even if the last says it’s long, it’s not that long. Then again Quit A+ after. Since your databse will be new you don’t have maybe to do the 3 steps but why not, take five mins for me.

After that, you go to the Database Music folder and A+ preferences files on the Mac as written up there and copy those two files somewhere else on your MAC in a folder and name it like the today date… That will be your good saved state of A+ music and prefs. I do that everyday when i add music to it or change my prefs. If something wrong happen, i just put back those last 2 files in their place and i’m back like new.

After all that and still working good, try Tidal or others. if it fucks again you can just put back your database and prefs in place and restart Mac and stay with your library :slight_smile:

Thanks for the advice. I will try that if the problem continues. Saving the prefs everyday is a good idea too! I wound up getting things to work late last night. It was strange. My DAC stopped being recognized by my Mac. When I plug in the USB cord it is supposed to say, “USB Ready” on the screen of the DAC, but it would only say, “USB.” I tried resetting the DAC to factory default, etc. but no luck. I finally wound up switching USB ports on the Mac and that did the trick. No idea why it just stopped working. It happened to me once before but I just unplugged the cord a few times and plugged it back into the same port and it worked. This time I switched USB ports and I plugged my external drive (that contains my music library) into the port I usually have my DAC plugged into and all was well. Frustrating, but…hopefully the port I have the DAC in now won’t crap out on me…or the one I have the drive plugged into! If either port stops working correctly for both devices that’ll be a big problem! Anyway, thanks yet again for all the advice and help! Oh, and I listened to some of that FZ Roxy set last night. Amazing! Love that band!

But it’s a pity that it wasn’t nearest one…

I am struggling to understand what is going on with HS and A+3 Direct Mode. When I bought A+3 earlier this month on the 8th. I was already running which I had installed in December. I had Direct mode and choice of integer modes and I elected to use integer mode 1 provisionally and then to try mode 2 after a few days. After taking up the Tidal free trial on the 14th I noticed a distinct fall off in SQ generally. I decided that because I was not enjoying the (library) music so much as I had at time of purchase I should try integer mode 2 but it and Direct Mode had gone. There had been no OS updates in the period since acquiring A+3. The only thing which I had done were the Tidal sign up and played some DSD files (which my DAC claimed not to be able to play) but I do not see how these could have any bearing on the disappearance of Direct Mode. I am tearing what remains of my hair out.

I should add that I have since updated to 10.13.3 x2 in the hope that Direct Mode might return but it has not.

Hey there,

So…I followed all the above instructions but I am still getting the “Loading first track…” issue where after A+ says, “Stopping audio device” and gives me an “Error starting device playback.” This happens whenever I try to play a new album or song after listening to an initial album or song. The workaround is to unplug and re-plug in my DAC. That resets things and I am able to select and play a different album or song. It works, but it is not an ideal solution. I would love to find a permanent solution to the problem. Any more ideas or suggestions would be most welcomed. Thanks!

are the terminal commands for the workaround in high sierra the same as in sierra??


the commands itself are the same but the text as changed a bit and the repair permissions thing is completely different.

Just give a second to the Download button to appear

High Sierra Link:

Sierra Link:

Hello RunHomeSlow

Did you experienced that after the whole operation Direct Mode came up but after restarting A+ it disappeared hehehe :smiley: ?

Greetings from Denmark :slight_smile:

This high sierra should works has it as always did. We are now with catalina and before mojave, they all works… but after a mac system update, you will need to redo the hack, maybe that what happen to you ?