Enable USB Power Save mode for external USB DAC

Hi guys,

Not sure if someone has a similar problem as I do. I am using a Windows 10 HTPC (always on) with FTP server installed (that’s why it’s always on) connecting to a Pro-ject Pre Box S2 Digital USB DAC via Audirvana, remotely controlled by Audirvana Remote app with my iPhone/iPad. The problem is my DAC does not come with a power button. Means as long as the USB port is powered up (my case), it will not shut down which makes me feel bad. Since I can’t put my PC into S3 sleep mode due to the FTP server, I do not have any solution but unplugging my DAC which is extremely stupid. Does anyone has a good suggestion? Even if I remove FTP server and put the PC in S3 mode, there is no way for my wife to use Audirvana app to wake up the PC and play music. Need some help here! Much appreciated!


Stop feeling bad. Problem solved.

You can buy an USB adapter with a switch.

1 Like

Sure, if not feeling bad isn’t enough… A variation of that idea, I have one of these in use (and another without switches), compatibility and build quality are very good.

Thats an Acasis HS-080 (gray) 4-port switched USB3.0 type A hub, if the link dies.

1 Like

Thank you guys! That would work! Will go grab one today.

Just wanna share. I had an idea yesterday to “shield” the +5V in USB by covering pin 1 and use a +5V linear power supply to control the on/off as Pre Box S2 Digital offers a micro-USB port for +5V input power supply. Unfortunately the experiment was a failure as the DAC refused to recognize USB signal if it didn’t come with a +5V. Seems external USB power switch is my best option :sweat_smile:

Thank you guys for the great suggestions. I finally bought a USB Hub with individual power switch for each port and it works like a charm. The only problem I had was keeping Audirvana on and turning the DAC off would cause some problem when turned it back again. Audirvana showed an error message something like “Failed to change to integer mode.” After switching to WASAPI from ASIO everything works seamlessly. And I am able to stream 44.1kHz to DSD256 including MQA 352.8kHz so I’m happy now. :grin:

Couldn’t really tell the difference between WASAPI and ASIO. May be it’s just my ears.