Kernel Streaming won't output from headphones on Bootcamp

I have a lightning-fast Bootcamp Windows 10 installation and I’ve never run into any compatibility issues with it before now.

However, I’m having a problem with Audirvāna Origin (& Studio), where whenever I try to use Kernel Streaming with my headphones plugged in, the output only plays from my Mac speakers instead of outputting sound from the headphones.

The output device is definitely selected as “Apple Audio Device (Headphones)” but it still plays from the speakers anyway. I’ve tried changing the output device in Audirvāna and rebooting the program a bunch of times, but to no success.

My headphones are set as the default audio device on my computer, yet Kernel Streaming seems to default to my speakers and I don’t know how I can change it. I tried disabling the Speaker device on my computer, which made the headphones the only output device able to be selected in Audirvāna, but even then it still played through the speakers.

I don’t have an external DAC yet, but maybe when I get one it will fix the problem?
In the meantime, here is my debug info:


Audirvana Origin 1.0.2 (10002)

Windows 10 (19044) with 8GB physical RAM

Connected account of : 11111


Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

r8brain not in use
r8brain filter parameters
Bandwidth = 99.5%
Stop band attenuation 218dB
Phase linear

Max allowed volume: 100
Replay Gain: None
SW volume control: ON

Sync list: 1 folders
AUTO: C:\Users\11111\Desktop\11111
Library database path: C:\Users\11111\AppData\Local\Audirvana\Audirvana\AudirvanaDatabase.sqlite

Remote Control server:
Listening on on port 49762

=================== AUDIO DEVICE ========================

Max. memory for audio buffers: 2544MB

Local Audio Engine: Kernel Streaming

Preferred device:
Headphones (Apple Audio Device)
Model UID:PCI\VEN_106B&DEV_1803&SUBSYS_1885106B&REV_01

Currently playing in Integer Mode:
Device: 2ch 16bits Integer, 4 bytes per frame 48kHz

Active Sample Rate: 48kHz

Bridge settings:
Sample rate limitation: none
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:
Local audio device
Headphones (Apple Audio Device)
Manufacturer: Apple Inc.
Model Name: Unknown manufacturer
Model UID: PCI\VEN_106B&DEV_1803&SUBSYS_1885106B&REV_01
UID: \?\SWD#MMDEVAPI#{}.{636ca00c-3c08-453b-9959-cc30d7acae49}#{e6327cad-dcec-4949-ae8a-991e976a79d2}
Kernel Streaming capable

1 available sample rates up to 48000Hz
Volume Control
Physical: No
Virtual: No
MQA capability
Auto-detect MQA devices: Yes
Not a MQA device, user set to not MQA
DSD capability: Unhandled
Device audio channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: No

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1
2 ch Integer PCM 16bit little endian 48kHz

Local devices found : 2
Device #0: Speakers (Apple Audio Device) Manufacturer: Apple Inc. Model UID: PCI\VEN_106B&DEV_1803&SUBSYS_1885106B&REV_01 UID: \?\SWD#MMDEVAPI#{}.{bbd4ff2a-7cc9-4d3e-bbbf-b04c8aeaa412}#{e6327cad-dcec-4949-ae8a-991e976a79d2} Model Name: Unknown manufacturer
Device #1: Headphones (Apple Audio Device) Manufacturer: Apple Inc. Model UID: PCI\VEN_106B&DEV_1803&SUBSYS_1885106B&REV_01 UID: \?\SWD#MMDEVAPI#{}.{636ca00c-3c08-453b-9959-cc30d7acae49}#{e6327cad-dcec-4949-ae8a-991e976a79d2} Model Name: Unknown manufacturer

UPnP devices found : 0

WASAPI sounds fantastic and plays perfectly fine, but I would like to give Kernel Streaming a shot, so I’m hoping someone can give some advice. Thanks!