Lack of song start when playing, No gapless playback between songs

Hi, I am using the trial version of audirvana origin in Japan, and I am thinking of purchasing the official version, but I have found two problems.

One is that when playing a song from a stand alone, less than a second or so of the beginning is missing. I felt that this is a problem that other players do not have, where you have to press the back button all the way down to play the song from the beginning.

Another problem is that when playing live music, there are no pauses between songs, and the music plays one after another, but this is also not a good thing, as the end of the song is missing or the beginning is interrupted.

In my environment, all the music data is stored and played on the local PC, so it should not have the same problem as network playback, but I am experiencing the same kind of trouble.

I have searched the forums and found that gapless playback is often mentioned, but no concrete answers or suggestions for improvement have been provided, which makes me worry. I don’t think it is possible that it is technically impossible.

I think it might be a specification of the software, because it does not improve even if I set WASAPI, ASIO, or Kernel Streaming. Other playback software such as hqplayer and foobar2000 have no problem at all, so I don’t think there is a problem with my hardware environment.

Even Windows Media Player, which is already more than 20 years old, can playback normally, so I would like to purchase this software if you can improve it.

I am using Topping U90 USB Bridge.
Driver version is 5.45.

Audirvana Origin 1.0.6 (10006)

Windows 11 (22000) with 192GB physical RAM
(Xeon W-3175X / SR-3 DARK)

Connected account of : -


Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

SoX not in use
SoX filter parameters
Bandwidth at 0dB = 99.5%
Filter max length = 30000
Anti-aliasing = 100
Phase = 66%

Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

Sync list: 1 folders
AUTO: G:\Users-\Music
Library database path: C:\Users-\AppData\Local\Audirvana\Audirvana\AudirvanaDatabase.sqlite

Remote Control server:
Listening on - on port -

=================== AUDIO DEVICE ========================

Max. memory for audio buffers: 87002MB

Local Audio Engine: ASIO ASIO 2 driver version 1325

Preferred device:

Model UID:

Active Sample Rate: 44.1kHz

Bridge settings:
Sample rate limitation: 192kHz
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:
Local audio device
Topping USB Audio Device
Model Name: Topping USB Audio Device
Model UID: Topping USB Audio Device
UID: Topping USB Audio Device

14 available sample rates up to 22579200Hz
Volume Control
Physical: No
Virtual: No
MQA capability
Auto-detect MQA devices: Yes
Not a MQA device, user set to not MQA
DSD capability: Raw DSD (MSB)
Device audio channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: Yes

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1
2 ch Integer PCM 32bit little endian 44.1kHz
2 ch Integer PCM 32bit little endian 48kHz
2 ch Integer PCM 32bit little endian 88.2kHz
2 ch Integer PCM 32bit little endian 96kHz
2 ch Integer PCM 32bit little endian 176.4kHz
2 ch Integer PCM 32bit little endian 192kHz
2 ch Integer PCM 32bit little endian 352.8kHz
2 ch Integer PCM 32bit little endian 384kHz
2 ch Integer PCM 32bit little endian 705.6kHz
2 ch Integer PCM 32bit little endian 768kHz
2 ch DSD 8bit big endian in 8bit chunk 2822.4kHz
2 ch DSD 8bit big endian in 8bit chunk 5644.8kHz
2 ch DSD 8bit big endian in 8bit chunk 11289.6kHz
2 ch DSD 8bit big endian in 8bit chunk 22579.2kHz

Local devices found : 1
Device #0: Topping USB Audio Device Manufacturer: Model UID: Topping USB Audio Device UID: Topping USB Audio Device Model Name: Topping USB Audio Device

UPnP devices found : 1
Device #0RX-A3040 B66622 UID: uuid:5f9ec1b3-ed59-1900-4530-00a0deb66622 Location:

1 Like

Reduce the pre-load cache to 4000MB. Why are you running it on a machine with so much RAM. Is it a server?

Thanks for your reply, bitracer.

As I have noted a little, the Xeon W-3175X is a server CPU, but it is a desktop to handle, and you need at least 128GB of memory for 4K UHD RAW recording and editing. It have 32GB*6=192GB RAM loaded in my computer for the 6ch memory interface.

I tried lowering the buffer as you suggested, and while it improved slightly, it didn’t seem to change whether I minimized that part or increased it somewhat. It’s hard to tell.

I only have concerns about this part (gapless playback) since other playback software does not cause the problem. Other than that, the user interface and look is cool and beautiful. I like it.

Over USB and with upsampling disabled, it shouldn’t be a problem.

Thanks for your reply.

I’m trying to play music with the settings you mentioned. I can’t seem to get it to work. Of course, I am trying with a USB connection.

Other software does not have problems without changing the default settings, so I think the problem is specific to audirvana origin.

But that’s the extent of the problem at best, and it generally meets my expectations, except for the listening of the live album.

I’ll be thinking about it patiently after the trial period of the software.

Thank you :slight_smile:

Hello @tsukimihime,

Do you have this issue if you use WASAPI instead of ASIO?

Hello Antoine. Thank you for your reply.

As I noted in my first sentence, neither WASAPI/ASIO/Kernel Streaming is allowed.

When playing a music, less than 1 second of the beginning is missing. When the song ends and the next song loads, less than a second is missing at the end, and when it starts, less than a second is missing at the beginning.

I get the impression that there is some kind of problem with loading songs. I feel that this is a player-specific problem, as it does not improve whether the buffer is increased or shortened. There is no improvement when I turn On/Off the “Use large buffer” checkbox inside the options.

I hate to say it, but this symptom does not occur at all with other music playing software. Of course, this is the default setting for all software.

1 Like

Very strange that your playback issues mirror the problems that UPNP Ethernet users have myself included. Your USB port is direct from the motherboard? The gapless failure ruining many albums not just live ones, Dark Side Of The Moon is a good test.

Good luck with it :+1:t2:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.