Library still exist (File is there) but appears empty

I do not understand what’s happening here. I let my Mac Mini having a rest during an entire day and when I woke it up, Audirvana was up and running but show NO album, NO track, nothing.
I checked in the library directory: file was there.
Performed maintenance on the DB: OK was reported by the tool.
Restarted Audirvana and will see what happens.

Not very reliable this DB…

Ok, so, without any reply, I reply to me.
I noticed that multiple SMB errors are reported in the console (Not that surprised as SMB is MS):
smb2fs_smb_cmpd_query_async_parse: smb2_smb_parse_create failed
I found a post somewhere where the proposed solution consisted in removing some file extended attributes that were put by the finder.
I did it, at least on some files because of the accented characters in file names for others, but to no avail apparently.
Audirvana is up an running and tries to rebuild the library whose size is stuck at 256K.

I cannot explain this sudden occurence of the problem as nothing has been done neither on Audirvana side nor on the Synology.
But using something coming from MS is ALWAYS a source of many problems.

Again, a self reply.
I managed to retrieve the old DB from the time machine backup. it seems to work.
BUT, although I was pretty sure to have the option “Sync network volumes at startup”, Audirvana restarted the whole process, which I stopped and ensure that the option is OFF.
So, now, I’m back with an old DB, facing the impossibility to sync any more I guess.
And I still have the problem with files on my NAS provoking SMB errors, most probably due to problems with character encoding when using accents.
AFAIK, there is no log file produced by Audirvana that could help to understand how those errors are managed.

Yet another self reply.
For unknown reasons, Audirvana decided on its own to restart the sync process.
Good news: it stopped after a reasonable amount of time! Bad news: some recently copied files did not appear, when they can be played by Audirvana if moved manually to the playlist.
I decided to restart the sync process (with a risk to loose everything in my library). It’s running.
Strange thing: Audirvana says “synchronisation” and not “synchronisation de Audio” (Audio being the name of the directory). Let’s see what happen.

Another thing to mention: SMB parsing errors do not seem to be related to Audirvana. It could be an asynchronous activity started by OSX kernel.

But once again, without any log from Audirvana, it’s hard to guess what happens…

And another self reply! Support is lagging here…
I managed to retrieve my music and to make a successful import of new titles. But Audirvana restarted the whole process, which I interrupted this morning after it seems it cannot fully end.
I was expecting to try putting in my smb.conf something related to the character code to be used, until I discover that the SMB server was already configured that way.
On the client side (Mac) as I do not see any smb.conf file I cannot check what is the character encoding used. I even do not know how I can change it on the client side.
What is sure, is that there is a problem somewhere with accented characters that are shown in the result of an “ls” command on the terminal but sometimes are not visible on the finder (file does not appear).
What is even much more strange is that:

  • I have a file that was on error by SMB
  • I could see the file in the finder
  • I tried to replace the character “ê” by retyping it: could do it but the file was not accepted by Audirvana
  • I tried to remove the accented character and I got an error 43, meaning the file was not existing
  • The file could not be visible anymore in the finder
  • But the file appears in the result of an ls command on terminal.
    Still digging on the issue.

Interesting, nobody from Audirvana support is able to help! In the good old industry, when you have an issue with the product you paid for, somebody was there to help. With the new approach initiated by MS, only basic support was proposed but forums and any other forms of help were available. Now, it’s turning to almost nothing.
Anyway, Audirvana is up and running, performing “Synchronisation” since 9AM this morning. No message, no warning, no info on what the hell the app is doing.

Ah, sorry, something I forgot: Audirvana is eating 70% of my CPU on a very recent (bought last month on purpose) Mac Mini.
70% for doing what??? I do not know.

Hi patifr,

You need to find somebody with IT knowledge to help you. Your issue is very specific to your setup.

It looks like your issue is NAS related. What you can try is to copy the library locally and import is from there. Just to verify that it’s not Audirvana issue.

It could very well be that Audirvana is choking on some special character. It should not, but it’s possible.

My setup is very similar to yours and it works without problems.

Hi bitracer,
Thanks for your message.
There are indeed problems related to my NAS setup with files containing accented characters that are not properly encoded and not accepted by the MAC.
But, there are things that are related to Audirvana itself:

  • Why is it that the library appeared suddenly empty when the DB was still at 3.2GB?
  • What the hell Audirvana is doing when eating 70% of the CPU and showing no progress in the sync activities (Mine is running for 24h now and still no progress)?
  • Is it possible to activate any debug mode able to produce some kind of log from Audirvana?

Here are my questions, but I’m not sure I will get an answer.
On my side I will dig in the issue of accented characters but knowing SMB is a MS piece of crap, I doubt I will find a clear reply.

I wouldn’t read too much into this. Resolve first your issue. The other issues might go away.

My setup is very similar and I have no issues. Your experience should not be different from mine.

Hello @patifr, Can you send me a copy of the “Debug Info”? You can get it in Audirvana Settings>General>Debug Info

Note: By clicking on the Debug Info Audirvana button automatically copies all its content, all you have to do is paste it in response to this message.

Also, if you are interested by looking into logs of Audirvana, there is some of them, i can send you the path to find them in a private message.

I am wondering, where your database is located? Did you changed his location to put it in your Synology NAS?

Hi Damien,
Thanks for helping.
Today I managed to clean-up a bit my directory on the NAS (5140 Albums… I need to stop accumulating).
What I discovered:

  • Some files were duplicated, and one of them was empty: I removed the copy.
  • Trash bin was activated on my NAS and a directory called #Recycle had been created and contained audio files that were most probably used by Audirvana when syncing.
  • Several file names contained character encoded in ways that cannot be used by SMB properly: I corrected some of them (Still 100 to process)

Finally, and this is good news, I managed to restart Audirvana and it seems to be able to recreate the DB from scratch. So far so good.

Anyway, here is the “Debug info” and I’m indeed interested to get access to the Audirvana log to better understand what is happening when strange file names (with accented characters using encoding not fully supported by SMB) are encountered. I think they are ignored as they cannot be retrieved through the SMB protocol.

Audirvana Mac Version 3.5.33 (3563)
macOS 10.15.3 with 16384MB RAM

Licence enregistrée pour Conquet Eric


Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

SoX not in use
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000
Anti-aliasing = 100
Phase = 66

Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

Sync list: 1 folders
AUTO: /Volumes/Audio/
iTunes/Music library synchronization: not synchronized
Library database path: /Users/eric/Library/Application Support/Audirvana/AudirvanaPlusDatabaseV2.sqlite


=================== AUDIO DEVICE ========================

Preferred device: UpMpd_TotalDac Model UID:JF Light Industries UpMpd_TotalDac UID:uuid:f88bf027-d2c5-e810-3750-d063b40157c5

Selected device:
UPnP device at
ID 0x0 UpMpd_TotalDac Manufacturer:JF Light Industries
Model UID:JF Light Industries UpMpd_TotalDac UID:uuid:f88bf027-d2c5-e810-3750-d063b40157c5

6 available sample rates up to 192000Hz
Volume control: No
MQA capability
Auto-detect MQA devices: No
Not a MQA device, user set to not MQA
DSD capability: Raw DSD (MSB)
Device audio channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1
UPnP/DLNA supported protocols:
DLNA 1.5: No
Gapless playback: Yes
Missing events workaround: No
Can play native DSD: Yes
Number of channels: 2
Use as stereo device only: No

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1

Stream ID 0x0 0 channels starting at 0
14 virtual formats:
2 ch Non-mixable linear PCM Interleaved 16 little endian Signed Integer 44.1kHz
2 ch Non-mixable linear PCM Interleaved 24 little endian Signed Integer 44.1kHz
2 ch Non-mixable linear PCM Interleaved 16 little endian Signed Integer 88.2kHz
2 ch Non-mixable linear PCM Interleaved 24 little endian Signed Integer 88.2kHz
2 ch Non-mixable linear PCM Interleaved 16 little endian Signed Integer 176.4kHz
2 ch Non-mixable linear PCM Interleaved 24 little endian Signed Integer 176.4kHz
2 ch Non-mixable linear PCM Interleaved 16 little endian Signed Integer 48kHz
2 ch Non-mixable linear PCM Interleaved 24 little endian Signed Integer 48kHz
2 ch Non-mixable linear PCM Interleaved 16 little endian Signed Integer 96kHz
2 ch Non-mixable linear PCM Interleaved 24 little endian Signed Integer 96kHz
2 ch Non-mixable linear PCM Interleaved 16 little endian Signed Integer 192kHz
2 ch Non-mixable linear PCM Interleaved 24 little endian Signed Integer 192kHz
2 ch Non-mixable linear PCM Interleaved 8 little endian Signed Integer 2822.4kHz
2 ch Non-mixable linear PCM Interleaved 8 little endian Signed Integer 5644.8kHz

0 physical formats

Current device transportInfo:
CurrentTransportState: STOPPED
CurrentTransportStatus: OK
CurrentSpeed: 1
Current device MediaInfo:
NrTracks: 1
MediaDuration: 00:00:00
PlayMedium: NONE

Current device AVT service description:

<?xml version="1.0"?> 1 0 TransportState no string STOPPED PLAYING TransportStatus no string OK ERROR_OCCURRED PlaybackStorageMedium no string PossiblePlaybackStorageMedia no string RecordStorageMedium no string PossibleRecordStorageMedia no string CurrentPlayMode no string NORMAL SHUFFLE REPEAT_ONE REPEAT_ALL RANDOM DIRECT_1 NORMAL TransportPlaySpeed no string 1 no RecordMediumWriteStatus string CurrentRecordQualityMode no string PossibleRecordQualityModes no string NumberOfTracks no ui4 0 2000 1 CurrentTrack no ui4 0 2000 1 CurrentTrackDuration no string CurrentMediaDuration no string CurrentTrackMetaData no string CurrentTrackURI no string AVTransportURI no string AVTransportURIMetaData no string NextAVTransportURI no string NextAVTransportURIMetaData no string RelativeTimePosition no string AbsoluteTimePosition no string RelativeCounterPosition no i4 AbsoluteCounterPosition no i4 CurrentTransportActions no string LastChange yes string A_ARG_TYPE_SeekMode no string ABS_TIME REL_TIME A_ARG_TYPE_SeekTarget no string A_ARG_TYPE_InstanceID no ui4 SetAVTransportURI InstanceID in A_ARG_TYPE_InstanceID CurrentURI in AVTransportURI CurrentURIMetaData in AVTransportURIMetaData SetNextAVTransportURI InstanceID in A_ARG_TYPE_InstanceID NextURI in NextAVTransportURI NextURIMetaData in NextAVTransportURIMetaData GetMediaInfo InstanceID in A_ARG_TYPE_InstanceID NrTracks out NumberOfTracks MediaDuration out CurrentMediaDuration CurrentURI out AVTransportURI CurrentURIMetaData out AVTransportURIMetaData NextURI out NextAVTransportURI NextURIMetaData out NextAVTransportURIMetaData PlayMedium out PlaybackStorageMedium RecordMedium out RecordStorageMedium WriteStatus out RecordMediumWriteStatus GetTransportInfo InstanceID in A_ARG_TYPE_InstanceID CurrentTransportState out TransportState CurrentTransportStatus out TransportStatus CurrentSpeed out TransportPlaySpeed GetPositionInfo InstanceID in A_ARG_TYPE_InstanceID Track out CurrentTrack TrackDuration out CurrentTrackDuration TrackMetaData out CurrentTrackMetaData TrackURI out CurrentTrackURI RelTime out RelativeTimePosition AbsTime out AbsoluteTimePosition RelCount out RelativeCounterPosition AbsCount out AbsoluteCounterPosition GetDeviceCapabilities InstanceID in A_ARG_TYPE_InstanceID PlayMedia out PossiblePlaybackStorageMedia RecMedia out PossibleRecordStorageMedia RecQualityModes out PossibleRecordQualityModes GetTransportSettings InstanceID in A_ARG_TYPE_InstanceID PlayMode out CurrentPlayMode RecQualityMode out CurrentRecordQualityMode Stop InstanceID in A_ARG_TYPE_InstanceID Play InstanceID in A_ARG_TYPE_InstanceID Speed in TransportPlaySpeed Pause InstanceID in A_ARG_TYPE_InstanceID Seek InstanceID in A_ARG_TYPE_InstanceID Unit in A_ARG_TYPE_SeekMode Target in A_ARG_TYPE_SeekTarget Next InstanceID in A_ARG_TYPE_InstanceID Previous InstanceID in A_ARG_TYPE_InstanceID SetPlayMode InstanceID in A_ARG_TYPE_InstanceID NewPlayMode in CurrentPlayMode GetCurrentTransportActions InstanceID in A_ARG_TYPE_InstanceID Actions out CurrentTransportActions

Current device RootDevice description:

<?xml version="1.0"?> 1 0 urn:schemas-upnp-org:device:MediaRenderer:1 UpMpd_TotalDac JF Light Industries UPnP front-end to MPD UpMPD 1.0 42 uuid:f88bf027-d2c5-e810-3750-d063b40157c5 urn:schemas-upnp-org:service:RenderingControl:1 urn:upnp-org:serviceId:RenderingControl /upmpd/RenderingControl.xml /ctl/RenderingControl /evt/RenderingControl urn:schemas-upnp-org:service:AVTransport:1 urn:upnp-org:serviceId:AVTransport /upmpd/AVTransport.xml /ctl/AVTransport /evt/AVTransport urn:schemas-upnp-org:service:ConnectionManager:1 urn:upnp-org:serviceId:ConnectionManager /upmpd/ConnectionManager.xml /ctl/ConnectionManager /evt/ConnectionManager urn:av-openhome-org:service:Product:2 urn:av-openhome-org:serviceId:Product /upmpd/OHProduct.xml /ctl/OHProduct /evt/OHProduct urn:av-openhome-org:service:Info:1 urn:av-openhome-org:serviceId:Info /upmpd/OHInfo.xml /ctl/OHInfo /evt/OHInfo urn:av-openhome-org:service:Time:1 urn:av-openhome-org:serviceId:Time /upmpd/OHTime.xml /ctl/OHTime /evt/OHTime urn:av-openhome-org:service:Volume:1 urn:av-openhome-org:serviceId:Volume /upmpd/OHVolume.xml /ctl/OHVolume /evt/OHVolume urn:av-openhome-org:service:Playlist:1 urn:av-openhome-org:serviceId:Playlist /upmpd/OHPlaylist.xml /ctl/OHPlaylist /evt/OHPlaylist urn:av-openhome-org:service:Radio:1 urn:av-openhome-org:serviceId:Radio /upmpd/OHRadio.xml /ctl/OHRadio /evt/OHRadio urn:av-openhome-org:service:Credentials:1 urn:av-openhome-org:serviceId:Credentials /upmpd/OHCredentials.xml /ctl/OHCredentials /evt/OHCredentials /upmpd/presentation.html

UPnP devices found : 3
Device #0: ID 0x0 CRX-N560 84BA0 UID: uuid:5f9ec1b3-ed59-1900-4530-00a0dea84ba0 Location:
Device #1: ID 0x0 UpMpd_TotalDac UID: uuid:f88bf027-d2c5-e810-3750-d063b40157c5 Location:
Device #2: ID 0x0 Marantz NA-11S1 UID: uuid:5f9ec1b3-ff59-19bb-8530-0006781a09a1 Location:

CoreAudio audio path, buffer I/O frame size: 0

Max. memory for audio buffers: 13312MB

Local Audio Engine:
Exclusive access: Enabled
Integer mode: Enabled

Local devices found : 1
Device #0: ID 0x47 Haut-parleurs Mac mini Manufacturer: Apple Inc. Model UID: Speaker UID: BuiltInSpeakerDevice

Oops, sorry I forgot to mention that I emptied the trash and disabled it on the Syno.

And, by the way, I still have this strange display showing: 3189 Albums, 47520 pistes and 4995j and 15h.
I’m sure there is an error in the way those things are computed. Usually one album is around 1 hour of listening time.

And, by the way, the problem I have with Samba is due to the use of different encoding schemes for the same character, “é” in French, or “ü” with Umlaut in German.
If somebody knows a trick, or better a tool, to automatically detect and correct those file names, I will be his or her first fan forever :wink:

Good news! Syncing is now completed and I have access to 5054 albums!
Still some file names to be changed to get rid of those bloody accents and everything is fine.
In the near future, before adding files to my NAS I will pay attention to the way the file names are encoded. I will maybe give a try with Audirvana and if the files can be played then I will give them the authorisation to enter the DB. Nowadays we are used to have authorisations to go outside :wink:

When done, don’t forget to close Audirvana and copy the .sqlite file and put it somewhere for a backup as todays date :grinning:

At least you’ll have enough time to sort out your music library. :slight_smile:

Yes, thanks for the advice. I have regular backups using Time Machine, so the DB is preserved and can be restored when needed.

That’s true… Or almost true as I am teleworking and sometimes you work more (and even better) than at the office.

Bonjour Damien,
Je ne sais pas si vous l’avez vu mais j’ai répondu à votre message. Je n’ai pas utilisé le bouton Reply, désolé…