Missing Albums from my library

You mean for Audirvana? Instead of each directory map to the root containing them all?

I’ll try that.

Yes, that’s what I meant exactly.

OK, I tried it this way:


And this way:


My results were the same, same folders missing.

Then Audirvana doesn’t like some characters either in filenames or metadata.

Is there a list of these characters?

I don’t know of any special characters that are being used in those folders names or files.

I’m currently looking at two artists that have missing folders. I feel safe to say that I’ll find more. I haven’t gone through my total library; that would be a time consumer. Plus, I shouldn’t have to.

There were a couple of folders that I reconverted the files; moved out of the tree structure and then back; rewrote the filenames to include artist name and they were then recognized. I didn’t change folder name or any metadata. There were also folders I did this to that still failed to be included in the library.

As I visually look through my data and compare to what was successfully scanned I come up with more instances of missed folders.

By existing threads I’ve seen here this isn’t a new issue. I’m willing to work closely with support to help identify why this is happening but only with a defined method of research. I don’t want a “try this” or “try that” method. Tell me specifically what to try and why - let me know what’s being looked for. Give me some insight into what the scanner is doing.

Check this thread for hints:

OK. I have a complete backup on an external drive of my NAS music from a few months ago. The folders I am having an issue with exists there too. I deleted the NAS music path from the Monitored Folders and added the Music path from the external drive. It found those folders (and others that I hadn’t identified yet I’m sure).

What’s my next course of action.

I’m running Windows 10.

My NAS is a ReadyNas RN314.

First update the NAS firmware to the very last version.

Find an external application to edit the metadata. Check the metadata album by album. Pay special attention to non English punctuation characters. Clear the empty fields. Add the albums one by one to the monitored folder hierarchy.

I updated to the latest firmware early this morning.

I use mp3tag:
I already checked the tags in those few folders that I’m currently aware of. They still do not appear in th library. I also reconverted them (dBpoweramp).

Going through all my folders one by one to see what’s missing will be a very large task. As I said before this is something I should not have to do. Obviously Roon and LMS are doing something to successively scan these folders that Audirvana is not.

However, I’m going to pick at the issue some more.

Is there anything here that can be changed?


Try with another metadata editor like Picard:

If that still doesn’t work, try adding just the folder and one track.

There must be something special in those albums, be it the cover art, metadata, filename or cue file.

I’ll check out Picard.

I’ll check for cue files. I normally delete them if they are there (except for ISO cue files).

I have come to the conclusion that the scanner has issues with the ReadyNAS. LMS & Roon do not. Heck, even the Foobar media library options find these folders!

I have to put this forward as a bug with Audirvana.

I’m not willing to expend the time to pound away at the folders the scanner has issues with. Let alone identify them. I did try the suggestion with Picard - that didn’t help. I have over 2500 folders. Even with our “stay at home” orders that’s not how I want to spend my time.

Joni Mitchel “Hejira” is one of the folders Audirvana has an issue with. As I said, Foobar finds it:

It’s too bad. Audirvana may have been a good fit for me.

Hello @moonloop,

I’m wondering, why you created shortcuts for your music files?

Which post from me are you referring to?

This one:

I had other directories in the music folder that I wasn’t including in the library. Actually, now I can reference just the music directory because I have since moved out what’s not included in the library. Just never changed it.

OK, check this out.

So, I was trying to get AN to recognize some failed (that I knew of) reads by reconverting flac, updating tags, clearing and updating tags, etc. Nothing changed.

I have the first and second albums by Jo Jo Gunne. The first was not being included in the library. Today I run AN, it goes though the scan at startup (I have this option turned on) and it finds the first one. Yay! But now the second one is not there.

How can this not be a bug with AN? I had already done a test by setting AN to read from a backup I have of my library on an easystore external drive and AN found all the ones that I was aware of that were missing. I switch AN back to read from my NAS and,nope, doesn’t find them. It’s a readynas RN314.

Guys, I am going to guess and say that AN has an issue with reading from the readynas rn314.

I am willing to help debug this issue but not by re-tagging, etc, etc, etc. It has to be something else that’s causing the issue.

[EDIT: I have just found that AN failed to include 9 of the 11 Tom Petty albums.]

Hello @moonloop,

Can you drag & drop one of those file in the play queue to see if you can play it or see the metadata of the file? Do you have some cue sheet file in the album folder?

Yes! Dragging to queue plays and shows the metadata including album art. I pulled all the files from the folder. Played and showed all with out issue. That’s interesting.

No cue sheet. Just the tracks and art.

Can you check the database integrity using the command in the Maintenance section of the preferences page?