MQA 16 bit 44,1 kHz super fast playback with integer mode on

Hi! Haven’t found such topic, so posting here.

I’m using Cayin n3Pro as DAC (MQA full decoder), MacBook Pro as source, Tidal connected. So everything works fine, I’ve disabled all filters etc, enabled integer mode and enjoyed hi-res MQA perfect apart from 1 issue:

  • with integer mode on , tracks from tidal which are sourced at 16 bit 44,1 kHz play super fast, only upsampling from 44,1 to 48 helps, but this kills MQA

  • with integer mode off everything seems to be working perfect

My question is this - disabling integer mode off will affect MQA unfolding or no? In my case, with integer both on and off DAC shows correct source signal (24/44,1 or 24/48 every time it’s MQA)

Thanks

Audirvana Mac Version 1.2.0 (10020)
macOS 11.4.0 with 8192MB RAM

Connected account: [email protected] (Maxim \ Malakhov)

SIGNAL PROCESSING:

Polarity Inversion:
	Globally: OFF
	Per track: OFF
Effects plugins NOT ACTIVE

UPSAMPLING:
SoX not in use
SoX filter parameters
Bandwidth at 0dB = 99.5%
Filter max length = 30000
Anti-aliasing = 100
Phase = 66%

AUDIO VOLUME:
Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

LIBRARY SETTINGS:
Sync list: 1 folders
AUTO: /Volumes/MUSIC/
iTunes/Music library synchronization: not synchronized
Library database path: /Users/maxim/Library/Application Support/Audirvana/AudirvanaDatabase.sqlite

Try to disable integer mode.

Are you certain MQA works properly with integer off?

Yes. I also have one device that behaves similarly.

What does integer mode do?

It’s essentially the way the device (DAC in this case) is addressed.

Sorry, didn’t quite understand that.
could you exsplain?

thanks.

It’s interfacing thing, some DACs don’t work or work erroneously when in integer mode. That’s why you have a toggle there. It influences how the data is sent to the DAC.

When possible, keep the integer mode on. If it doesn’t work, toggle the integer mode to off.

ok… got that.
thanks.