Newb - cant add lib and endpoint

Posted this on AS.

Trying out an eval of latest audirvana. Installed it on my Win10 laptop. All I want to do is add my library which resides on my NAS (for this example, with roughly 4200+ ablums). For the life of me I cannot find away to do this and have searched forums with no results as well as I see no help file to specifically talk about this? Maybe its my search criteria or whatever but anyway.

My NAS has many shares and I access the shares for other applications via IP:


The multimedia folder is the share point and can access it from win (e.g. mapped drive) and ubuntu (e.g. mount via SMB / cifs)

When I go into audirvana and select add folders, it comes up with the default windows dialog/explorer and I select the mapped drive I have on my laptop:


Nothing happens? I see no other way to hardcode this via smb, cifs or whatever. I never use windows “network neighborhood” or whatever to browse network

I can browse, add, delete files etc…on the NAS from on this mapped drive from my win explorer on laptop

Also, is the win version of audirvana able to stream to an endpoint (opticalRendu). The only audio option that comes up in the audirvana settings is the local laptop, which I don’t want. Is there a help file or something available that walks through all of this - I can’t find info on any of this.


Hello @foggie,

Have you tried to add your NAS as a network dirve?

If I understand your question, yes. In my orig statement, I indicated I have mapped drives from laptop to NAS (NAS has shared folders).

So on my Windows laptop (were I have audirvanna installed) if I look at my explorer I have several mapped drives to the NAS, one of them is to the music share on the NAS => M:\\Multimedia\

What is the NAS you are using? Is it a Synology?


If you are referring to browsing the network by name (the QNAP “hostname”) it doesn’t show which I’m sure there is some QNAP network setting that may resolve IP into hostname, but I never bothered with it since I have always mapped / accessed via IP.

FWIW - In my other audio players, roon, HQP etc… I have always used IP to lib path

Can you try to map your folder with the hostname instead of IP on this specific folder?

No not at the moment, it would appear name resolution isn’t resolving. Not sure if that is a nas setting or general network setting. I can look into that.

Is that the crux of the problem here and why audirvana won’t connect (e.g must have hostname)?

There was a setting on the nas networking area to enable as master browser and that did make the hostname appear through network browsing from office wkst but on my laptop (WiFi) in listening room, the hostname did not show up.

Fwiw, all the computers involved in this, whether wired and wireless are all on same network (vlan) and all can connect communicate with each other.

If hostname is absolutely needed the software to work I can look into further

Can you try to put the hostname for testing purpose?

Yes I will try that.

However, does it matter where audirvana is installed? Being I will ultimately send the audio stream to an endpoint, does it matter if audirvana is installed on my laptop or my high power server (server 2019 and then controlled from the iOS app?

You can install Audirvana on a Windows Server 2019 using this link:

I was able to get the nas hostname to work, and mapped a drive via the host name.

Audirvana saw / accepted the mapped drive for library, so that is now working.

Next item, how to get audirvana to see the endpoint? Nothing shows up in the speaker except the local audio sound card.

Endpoint is opticalRendu connected to DAC. I’ve enable mpd/dnla on the oR, saved and rebooted the oR several times. Are endpoints just supposed to show up / listed under speaker?

Hello @foggie,

Can you check the firewall settings: In Settings > Update and Security > Windows Security > Firewall and Network Protection > Allow an application through firewall, make sure that Audirvana is allowed to access the network.

I completely disabled all FW, antivirus etc… and also for the heck of it added a FW rule to allow the audirvana app as well as all IP ranges all traffic, nothing seems to work in so far as I see nothing available when I select the speaker icon?

Does the issue you have is on a Windows Server or Windows 10?

I installed audirvana on my laptop with win10 Pro

I didn’t install on my 2019 server (yet) as I don’t really want to mess with that server. I wanted to test out audirvana first.

I’m assuming the oR should be in upn/dnla mode

To be sure about that, do you have a android device that would run BubbleUPnP?

Unfortunately I do not

This could be a networking issue with the media (ethernet to optical) bridge, or some other networking problem if you run more complicated LAN setup.