No more UPnP

Hi there,
since today I can not use UPnP any more to send music from my NAS to my DAC. Audirvãna only offers Chromecast. As I do not know which service or device is offering the UPnP service, I am a bit lost where to start looking. I guess Audirvãna is only offering services that are made available from my computer or router?


Another self healing thing. I tried various things for the last three hours, including re-starting computer and all other devices, re-plugging cables, etc. Nothing worked, until now I unticked a not UPnP related check box in my router’s settings (using LAN port 5 as a WAN port), and UPnP is back.


There must be a UPnP/DLNA renderer/endpoint on the DAC end of things, so I wonder whether setting that port to LAN (as part of your home network) enabled the computer running Audirvāna to “see” that endpoint again?

1 Like

I never used that LAN port on my router and haven’t changed any settings on it for over a year now. Also there was no firmware update recently on any of my stuff and everything was running normal yesterday.

Another hick-up I guess - at least computers are humans too :slight_smile:

My DAC is in one of my pair of KEF speakers and I also would asume that the problem is with them. Especially because I sometimes have to unplug them from the power source to be able to play more than just one song from my music library.

I am aware of the flaws that the old UPnP protocol has, but as there is no other way to tell Audirvãna to send High res audio files from my NAS to my DAC, I have to use it.

1 Like

My wild guess, not being present, is that the router re-looked at the local network after you made the change and oh! - what have we here, a UPnP endpoint? Quelle surprise! :wink:


That wouldn’t surprise me. It propably doesn’t agree with my taste of music :grimacing:

1 Like

That’s interesting! A friend of mine lost UPnP access on his main network when he lost the Internet access: he was trying to understand why after 2 minutes max his DAC (Integrated into a Cabasse The Pearl Akoya) stops playing music. So, he rebooted the box/router and lost internet access.

And, interesting thing: the UPnP devices were not found by his PC through the router until he recovered the internet access.

But, on a backup network (using 5G) he was able to see the DAC and access it with UPnP.

1 Like

I don’t know much about which machine in a network is able to interfere with network protocols. I read a lot about UPnP, because it makes it vulnerable for access from “outside”, but I forgot most of it already. It is not what I am dealing with daily. My KEFs seem to have occasional problems with UPnP too.

I meanwhile might have found the real culprit of losing UPnP: My VPN. I re-installed it on that day but haven’t thought about it until today. If I find the time I will test this over the weekend.

(During the long hours of searching for my UPnP I really thought about switching to DAT and abandon my music server set-up.)

Home again, I just started Audirvãna - and UPnP was gone. I quit Audirvãna and then my VPN too and fired up Audirvãna - UPnP was back.

So, a bit uncomfortable, but easy to fix. :slight_smile:

1 Like

UPnP being a protocol on top of the network transport layer (TC/IP), it’s clear that it’s behaviour fully depends on how the lower layers are configured.
If you use a VPN for example, to access resources of your company, in most of the cases, you cannot access your local resources (I have the case on my side where my local printer cannot be reached when I’m connected to the network of my company using a VPN).
It’s certainly the same when you use an internet box without any connection to the WAN side (No internet connection). My guess is that UPnP requests in that case are not processed by the box/router even when UPnP is authorised by the box.
What could be interesting would be to track the UPnP traffic on the local network to better understand what really happens.


Thanks for the explanation! :+1:

What I understood when I looked for the problem was that my router is responsible for the main stuff, when it comes to UPnP. So I was looking there. It was actually a shower thought in a hotel room that made me think about the VPN.

Weird thing that I never had that problem before, although using VPN and Audirvãna for quite some time now in the same network.

I am not a technician and wouldn’t know how to track the UPnP traffic, let alone what to get from the information. I’m happy that I know the reason of the issue and how to work around it. This thread might help others with similar problems.

1 Like

There are means to capture any network traffic but they sometimes require a good knowledge of network protocols you would like to track.
Obviously, you can capture existing traffic but not the one which is blocked by the box/router, unless you are “spying” from the router, or configure your PC/MAC as a router.
There is this tool named “WireShark” that works on many different platforms and seems to be very powerful, provided you have a kind of “driving license”.


I can almost guarantee it’s the VPN

Me too :slight_smile:

The strange thing really is that I use this combination for over two years now and never had that experience before.

Interesting. Guess it depends what kind of VPN it is.
I know with my work vpn they tend to override my LAN dns settings so local name resolution is not working and UPNP discovery also breaks.
I think if I enable UPNP playback before connecting to VPN then it works.

That’s my workaround too. starting Audirvãna first and then the VPN :slight_smile:

Generally speaking UPnP is a end user convince layer and not a very secure thing…

I know about the flaws and security risks, which is propably why my VPN decided to block it. But, at the moment, there’s no alternative and the hope that no one is interested in my recipe collection.

1 Like

VPN doesn’t block UPNP intentionally.
It’s not what VPN is for. It just happens to mess with routing. Breaking UPNP is the side effect.