Oh boy, too much RAM!

Audirvana requires a lot of RAM memory!
I have a library of more than 200,000 titles, and 32 GB of RAM and when I open Audirvana, only Audirvana, I have almost no memory left!
Anyone experiencing this kind of problem?

Do you have upsampling enabled? Try to disable it.

I don’t know what you’re talking about.

Edit*** Okay, I’ve found it. Yes, it is disabled.

Audirvana run on nothing… cpu is idle for me at 80% to 90% while playing a song or CD loaded…
no upsampling, mac mini 2012, i5, 16gb ram. If i look at monitor it says less then 1gb memory.

You surely have a bug somewhere if you are not upsampling.
It as nothing to do with the larger the library is… i think (i have 42000 songs).

Try to do a library maintenance… The three steps… The third one for me takes 5 minutes…
so yes, will be longer for you, but not that long anyway… go to sleep if too long :slight_smile:

First if you, i’ll restart the mac,
open Audirvana,
do the three steps…
don’t play songs,
don’t edit tags… let i t go alone for the third step.

After it is done, close Audirvana. Restart mac again, yes i know…
try to make all things on your side to be sure :slight_smile:
restart Audirvana, and check again memory used if it changed.

I did that (thanks), so Etrecheck tells me that Audirvana take 4,9 GO…

Can you send me a copy of the “Debug Info”? You can get it in Audirvana Settings>General>Debug Info

Note: By clicking on the Debug Info button, Audirvana automatically copies all its content, all you have to do is paste it in response to this message

Audirvana Mac Version 3.5.25 (3555)
macOS 10.14.6 with 32768MB RAM


Polarity Inversion:
	Globally: OFF
	Per track: OFF
Effects plugins NOT ACTIVE

SoX not in use
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000
Anti-aliasing = 100
Phase = 66

Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

Sync list: 1 folders
AUTO: /Volumes/Sauvegarde5/Bibliothèque musicale
iTunes/Music library synchronization: not synchronized
Library database path: /Users/tupgss/Library/Application Support/Audirvana/AudirvanaPlusDatabaseV2.sqlite


=================== AUDIO DEVICE ========================

CoreAudio audio path, buffer I/O frame size: 512

Max. memory for audio buffers: 29696MB

Local Audio Engine:
Exclusive access: Disabled
Integer mode: Enabled

Preferred device:
Model UID:a12 1

Active Sample Rate: 44.1kHz
Hog Mode is off

Bridge settings:
Sample rate limitation: none
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:
Local audio device
ID 0x63 Sortie intégrée Manufacturer:Apple Inc.
Model UID:AppleHDA:16 UID:AppleHDAEngineOutput:1F,3,0,1,1:0

3 available sample rates up to 96000Hz
Audio buffer frame size : 14 to 4096 frames
Current I/O buffer frame size : 512
Volume Control
Physical: No
Virtual: Yes
MQA capability
Auto-detect MQA devices: No
Not a MQA device, user set to not MQA
DSD capability: Unhandled
Device audio channels
Preferred stereo channels L:1 R:2
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: Yes

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1

Stream ID 0x64 2 channels starting at 1
3 virtual formats:
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 96kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 48kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 44.1kHz

3 physical formats
2 ch Mixable linear PCM Interleaved 24 little endian Signed Integer aligned low in 32bit 96kHz
2 ch Mixable linear PCM Interleaved 24 little endian Signed Integer aligned low in 32bit 48kHz
2 ch Mixable linear PCM Interleaved 24 little endian Signed Integer aligned low in 32bit 44.1kHz

Local devices found : 9
Device #0: ID 0x63 Sortie intégrée Manufacturer: Apple Inc. Model UID: AppleHDA:16 UID: AppleHDAEngineOutput:1F,3,0,1,1:0
Device #1: ID 0xbb Yeti Stereo Microphone Manufacturer: Blue Microphones Model UID: Yeti Stereo Microphone:B58E:9E84 UID: AppleUSBAudioEngine:Blue Microphones:Yeti Stereo Microphone:14340000:2,1
Device #2: ID 0x44 MJRecorder Device Manufacturer: MJ Music Recorder contributors Model UID: MJRecordDeviceModelUID UID: MJRecordDevice
Device #3: ID 0x41 Movavi Sound Grabber Manufacturer: Movavi Software Inc. Model UID: Movavi Sound Grabber 3 (Model UID) UID: Movavi Sound Grabber 3 (Device UID)
Device #4: ID 0x52 Soundflower (2ch) Manufacturer: ma++ ingalls for Cycling '74 Model UID: com_cycling74_driver_SoundflowerDevice:Soundflower UID: SoundflowerEngine:0
Device #5: ID 0x4a Audiojingle Manufacturer: Audiojingle x Software Model UID: Soundtree UID: com.audiojinglex.soundtree.mastereffect
Device #6: ID 0x4f Audiojingle (UI Sounds) Manufacturer: Audiojingle x Software Model UID: Soundtree_UISounds UID: com.audiojinglex.soundtree.mastereffect.UISounds
Device #7: ID 0x3b ZoomAudioDevice Manufacturer: zoom.us Model UID: zoom.us.zoomaudiodevice UID: zoom.us.zoomaudiodevice.001
Device #8: ID 0x37 ApparAudiojingle et sortie intégréeeil à sorties multiples Manufacturer: Apple Inc. Model UID: ~:AMS2_StackedOutput:0 UID: ~:AMS2_StackedOutput:0

UPnP devices found : 0

you can change this setting in the audio output and set it to 3 or 4000MB and Audirvana will take less RAM in your system.

And Audirvana will continue to function well despite my 230,000 songs?

Yes, this is an allocated space for audio when you play music in Audirvana

Dear users of Audirvana,

I have a similar problem. With the option upsampling on (factor 2) the RAM uses explodes for large files even if I restrict the preload allocation to 1GB. I get in the situation that 6GB from 8 are used: not workable as I also work simultaneously on this laptop.
If I stop the upsampling the sound becomes of bad quality with constant horrible hiccups: useless, better have silence.
My current option is to avoid large files and to limit the upsample to a factor 2. In this way Audirvana is using “only” a GB of RAM: It is not ideal but workable for the time being.

My system is a MacBookAir 2015 (core i7), connected by Thunderbolt 2 to a OWC Dock. The dock is connected to the DAC via a 0.5 meter spdif optical cable.



if you have hiccups while not upsampling, check your mac… it should be the reverse happening… hiccups when upsampling and working at the same time with the mac…

Turn upsampling off, Restart mac, Restart Audirvana.

Me, no upsampling. Here is a file of 24-96 playing at 24-96…
load in a second on mac mini i5 2012 16gb ram, then computer is nearly sleeping till the CD finish… ram is super low, surely no hiccups :slight_smile:

Thank you for your answer. I will try. Now I have also a RAM use of a GB, that is in accordance with the preload allocation.