Origin freezes (mac)

Hi @Antoine
Origin managed to write 2 CDs in the library under 10 hours. I’m here right now.
By the way, it is also weird that the remote control also freezes many times during Origin not response, but playing the music.
If I just open one Folder where my music is then origin starts scanning the whole thing right away and it usually takes 6-8 hours (usually these 2-6TB folders)
I know that relatively few users have such a quantity of local music, but please try to do something (because when I switched from Roon, I asked how many tracks can be handled by Audirvana and you said it works up to 500,000).

The iTunes library file could be perfectly read even with the 500,000 tracks, it plays them, only the covers are missing approx. 30 % and they are grey color, but playing well.

However, this was not the cause of freezing for me, as I have suffered from the beginning, after 50,000 tracks of music, slowed scanning began.
Yeah, and one more thing: it is strange that music added to Folder does not appear in the library at the time of adding, but slipped, little bit randomly.
many thanks

Hi @szablyaakos,

Can you go in the Audirvāna settings and in the My account section? You will see a button ‘Start Log Session’, click on it and then reproduce your issue. After you reproduced it, click on ‘Stop Log Session’ and then send me the log file you can find by clicking on the button ‘Open Log Folder’ at support@audirvana.com

Hi @Antoine

I sent it.
thanks for your support

many cue sheets cause the problems i have seen in the log files… should i delete the cue sheets or/and m3u/log files of XLD app ?

Hi @szablyaakos,

It’s possible that those files are indeed pointing to a older location and slow down the sync process. Can you please try to remove them?

Hi @Antoine

not other location, but i think they stayed there after the unpacked. i am startining to delete them

Hi @Antoine

I checked and deleted 1882 cue sheets. It looks like nothing better: It is killed my finder, freezing, delaying, rainbowball is spinning.
After pressing play, it started playing the album about 5 minutes later. After clicking on the album, it opened it about 10 minutes later.
Couldn’t open preference with shortcuts to copy a new log session

I will send it when i can copy it (by mail).

I sent it.

Hi @Antoine

Did you find the reason of my freezings? Do you have any solution?

In the meantime, I deleted the iTunes Library shared file and since then the MBP is not freezing, it is only slowed down and the added music appears in the library disastrously slowly sometimes one or two hours later. As if I open the albumart origin will start again synchronization and the album will appear. Plus, not in the order of the addition.

it is really strange…

Hi @Antoine

I moved to Ventura, but the album adding still terrible slow. I deleted iTune library, so now the Origin doesnt freeze, but the added cd appears in the library disastrously slowly sometimes one or two hours later or doesnt. Sometimes doesnt start the synchronization , although in the folder have many new cd. If i open the album arts it started and the process is more faster

Anyone else having a similar problem? Ever since I got Origin, I’ve been suffering with this, there are days when Origin adds an album to my library in a couple of hours, sometimes 4-5 hours - it’s a nightmare, it’s a nightmare :cry: :disappointed_relieved:

1 Like

Before going to sleep,
Go in origin pref and delete the folders of music there
Close origin.
Go to database folder in mac and delete it (or copy it somewhere else, then delete it)
Restart mac
Open origin, add music folder ( one if you have more), let it go, go to sleep :grinning:
After sync is finished, close origin , copy the database elsewhere as a good one
Open origin, add your second folder… repeat all.
See if it is faster, or when it got slower…

The sync should be instantly, remove an album should be instantly also, add one the same

The problem I had was that I was using iCloud to store my files. Before Sonoma, opening Origin and pointing it at my iCloud Music, Origin just picked up the stuff that was already downloaded on my Mac. With Origin, it starts to download everything that is up in iCloud and adds them to Origin library only when it has downloaded them. It basically made Origin unusable with iCloud. Now I just go into Finder and DL an album and put it in a folder that I can point Origin to. There is something different about iCloud in Sonoma. I noticed that the new behavior of iCloud is the same as OneDrive which is also unusable with Origin. This might or might not be similar to the problem you are having with iTunes but your experience of it beach balling when you open Origin while it syncs with a database was the same for me. I guess trying to use Origin with a streaming database, even if it is your own database, is ‘streaming’ and it won’t work.

Thanks @RunHomeSlow for the idea, but so far i deleted and reinstalled all the folders 4 or 5 times approx. The problem starts at 50,000 tracks and now at 160,000 tracks it is scandalously slow. However, there are a total of 800,000 tracks, which I would like to add (i tried to add itunes library file, but it killed my mac - i mean the applications completely froze and the whole Mac was unusably slow all the time) , as I wrote at the beginning. iTunes handled 1 million tracks easily and at almost same speed, and that’s why I’m quite disappointed that such a professional program as Audirvána can’t do the same and @Antoine didn’t find a solution for it

Hi @ronmad8,
I only use local files that are located on external HDDs connected with Thunderbolt 3 to my MBP (M1 max 64GB) and Lumin X1 plays them, via fiber network connection. So i dont have any music files on my iCloud

i have 53000 songs. Only FLAC or DSF.
when i click sync, Audirvana thinks for 10 seconds,
then read my 2 external usb hard drive in 10 seconds…
i can also at the same time open 3.5 Audirvana
and sync it too and it will be done too in 10 seconds…
when i add a CD it is instantly added to new items playlist…

i made a film for someone to show how fast it should get…
no streamer or other internet in between my mac and external usb hard drives,
maybe it was already for you… :slight_smile:

Mac Mini 2018 16gb of ram…
YOU have a bug… in your picture above we can see you have LittleSnitch, Malwarebytes, Dropbox, Time Machine… come on!! remove them, do your test, put them back after…
now that you deleted the .cue sheets and not pointing to iTunes anymore…
Start from scratch…

Before going to sleep,
Go in Origin prefs and delete the folders of music there
Close Origin.
Go to database folder in Mac and delete it
(or copy it somewhere else, then delete it)

Apple hide the Home Folder in User Library at some time depending on OS System…
When you have clicked your Home Folder, and cannot see the Library Folder in there,
just do a ‘‘cmd J’’ to show the folder settings preferences and see at the bottom…
click Show Library Folder and then you’ll have access to the rest forever.

Go to User… Your Home Folder… Library… Applications Support… Audirvana Folder…
Trash All the files in that folder (that is your database of music, back it up! or not)
AudirvanaDatabase.sqlite is for Studio or Origin,
but remove others if you have old version of .sqlite
for Studio or Origin not Starting to convert them at first launch.

Restart mac
Open origin, add music folder (one if you have more), let it go, go to sleep :grinning:
After sync is finished, close Origin, copy the database elsewhere as a good one
Open Origin again, add your second folder… repeat all.
See if it is faster, or when it got slower…


i can see that with 160 000 songs it will took longer,
but not that longer like you have… and with a full loaded M1

You surely also have some trouble finding what to play with all those tracks :slight_smile: