Read doesn't without a "Asio driver configuration" first

I have an issue when I launch the first song : Audirvana refuse to play until I open the “Configuration of the ASIO driver” one time. Could you help me, please ? Thanks.

Initiale configuration:

  • I use a PreSonus Studio 192 Mobile as DAC and with its ASIO driver
  • The over Oversampling is activated using the device’s Max Frequency

Procedure

  • Start Audirvana
  • Choose any song or playlist. Example: a playlist in Qobuz
  • Click on the song’s play button
    => Message “Error starting audio playback”
  • Click on the output mode selection button
  • Click on the arrow to the right of “Studio 192 ASIO”
    => The configuration panel opens
  • “Configuration of the ASIO driver”: click on the “Open” button
    => The PreSonus “Universal Studio” application opens
  • Return to Audirvana
  • Click on the “Previous” button to return to the playlist
  • Click on the play button of the same song (or another)
    => The music starts

If I don’t use oversampling, I have seen issues taking into account the new playback frequency when it changes from song to song.

Can you send me a copy of the “Debug Info”? You can get it in Audirvana Settings>General>Debug Info

Note: By clicking on the Debug Info button, Audirvana automatically copies all its content, all you have to do is paste it in response to this message

Yes, you will find it down below. Regards.

Audirvana 3.5.43

SIGNAL PROCESSING:

Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

UPSAMPLING:
SoX with device max frequency upsampling
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000
Anti-aliasing = 100
Phase = 66

AUDIO VOLUME:
Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

LIBRARY SETTINGS:
Sync list: 1 folders
AUTO: C:\Users\Sébastien\Music
Library database path: C:\Users\Sébastien\AppData\Local\Audirvana\AudirvanaPlus\AudirvanaPlusDatabaseV2.sqlite

ACTIVE STREAMING SERVICES
Qobuz: Connected as Qobuz Studio

=================== AUDIO DEVICE ========================

Max. memory for audio buffers: 4216MB

Local Audio Engine:ASIO 2 driver version 1092

Preferred device:
Studio 192 ASIO
Model UID:Studio 192 ASIO
UID:Studio 192 ASIO

Active Sample Rate: 192kHz

Bridge settings:
Sample rate limitation: none
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:
Local audio device
Studio 192 ASIO Manufacturer:
Model UID:Studio 192 ASIO UID:Studio 192 ASIO

6 available sample rates up to 192000Hz
44100
48000
88200
96000
176400
192000
Volume Control
Physical: No
Virtual: No
MQA capability
Auto-detect MQA devices: Yes
Not a MQA device, user set to not MQA
DSD capability: Unhandled
Device audio channels
Multichannel: 8 channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox63f, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1
Channel 2 mapped to 2
Channel 3 mapped to 3
Channel 4 mapped to 4
Channel 5 mapped to 5
Channel 6 mapped to 6
Channel 7 mapped to 7

Audio channels in use
Number of channels: 8
Use as stereo device only: No
Simple stereo device: No

1 output streams:
Number of active channels: 8, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1
Channel #2 :Stream 0 channel 2
Channel #3 :Stream 0 channel 3
Channel #4 :Stream 0 channel 4
Channel #5 :Stream 0 channel 5
Channel #6 :Stream 0 channel 6
Channel #7 :Stream 0 channel 7
8 ch Integer PCM 32bit little endian 44.1kHz
8 ch Integer PCM 32bit little endian 48kHz
8 ch Integer PCM 32bit little endian 88.2kHz
8 ch Integer PCM 32bit little endian 96kHz
8 ch Integer PCM 32bit little endian 176.4kHz
8 ch Integer PCM 32bit little endian 192kHz

Local devices found : 9
Device #0: AudioBox ASIO Driver Manufacturer: Model UID: AudioBox ASIO Driver UID: AudioBox ASIO Driver
Device #1: ioStation ASIO Driver Manufacturer: Model UID: ioStation ASIO Driver UID: ioStation ASIO Driver
Device #2: ASIO PreSonus FireStudio Manufacturer: Model UID: ASIO PreSonus FireStudio UID: ASIO PreSonus FireStudio
Device #3: Quantum ASIO driver Manufacturer: Model UID: Quantum ASIO driver UID: Quantum ASIO driver
Device #4: Studio 192 ASIO Manufacturer: Model UID: Studio 192 ASIO UID: Studio 192 ASIO
Device #5: Studio USB ASIO Driver Manufacturer: Model UID: Studio USB ASIO Driver UID: Studio USB ASIO Driver
Device #6: StudioLive AR ASIO Manufacturer: Model UID: StudioLive AR ASIO UID: StudioLive AR ASIO
Device #7: StudioLive Classic USB Manufacturer: Model UID: StudioLive Classic USB UID: StudioLive Classic USB
Device #8: StudioLive Series III ASIO Manufacturer: Model UID: StudioLive Series III ASIO UID: StudioLive Series III ASIO

UPnP devices found : 0

Does the issue appears with every ASIO driver you have?

I have only the Studio 192 Mobile. And I use its official driver. As far as I know, the other drivers are for other products of PreSonus. If I try to use one of them, Audirvana show an other message : “Error: no audio device”

Have you tried to open Universal Studio app before playing a track in Audirvana using Studio 192 ASIO as output?

It does not change anything. The issue occured even if the Universal Studio app is already opened.
I also try to launch Audrivana then open the Universal Studio app independantly. But I still have the error message.
It’s only clicking on the button “Open” of “Configuration of the ASIO driver” that makes it work, even if the Universal Studio app is already opened.

After selecting an wrong asio driver and coming back to the right one, it solves the issue (with Oversampling on). And it still works if I close and relaunch Audirvana.

To reproduce the issue, I desactivate the oversampling, play a song, stop it and reactivate the oversampling. Then the issue come back.

ASIO driver should start without having to open your app, you should contact PreSonus as it should not behave like this.

To complete my test, I reboot my computer and launch Audirvana from a fresh start:

  • With oversampling (192khz), the play does not start without help (no matter what I do before the reboot).
  • Without oversampling, the play works for song in 44.1kHz or 48kHz, but crash for song in 96kHz.

My ASIO driver is in 44.1kHz by default, And it seems that Audirvana failed to change the frequency. Maybe the code does not wait enough or it forgets to confirm the change from the driver, your developpers should know.

To contact PreSonus, I need more information about the error encounterred by Audirvana. Or they won’t be able to help.

About the app, I can solve the issue by acting only in Audirvana (switching of ASIO driver) and without opening the PreSonus Universal Studio, even after a complete reboot. So the App itself is a dead-end. It’s certainly the way Audirvana launch this app that solve the issue.

To try to understand, I do some more tests without the oversampling :

  • Before switching of ASIO driver: songs with 96kHz don’t work.
  • After switching of ASIO driver: songs with 96kHz work. But if I navigate from song to song (without stopping), going from 96kHz song to 44.1kHz song works, but going from 44.1kHz song to 96kHz song crash.
  • After switching of ASIO driver (bis): if I test different songs but always manualy force a stop before starting a new one, it always works (44.1, 48 and 96).

Obiously PreSonus Studio 192 ASIO drive does not like the way Audirvana initiate/change the output frequency.

“ASIO driver should start without having to open your app, you should contact PreSonus as it should not behave like this.”
As my test show, the asio driver are started. It’s the frequency change that have an issue.

Could you check and give me more information about the error that occured in your application, please ? I can not contact PreSonus with so few data.

Thanks.

Hello @damysos,

Have you tried with every option available for upsampling? Does it behave the same when you are setting it as “Power of 2” or “x2”?

Hello @Damien3

I tried x2 with a 44.1Khz file. But the result was the same. I also tried to fix “by frequency” and selected 96Khz to every file below this frequency. Unfortunately same result.

I finally solve my issue by changing these 3 options: “Use only in stereo”, no auto-detection of MQA DAC and “Put in silence when changing frequency” (sorry for the translation, my interface is in French).

I cannot say which one solve it. But with these 3 options and the version 3.5.44, every works fine now.

My 2 cents, if it can help someone else.
Regards,