Recently Added... is not recently added

Under LOCAL → there is a default “Recently Added” It says “tracks and albums recently added in the last 15 days”. It is actually displaying recently PLAYED. I had not added anything to my library for over month but now recently PLAYED albums and tracks are showing up in there…which is annoying since I can’t fix it and its now mixing with items I HAVE recently added.

I created my own smart playlist for Recently added. It is picking up everything I added and everything i played. Why would playing it change a date in the file?

Never worked for me. Displayed all number of albums added at all odd times.

This definitely worked in the standalone version. That version had problems adding tracks multiple times and that is where it would show up. An album that had been in the system for months would all of a sudden show up as recently added and then have double tracks.

Since the search criteria is based on date, I don’t know why PLAYING an album would change the date in the folder so it looked modified.

The whole point of a filter is moot if this doesn’t work

never had problems with those settings:


an album showed up that I added in 2019…just a mish mash of stuff.

Hi @cjjeeper,

Can you send me a mail at ? I will send you a link to send me your Audirvāna database file so I can take a look at it.