Remote does not load library

For quite some weeks, Remote does not load the library (neither on iPad nor iPhone). Remote displays “Loading” endlessly however does not load.

Remote connects properly, the track playing is displayed correctly. I use the latest versions of both Remote and Audirvana for Mac. The library contains 4000 albums and over 60000 tracks however if i filter (to display just a part of that) that does not make any difference.

How can i have Remote display my library again?

Hello @ThijsA, can you make some screenshots of the issue you have ?

Please find below the screenshots


Have you tried to restart your WiFi router? it may have a problem transmitting the connection used by Audirvana Remote (Like the Apple Remote app that controls iTunes, which can be blocked for the same reasons)

Hello Damien,
I restarted the router to no avail. I disconnected the hard disk, restarted Macmini. Moved sqlite db. Connected harddisk again. Had Audirvana build up a new library. Restarted Remote on iPad and iPhone.
Again just the ‘Loading…’ message, despite the fact the Remote indicates the track playing and Remote can control (start/pause) the track playing.

Looking forward to any other suggestions

[Edit: I just tried Remote on iPhone with my iMac, same problem: just the ‘Loading…’ message]

Your files are stored in a external Hard Drive?

Yes indeed and I made sure it was running (since it plays music)

How are you connected to it? You are using a USB 3.0 (with blue connector) cable?

Yes, it is connected to a Mac mini using a USB 3.0.
The issue with Remote however appears in both configurations (macMini and iMac).
The only difference being that the external RAID 0 harddisk is connected to iMac through a hub.

Hello @ThijsA,

Can you send me a copy of the “Debug Info”? You can get it in Audirvana Settings>General>Debug Info

Note: By clicking on the Debug Info button, Audirvana automatically copies all its content, all you have to do is paste it in response to this email

I just sent you both bug reports via e-mail

Still, the app shows the track currently playing, however when I chose Album in the Remote app it shows endlessly ‘Loading’ and does not show the Albums.
However I found something very odd : despite the Albums not being shown, all Tracks are shown in the App!

As mentioned, until some weeks, say 2-3 months ago it worked perfect.
Do you in the meantime have any suggestions that would solve this? Pls let me know if I can provide any additional information.

I was at lost, I re-installed Audirvana, re-installed the hard disk, nad a new library built up. re-installed Remote everything to no avail.

It turned out to be a setting in the router.
What needed to be turned on in my FritzBox was ’ 'Transmit status information over UPnP

Damien you we’re right in the first place. It now works like a charm again.

I was too premature. It works for just one of the Mac’s both connected to the same network via ethernet and via the same switch.
With the iMac the Albums show, with the Mac mini it endlessly displays ‘Loading’ etc.

Does anybody have any suggestions how to resolve this?

I really like Audirvana and would very much like to stick to Audirvana, however this make Audirvana unworkable for me

Hello @ThijsA,

Can you check your firewall settings: In System Preferences > Security and Privacy > Firewall > Firewall Options > Automatically allow signed software to receive incoming connections check that this setting is selected and “Block all incoming connections” is not selected.

Hello Damien,
Just checked. The firewall of the Mac mini was off. I just set it on and Audirvana was allowed to make incoming connections. Both settings resulted in the ’ Loading…’ message.
Would you have any other suggestions?

Hello Damien,
What I - as a layman - find hard to understand is that with Remote from the Mac mini
all ‘Tracks’ are displayed, however ‘Albums’ are not and
in the standard Playlist ‘Recently Added’ all ‘Tracks’, are displayed however ‘Albums’ not.
How has this anything to do with the connection, router etc, if half of the info is displayed and the other half not?

Would any of you have any suggestions ?

Can you check your database using the three commands in the Maintenance section of the preferences page? What is the speed of your wi-fi between your phone and your wi-fi router?

Hello Damien,

I just performed - as I do one a weekly basis - the 3 maintenance actions.

In the specific location of the audio setup the wifi speed - depending on the app used - is either
down 186Mbps/up 146 or
down 207/up227 Mbps,
which should be sufficient, I guess

However still the Albums do not appear.

To add to my previous post: if I search for Albums of a specific Composer, all of the Albums of that Composer (in my test 114 albums) appear instantly.

At the moment the database comprises approx. 3.600 albums and 62.000 tracks. (Funny enough, all ‘Tracks’ load without hesitation)

Do you have any further suggestions. I would be happy to provide additional information

Hello Damien,
Would you have any further suggestions in order to have all Albums shown in Remote?