RoPieeeXL unselectable in Network output device list

RoPieeeXL w/Dragonfly black, static IP, latest RoPieeeXL on Rasberry PI 3 – shows in the list of selectable devices, but the box/selection never takes. The little square doesn’t highlight (only flashes the device name), but never connects. Also, the > doesn’t show with more settings… basically unable to select it. Trial license of Audirvana.

I am running on a Mac Mini (Early 2009). I installed Audirvana 3.5.32 on Yosemite, realized I needed El Capitan, then upgraded to MacOS 10.11.6 (El Capitan). Mac Audio wasn’t working/showing up - I eventually created boot/recovery drive and ran CSRUTIL DISABLE to shut off SIP. Audio device now shows. Still not able to hear audio through internal audio section w/ear buds plugged in. If I plug Dragonfly Black DAC into Mac Mini USB, I can stream audio just fine - shows 24/96 and sounds good. I was also able to stream to a Bluetooth speaker defined as a Mac Mini Bluetooth device (since un-paired).

iTunes w/Airplay was able to stream to the RoPieeeXL w/AQ Black DAC no problem. I start Audirvana w/o iTunes running. I have tried both modes in Audirvana.

I have set a static IP on the RoPieeeXL device, tried turning each protocol on/off (in the PI) and retesting - still can not get Audirvana to select/connect to the PI w/AQ Black DAC.

Any insights on this setup?
Q: Why can I not play audio back through the internal speaker or headphone jack? Is that normal?

Q: Why can I not select the device in Audirvana even though it shows up as a Network device?

Q: Is there a device-driver issue? Can I just re-install the Audirvana device driver cleanly into the current 10.11.6 environment?

Q: If I un-install/re-install Audirvana, will my Trial license continue? or will it time out?

Q: Can I preserve the library/indexes if I un-install/re-install?

Further update… stabilized the Mac Mini/Mac OS and the internal speaker/headphone output has been restored by reseating the hardware, and re-selecting the audio steps on El Capitan.

Audirvana will play on internal speaker and headphones, but still will not let me select the RoPieeeXL device - despite it showing in the network devices list. I have DNLA, AirPlay, and Spotify, and HQPlayer AA all turned on.

iTunes and Spotify will play to the RoPieeeXL player just fine outside of Audirvana.



Hello @PKrein, have you checked this thread regarding the RoPieeeXL? Audirvana > Raspberry 4 (Dietpi) > DAC or working !?!

I had tried the RBP with a statis IP, no change. I then changed my Mac Mini to a static IP, still no working.

I did load Volumio on the RPi and it works properly (same hardware setup) with Audirvana 3.5.33. Both RPi and Mac Mini have static IP, and I did go into the Volume.local setup and discretely set the output to my USB DAC connected to the Raspberry Pi. Will retry RoPieeeXL another day.