Studio not addiing files fron nas files

Hi, new here, I recently suscribed to studio version. I tested the 3.5 version in the past and worked fine. Now with Studio, this version doesn’t add all my music from Synology Nas (Plex folder), even the new music. It only adds some albums but not all the music about +400 from over 2000. I tried several scans, erase the program and re-install, nothing helps. Even I remove all the files, change the library to other files and same problem. I also tried an external HD with more than 1000 albus and works fine knowing all of them. The situation is that I can fully use the HD due to capacity limitation and even want to use another computer sharing the Nas files. Any Suggestion? Thanks in Advance!

Audirvana Studio 2.2.3 (20203)

macOS 12.6.3 with 16GB physical RAM

Connected account of : Alexis Ortiz Colon

SIGNAL PROCESSING:

Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

UPSAMPLING:
r8brain not in use
r8brain filter parameters
Bandwidth = 99.5%
Stop band attenuation 218dB
Phase linear

AUDIO VOLUME:
Max allowed volume: 100
Replay Gain: by album
SW volume control: OFF

LIBRARY SETTINGS:
Sync list: 2 folders
AUTO: /Volumes/LACIE LAP/Audirvana Flac HiFi Library
AUTO: /Volumes/Plex/Media/Music/Flac Music
iTunes/Music library synchronization: not synchronized
Library database path: /Users/alexisortizcolon/Library/Application Support/Audirvana/AudirvanaDatabase.sqlite

Remote Control server:
Listening on 127.0.0.1 on port 62613

ACTIVE STREAMING SERVICES
Qobuz: Connected as Qobuz Studio
TIDAL: Connected as HIFI

=================== AUDIO DEVICE ========================

Active method: Local

Max. memory for audio buffers: 13312MB

Local Audio Engine: CoreAudio
Exclusive access: ON
Integer mode: ON
Use max I/O buffer size: ON
Actual I/O buffer frame size: 512

Preferred device:
Apple Inc. MacBook Pro Speakers
Model UID:Speaker
UID:BuiltInSpeakerDevice

Active Sample Rate: 44.1kHz
Hog Mode is off

Bridge settings:
Sample rate limitation: none
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:MacBook Pro Speakers
Manufacturer: Apple Inc.
Model name: Apple Inc. MacBook Pro Speakers
Model UID: Speaker
UID: BuiltInSpeakerDevice
ID 0x4a

4 available sample rates up to 96000Hz
44100
48000
88200
96000
Audio buffer frame size : 14 to 4096 frames
Current I/O buffer frame size : 512

Volume Control
Physical: Yes
Virtual: Yes

MQA capability
Auto-detect MQA devices: Yes
Not a MQA device, user set to not MQA
DSD capability: Unhandled

Device audio channels
Preferred stereo channels L:1 R:2
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: Yes

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1

Stream ID 0x4b 2 channels starting at 1
4 virtual formats:
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 96kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 88.2kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 48kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 44.1kHz

4 physical formats
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 96kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 88.2kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 48kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 44.1kHz

Local devices found : 1
Device #0: ID 0x4a MacBook Pro Speakers
Manufacturer: Apple Inc.
Model UID: Speaker
UID: BuiltInSpeakerDevice
Model name: Apple Inc. MacBook Pro Speakers

UPnP

UPnP devices found : 3
Device #0: ID 0x0 : Marantz ND8006
UID: uuid:54d7371b-0c0e-1e51-0080-0006787cb162
Location: http://192.168.35.29:60006/upnp/desc/aios_device/aios_device.xml
Manufacturer: Marantz
Model name: Marantz ND8006
Device #1: ID 0x0 : Marantz SR6012
UID: uuid:0048523a-e67c-19fc-0080-0005cdf0de6a
Location: http://192.168.35.59:60006/upnp/desc/aios_device/aios_device.xml
Manufacturer: Marantz
Model name: Marantz SR6012
Device #2: ID 0x0 : UBP-X700
UID: uuid:00000000-0000-1010-8000-143fa600b63b
Location: http://192.168.35.57:52323/dmr.xml
Manufacturer: Sony Corporation
Model name: UBP-X700

Chromecast

Chromecast devices found : 0

400+ added, always stop at the same place? Maybe check that album… may have names or accents, letters Audirvana doesn’t like?

No, just random, several atemps with different quantities. Even I move the library to other folder and start adding incrementals of 50, then 100 then 200 and until the end and just finished with more tha a 1000.

Ok, interesting case, just a few things to look at:

  • You said “Plex folder”: maybe Plex added some specific files that AS does not like?
  • I guess that the NAS folder is mounted via SMB: can you check in system logs if you have issues reported on SMB.
  • Do you have the Recycle Bin activated on the NAS volume you are using? If yes, you could try to deactivate it.

I’m not sure though of the above tricks as you also have problems when using an external HDD, not a NAS.

OK, we are looking for a possible issue with the access to Volumes/disk, but what if several albums were merged together? Do you have collections of disks with similar names or same composer/musicians? I’ve already seen strange things with merge of albums that normally should not be merged altogether.
Can you try just to access your NAS volume from the MAC where AS is up and running, and you simply change the name of any folder in that volume: that should trigger the Sync process. And let’s see what we have after that.
Another way to check if all your albums have been process would be to look inside the DataBase with DB Browser for SQL lite, but that is a bit more complex.
Eric

Ok, first thank you for your response.

Initially I created this library inside the plex folder. I also tried the audirvana 3.5 with the same folder and works fine until the upgrade to studio.

I had been reading about smb an now I think that could be the problem, could be possible that this smb protocol works fine with 3.5 and not work with studio? How do I check the logs on Nas,? I checked the Log and don’t see any issue.

About the recycle bin I will check in the afternoon and let you know.

I don’t have any issue with the external HD the only problem is with the nas folder. I just want to eliminate the redundancy of multiple libraries. Just one to both computers and the plex server

Ok, at least the problem seems to come from the folder mounted from the NAS. So, it could be a problem with SMB but if you did not see on the console any error message from the smb protocol, it’s probably something else.
I have the feeling but no certainty that the Sync algorithm of AS and 3.5 are not much different, so what works on 3.5 should work with AS.
If I were you, I would try to put the files into another shared folder on the NAS (Separated from Plex), just to see if the problem could come from any additional files inserted by PLEX.
It’s a pity again not to have any log file on the MAC version, just as an optional thing to try to understand why the Sync process is sometimes incomplete.

Ok I moved the library to another folder inside the plex with the same results. I also find a recommendation in Synology website to adjust the smb min and max settings from smb 1/ smb2 to smb2/sbm3 to get a maximum support. Re scan and nothing either. I will try your recommendation moving to a folder outside the plex. Thanks

I tested your recommendation moving 150 files and change the directory outside plex and only sync 48 albums from the first sync. On the second try sync 150. Then move the rest of the library and don’t sync anymore.

I also check and disable the recycle bin, nothing change. Additional I entered to the smb advance setting on the mac os tap and click enable the vrs module to get mac compatibility and nothing yet

Actually it doesn’t sync anymore

you mean albums… only sync 48 albums on first sync…
what was the 49e album name? strange typo sign?

Yeah albums

I am very frustrated about this issue. I also entered to the smb advance settings to see all the options that I can adjust . Also to the help menu from the Nas without any change. I been all day reading and searching about a guide o more info about it! Does Audirvana has any tutorial or following step to create this process or to help people to manage this process the right way?

what was the 49e album name? did audirvana import 48 in alphabetic order?

yes because I add all the A letter, 150 albums

so…

what was the 49e album that didn’t sync… Folder name?

I added to a folder outside the plex folder as recomendation of you guys (to descate the problem will be a plex issue), I moved all the files starting with the letter A. From 150 albums just sync almost 50 ramdom. So the problem apparently isn’t plex. something else.

it is working because it add some… you have to check why the others didn’t sync…
maybe it is just in the names of the folder of that or those Cd’s.

I don’t know where you from, but sometimes it is accents on letters that Audirvana don’t like… so it passes those albums or just stop syncing… put 30 albums if they all passes, remove the 30 albums put 30 new ones, then see if sync all good, if not removes last 30 put 15… try to find the ones that don’t sync if they have something s^pecial in their names…

we are just users that answered you to date… not Audirvana company
i don’t even have a NAS :slight_smile:

Ok, i will tried your suggestion. Thanks! Really appreciated!:grinning: