Sync folder not updating

From the beginning of my using Audirvana (v2.0) syncing was great until recently (v2.2?). Now it never syncs unless I go to Settings>Local and manually start the sync. I have a decently fast computer but it is still a PITA to do.

Library is on a USB external drive.
M1 iMac
macOS Ventura 13.1
Audirvana 2.2.4

Audirvana Studio 2.2.4 (20204)

macOS Version 13.1 (Build 22C65) with 16GB physical RAM

Connected account of : Tim Lance


Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins ACTIVE in offline mode with legacy macOS API
	AU plugin #0: Effect - Apple AUGraphicEQ ()
	AU plugin #1: None
	AU plugin #2: None
	AU plugin #3: None

SoX with 2x upsampling
SoX filter parameters
Bandwidth at 0dB = 99.5%
Filter max length = 30000
Anti-aliasing = 100
Phase = 66%

Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

Sync list: 1 folders
AUTO: /Volumes/One/MUSIC
iTunes/Music library synchronization: not synchronized
Library database path: /Users/me/Library/Application Support/Audirvana/AudirvanaDatabase.sqlite

Remote Control server:
Listening on on port 55740


=================== AUDIO DEVICE ========================

Active method: Local

Max. memory for audio buffers: 13312MB

Local Audio Engine: CoreAudio
Exclusive access: ON
Integer mode: ON
Use max I/O buffer size: ON
Actual I/O buffer frame size: 512

Preferred device:
Built-in Output
Model UID:

Active Sample Rate: 48kHz
Hog Mode is off

Bridge settings:
Sample rate limitation: none
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:iMac Speakers
Manufacturer: Apple Inc.
Model name: Apple Inc. iMac Speakers
Model UID: Speaker
UID: BuiltInSpeakerDevice
ID 0x4e

4 available sample rates up to 96000Hz
Audio buffer frame size : 15 to 4096 frames
Current I/O buffer frame size : 512

Volume Control
Physical: Yes
Virtual: Yes

MQA capability
Auto-detect MQA devices: Yes
Not a MQA device, user set to not MQA
DSD capability: Unhandled

Device audio channels
Preferred stereo channels L:1 R:2
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: Yes

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1

Stream ID 0x4f 2 channels starting at 1
4 virtual formats:
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 96kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 88.2kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 48kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 44.1kHz

4 physical formats
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 96kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 88.2kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 48kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 44.1kHz

Local devices found : 2
Device #0: ID 0x4e iMac Speakers
Manufacturer: Apple Inc.
Model UID: Speaker
UID: BuiltInSpeakerDevice
Model name: Apple Inc. iMac Speakers
Device #1: ID 0x31 Microsoft Teams Audio
Manufacturer: Microsoft Corp.
Model UID: MSLoopbackDriverDevice_ModelUID
UID: MSLoopbackDriverDevice_UID
Model name: Microsoft Corp. Microsoft Teams Audio


UPnP devices found : 0


Chromecast devices found : 0

1 Like

Similar issues here - I have a mixture of legacy (i.e. from AS 3.5) and newly created music folders - some sync automatically, some don’t - there’s little rhyme or reason as to which.

At least my issue is consistent.

I can’t say this is contributing to your syncing problem, but it could… You are allocating a lot of memory for audio buffering… Try bringing this down to 6 to 8GB and see if this makes any difference in the behavior… MacOS needs RAM and Audirvana needs RAM to operate efficiently…
:notes: :eye: :headphones: :eye: :notes:

1 Like

That RAM quote is misleading. The machine is an M1 iMac. Apple Silicon machines have “unified RAM”

and are designed as a part of the “system on a chip”. That is, unified RAM > traditional RAM.

More, AS was fine on this system before. As stated, “syncing was great until recently”.

Delete the path of your audio files and configure it again in Audirvana.
I did that and it’s working normally.

Yes, I know that the Apple silicon employs unified memory in the chip… However, how this memory is deployed is the key… It seems this memory is primarily deployed in shared support of the core graphics/video engine and other system level operations… When Apple provides a dedicated on-chip unified memory bank in support of Core Audio, I would agree with you… However, this presumption that the unified memory is being employed in support of audio applications, may be the source of why many Mxx series platform users of Audirvana are experiencing difficulties in some Audirvana playback scenarios when allocating a large audio buffer that usurps the majority of shared RAM

@Reynaldo seems to have presented a reasonable solution…
:notes: :eye: :headphones: :eye: :notes:


All of what you’ve written is besides the point. The point being "syncing was great until recently”.

Did @Reynaldo 's suggestion work?

I’m marking Reynaldo’s input as the solution.

But, is it? Should the delete path thing be necessary much less be regarded as normal/expected operation?

1 Like

What did you change recently?

1 Like

I am also using macOS Ventura and Audirvana 2.2.4, and with me it has also stopped syncing.
I did this simple procedure and everything worked again.

Absolutely nothing. No apps added deleted. No operating system changes. The machine is an “extra” computer and pretty much only does Ardirvana.

1 Like

So… just a guess.(we would need more input from the Audirvana development team for an answer)…If Audirvana Studio 2.2.4 is the only change, then perhaps it needs more application memory allocation that is being usurped by the large percentage of RAM allocation for your playback buffering…

Why do you think you need such a large audio buffer RAM allocation? What do you believe is the benefit of such a large allocation of audio buffering? Why do you think the available RAM is inconsequential to the MacOS and Audirvana Studio systems operations outside of audio buffering?

I’m curious about the rationale…

:notes: :eye: :headphones: :eye: :notes:

1 Like

13 312mb is the default memory buffer set by Damien when you have 16gb of system ram.
He said at the time that the System needs 2.5gb of memory (mac only then, maybe same for Windows) to run bugless.

Maybe it is good to reduce a bit when you are upsampling if you have bugs…

I have 20gb of ram and put mine at 17 000mb :slight_smile:
Computer is sleeping nearly at 97% of the time…
it loads tracks of the CD fast then nearly don’t work at 4% cpu usage used most of the time… MacMini 2018

i think memory as nothing to do with syncing

First, update your Monterey 13.1 system to latest 13.2.1, nearly now 13.3 out
never stay at first number release for sure :slight_smile:
Stop upsampling when you have bugs… try after.
Do the Four database repair things in the preferences
Restart your mac, restart Audirvana… if it is still slow syncing…
trash your database and backup your playlist first :slight_smile:

1 Like

I just installed Origin for MAC version 2.2.5.
But it’s still not showing up here.

I never made any memory settings change.

And to be clear, it is not that sync was slow it was that it wasn’t happening at all, until the path was deleted/added.

Sure wish @Antoine would chime in.

There’s not much sense to cache more than a song worth of content. If you’re upsampling calculate for upsampled size.

Per default Audirvana allocates way too much memory. It should default to a maximum 4000MB. That’s the sweet spot with current memory configurations on the market.

1 Like

Audirvana at the time before Studio and Origin was always caching two songs at the time…

The one playing and the next. Caching is just reading the file, then if you are NOT upsampling it is done, it plays.

If you are upsampling then after the cache, the software is processing the song, that might be good then to lower the memory… but playing bit perfect only, caching is just loading fast a song… it is longer caching a 12 mins 24-192 file, so the faster it is cached the faster Audirvana is just playing the file… not play the song, cache while playing, play the song still caching while playing, forget about playing the song, still caching, drop sound, oupps, end prematurely :slight_smile:

The less i give Audirvana treating files at the same time, the better for me :slight_smile:

I never had a bug in Audirvana since i use it with default cache settings… only with the design :slight_smile: never stop before end, never hiccups, so all good to me, but all is for people to test on their side i guess for best result :slight_smile:

The one thing i still don’t understand is why still today it is written 13 312mb and not 13 312gb ???

Hi @tmthylance ,

What about a folder that is stored in your computer itself instead of USB, do you have the same behavior?