Unasked for update

I have Audirvana in direct mode on an old 2011 Mac Mini, running OS 10.13.3. I have no desire to change this set up. When I launched it earlier this evening it asked me if I wanted to update to something new ending in a 3 and I declined. I then had a power cut and when I launched Audirvarna it said it needed to update the library for the new version (something ending in 3, Audirvana plus?) !!! What the hell?! I have not updated the library as requested but it will not load the library any more. The installed version of Audirvarna is 3.5.44, so I don’t think the application has been updated without my consent but I am puzzled and stuck. Can anyone advise me please?

Check which version you have effectively.

Sorry, I don’t understand what you mean. Do you mean which version of Audirvana? If so, it is 3.5.44 as I said. If I launch it, I get a message saying I need to upgrade "Migrate library from Audirvana Plus 3"“The current version of Audirvana library needs to be migrated to the new version”. I have not changed the version.

if you have a backup like time machine, just put back your last .sqlite file and the 2 preferences of Audirvana to replace the buggy ones now…

Apple hide the Home Folder in User Library at some time depending on OS System…
When you have clicked your Home Folder, and cannot see the Library Folder in there,
just do a ‘‘cmd J’’ to show the folder settings preferences and see at the bottom…
click Show Library Folder and then you’ll have access to the rest forever.

Close Audirvana.

Go to User… Home Folder… Library… Applications Support… Audirvana Folder…
put back .sqlite file

Go to User… Home Folder… Library… Preferences…
put back your 2 preferences
com.audirvana.Audirvana-Plus.plist and com.audirvana.Audirvana.plist

Restart Mac, Restart Audirvana…

Many thanks for going to so much trouble, it is appreciated. I will give it a go when I get back.

Anyone want to speculate on how this could have happened? Obviously a power cut when in use is probably going to cause problems with any application but why this particular message came up is a puzzle.

Drew

Well that was an ordeal.

After the power cut and the shenanigans trying to get Audirvana working I went to get the sqlite files and the prefs files from backup as suggested. It was not straightforward as the dedicated server is headless and my SuperDuper! backup, when mounted, would not let me see the user library. Eventually I used the Go To Folder and Volumes path and it let me in.

After reinputting my license number it is back working but it does not sound quite the same. The set up was originally with the Direct Mode kext file hack and I wonder if that is now broken. Is there a way to check as it is no longer acknowledged in the preferences information?

Thanks again. I really hope that is not going to happen again.

Drew

Audirvana 3.5.44 (3574)

Mac OS 10.13.3 High Sierra

Mac Mini (Mid 2011) headless

Maybe it was Apple how want to updated something after power failure…

If you reinstalled High Sierra from Apple or Apple changed something,
the hack is gone… if just changed the .sqlite and prefs should be working again…

the change of date for the .ktext is here (see pict original and changed), if you have still the 2017 date Direct Mode should be again the Audirvana preferences. Look in ‘System’ folder, ‘Library’ folder, ‘Extensions’ folder.

I do not have one dated as modified 02-11-17 but I do have one dated as created 02-11-17 and modified 24-02-18…

In records office I have two kext modification dates: 26-12-17 and 21-03-18 so I am not sure what to make of that though I have a vague recollection of doing it twice

You don’t see the Direct Mode option here?