UPnP stopped working

Unfortunately, using RoPieeeXL as UPnP renderer with Audirvana+ stopped working with today’s update of RoPieeeXL. It worked for several weeks before.

Yesterday I wanted to check out moOde as UPnP renderer but it didn’t work. Seems to be the same error, I think.

Foobar2000 can still stream to RoPieeeXL in both versions and moOde, so it must be something with Audirvana+.

I hope you can fix this.

I am on Windows 10 and use a Raspberry Pi as UPnP renderer.

Have you tried with Volumio?

In the meantime, Audirvana+ and RoPieeeXL got updates, but it still doesn’t work.

Just tried Volumio, this works!

I’d prefer to use RoPieeeXL which works with Foobar2000, same with moOde.

Any idea what might be the cause or how to fix that?

Same thing happened for me. Stable with a usb sig running gentoo player. UPNP with dirac VST no longer plays.

You mean, without the Dirac VST it works? With which renderer exactly?

I am using Sonarworks VST plugin, by the way.

Sorry, tired and rushed.

It was stable, but since update it won’t work with Dirac VST enabled or disabled.

Is there a way to roll back versions?

I’m thinking of leaving audirvana, it sounds better than Roon but far far less reliable.


These quirks are related to UPnP implementations of various manufacturers. Contact RoPieee team and make them aware of this. It might start working again with the next version. In the meantime you can try with an older version RoPieee XL.

That said, if you’re ok with the cost associated with Roon, why not.

1 Like

I cannot say I’m convinced. I’ve been using Audirvana since April and dealt with a variety of user experience damaging quirks, which aren’t all associated to UPNP.

The challenge is, the latest bug fix release has actually caused the error. So surely, it must be on the Audirvana release?

I work in software development.

1 Like

I am in contact with the RoPieeeXL developer. I hope he can fix it and tell me how to get hold of an older version.

In the meantime I can use Volumio or USB.

Thanks for the explanation with the different implementations. Still I want to point out that Foobar2000 doesn’t have these problems with all three UPnP implementations.

Good luck, I’ve switched back to Roon until it’s fixed. I far prefer dirac to acourate :slight_smile:

1 Like


Well, the developer of RoPieeeXL has pushed out at least three beta versions for me in order to fix this, but to no success. I always send him feedback protocols, and he can see that there are a lot of connection timeouts.

So I think he can’t do anything about it, because:

Audirvana streaming to RoPieeeXL works (!), but only when I disable my Sonarworks VST plugin.

Foobar2000 streaming to RoPieeeXL works, even with the Sonarworks VST plugin enabled.

So this is an Audirvana thing, isn’t it?

My workaround is using DietPi with Allo GUI now, also works with the VST plugin enabled.

I really hope I can switch back to RoPieeeXL in the near future. I will continue to check back when new versions of Audirvana, Sonarworks and RoPieeeXL are released.

I really hope that Audirvana will be able to support more/all Raspberry Pie UPnP renderers in the future so one can choose which one suits the best.

I am running Audirvana on Windows 10 and all was fine until this evening. A problem has arisen when streaming from my laptop to my Cambridge Audio CXNV2. The Cambridge displays the selected track but playback does not execute in Audirvana. The same issue occurs if I select my WTX Stream Pro - no playback. This is the case whether I select local files or Qobuz. Playback is fine is I select the laptop playback.

I have checked streaming both to the Cambridge and the WTX Stream Pro from my laptop using Bubble UPnP and there is no problem in either case.

Any assistance greatly appreciated.

Many thanks


Hello @jeromecork,

Can you check the firewall settings: In Settings > Update and Security > Windows Security > Firewall and Network Protection > Allow an application through firewall, make sure that Audirvana is allowed to access the network.

1 Like

Hi Damien
Many thanks for the prompt reply.
The issue is solved. A system update had resulted in some internet connection issues which have since been resolved.
Audirvana sounds great again. Thanks.
Kind Regards

1 Like