While opening Studio: Error opening library file

After installing Studio on my Mac I was able to open and use it for maybe an hour or so. Then it stopped. When I rebooted the application, I could not open it anymore. I always get an error message that a database file cannot be found. I deleted Studio and re-installed the application several times but the problem persists. Can you help?

Hello @Refschicht,

Can you send a screenshot of the error?

Will send tomorrow or Thursday when I am back home again

Have you gone to the location that is listed and trashed the sqlite folder?

I have tried the Mac search function for the file and it cannot find it

Follow the path

If you have Playlists that are important export them first to desktop and
save them in a folder… when Audirvana is reset, you can re-import them back in one shot.
sadly to this day, the folders they were in if so, are not back, you have to do them again…

Apple hide the Home Folder in User Library at some time depending on OS System…
When you have clicked your Home Folder, and cannot see the Library Folder in there,
just do a ‘‘cmd J’’ to show the folder settings preferences and see at the bottom…
click Show Library Folder and then you’ll have access to the rest forever.

Close Audirvana.

Go to User… Home Folder… Library… Applications Support… Audirvana Folder…
Trash the file in that folder (that is your database of music, back it up! or not)
AudirvanaDatabase.sqlite is for Studio

Restart Mac. Restart Audirvana.
Let it go while it loads your new database, could be long… go to sleep :slight_smile:

After the sync is done, you can close Audirvana again, and save somewehere else that newly done database in a folder… give it the todays date to know when was that database backup was done… if you have bugs again, just close Audirvana and replace the .sqlite by one of your backups of it… more often backup… less chance losing things again.

1 Like

Hey RunHomeSlow: This looks like the solution as the folder is not visible. Will try and report back. Many thanks!

Just tried the steps RunHomeSlow outlined. I get to the “Users” folder but cmd J does not give me any option to see hidden folders etc

Can you try this instead?

  1. Open the Go menu of Finder.
  2. Pressing the option (or alt) key, and maintain it pressed. This reveals the Library command in this Go menu.
  3. Click on this Library command
  4. In the Finder window that opens, navigate into Application Support, then Audirvana
  5. You’ll find there the file AudirvanaDatabase.sqlite
1 Like

Thank you, Antoine, this did the trick.


That solution fron @Antoine is good i know, but you have to remember what to do if you have to come back to the user’s library for whatever need… difference with mine, is permanent, on every macOS system :slight_smile:

No, my desktop is not ugly like that, i made the picture smaller :slight_smile:

1 Like

Thank you RunHomeSlow for the visuals!

I am having the same problem. I went through these steps and deleted the files. I then tried to do a fresh install and to my surprise I got the same message again. I looked for the files again and there is nothing there.

I still cannot install the program. Any ideas?

you are on a Mac ?
installing is just dropping the application from the .dmg to the applications folder

so, you can’t play a song? from your local files?

The exact problem as above. I have looked for ALL instances of Audirvana on the system and deleted them. I don’t have any external drives attached to the M1 Mac Mini. I download a new install dmg and copy it to the application folder. Open app and it displays the Error /AudirvanaDatabase.sqlite is corrupt or does not exist. exit or create new database. I try to create and it gives me a warning saying that it cannot and only gives the option to close.

The system was working fine before. I had an issue with the external hard drive (single 5tb usb hd) not mounting before and decided to switch back to my 2 drive (2x 2tb usb ssd)setup.

This mac is only used for music playback.

There is no .sqlite file in application support?
You look in the Home library folder yes? Not the main library folder?

you can also try to delete your preferences of the Software…
in the home library… preferences folder and delete those,
you can have more then 2 there if you use studio or not Origin…

Restart the mac, restart Audirvana and it should start from beginning as first use