1.4.5 Freezes (again)

After having lots of freezing issues with the Windows AS versions up to 1.3 I’ve installed the new 1.4.5 this afternoon.

At first it seemed to work more then fine. Audio analyzing never got past 15% with version 1.3 and now it got to around 75% in one go. Which took about 6 hours with my 28k+ local library.

Then the same thing happened again like with the previous versions. Audirvana Studio freezes. And this time it’s even worse then before.

Before I had to kill the program through Windows Task Manager otherwise it would keep running in the background. X close button didn’t work after a freeze and closing the program by right clicking the icon on the taskbar didn’t close it either. Restarting the program afterwards made the whole analyzing start all over and freeze at 15% again.

Now with 1.4.5 after it froze exactly the same symptoms. But after killing Audirvana and restarting it, it now freezes immediately. The audio analyzing progress bar has reset back to 0, but there is now no more activity that it is doing anything. Closing the program normally now doesn’t work anymore either, so I can only quit Audirvana by killing it’s task in Task Manager.

Before the freeze I could quit Audirvana as usual, and the analyzing would continue as normal.

I haven’t checked the Mac version yet, but that one has completed analyzing everything in one go with 1.3 and 1.4 didn’t give me any problems either. So I’ll check that one again tomorrow.

I can play music just fine with both versions. Local music, Internet radio and Qobuz all work as they should.

I did notice something else as well. Audirvana’s RAM usage went up and down a lot.
At program launch it only uses a few hundred megabytes of RAM. But I’ve also seen it rise to nearly 5 gb, and when it froze it was sitting at 2,8 gb of RAM used. This was just analyzing audio. No music being played.

Even though my laptop has 16 gb of RAM onboard, I do think that’s a very high RAM usage.

It seems to me that overall Windows AS 1.4.5 is a big improvement over 1.3. But still has some serious issues that need to be fixed.

Edit:
As a test I’ve created a backup of the AudirvanaDatabase.sqlite file and deleted it from the Audirvana folder where it is stored in Appdata. Audirvana now starts as normal and closes as normal. But of course with an empty library and Qobuz login had to be redone as well.

Now it’s syncing my music collection and likely starts analyzing as again as well. When i copied the AudirvanaDatabase.sqlite back to it’s original location. The program immediately freezes.

So it would seem to me that all these freezes are linked to the database itself.

2 Likes

Sometimes, I get freezes after trying to change too many settings or when using cursor keys too much. Seems to me it is a problem with Studio’s use of buffers. I.e. this points to programming error.

And in your case, the buffers are overrun when using a complete database (as opposed to an empty one).

I have still the same problem than you after having upgraded to 1.4.5 (with fresh library) adding step by step the folders. The application freezes after few minutes. Same symptoms, same problems, same consequence except that this time I paid for 1 month.

Really disappointed : no support, no improvement, no communication, no remote…

Last question : is there somewhere a log to check the library analysis in order to see if any file is creating this problem ? It exists on Roon, lms or other …

Yeah I found a log file in the same folder where the database is stored. I’m not a software guy, but noticed that at the end the word fatal appears a lot. I’ve already asked in the general 1.4.5 error topic if there is a way to upload it. But no answer yet from Damien…

2 Likes

Ok thanks, I will read your post on the thread you mention

I tried to open this file in the database folder (AudirvanaDatabase.sqlite-journal) but always 0Ko…When it works, it seems it is writing something and after come back to 0ko.
This 1.4.5 version improves nothing in terms of lisibility of the Library Analysis

Well I’ve made a second analyzing run, this time adding folders 1 by 1. And started with the folder that was listed last in the first log file. And AS froze at exactly the same folder as the first time. Odd thing is, I have exactly the same local collection on my Mac. And AS on my Mac imported everything at once without a problem.

Ok i found the log file. Most of the errors are coming of “wav” files but also some flac with “error 4”

1 Like

You’ll find it in exactly the same folder where Audirvana stores it’s sqlite database file.

Ok this is the kind of error detected from my side

2021-06-19 11:06:11,481 [21] DEBUG Audirvana.App - Error -2147024894 opening media foundation file: file://E%3A%5Clossless_officiels%5CAnouar%20Brahem%5CKhomsa%20%281995%29%5CCovers%5C01%20Comme%20un%20Depart.wav

The problem is that the file is a flac and not a wav !

I have the same (AS 1.4.5 on Windows). I have AS installed on a dedicated music NUC (core i5, 16 Gb RAM, 512 Mb internal SSD). My music libray is on external USB drives.

AS shows ‘analysing files’. I have a disk monitoring tool in place and I see that AS produces lots of *.json files in a temporary directory. If analysing is around 20%. AS crashes and says that a dump file is generated. I can not make head or tails from the dump file. I do not have a clue in what kind of format it is.
When I look in the most recent log file (which is ca. a half hour older than the dump file) I see in the last line: errorcode = 4 in map Classical\Vivaldi…\allegro.flac. This file does not exist in the path mentioned in the log file.
I don’t know if these errors cause the crash, because (as said) the log file was older than the dump file.

I can play music in AS during analysis, until it crashes of course. After restarting AS starts analysing again and crashes again at around 20%. This takes around 2 hours to happen.

A simple solution would be if I could opt-out of the analysis proces altogether, because I don’t care for it. I’d rather have a stable AS than one that crashes everytime. Until now (since AS 1.0) the analysing process never finished. I had to re-install AS completely when 1.4.5. came and (to start completely from scratch) before I installed 1.5.4. I deleted the completel SQLite folder. So since 1.5.4. the analysing process basically started all over again.

@Damien3 please read this topic and try to provide a crash fix or an opt-out for the analysis proces. Clearly AS crashing every 2 hours on Windows is not a pleasurable experience.

1 Like

Same problem here on a MacBook Pro with macOS Catalina, after analysing files for quite a while Audirvana will crash and won’t start anymore reinstall only option, did that once will wait now till it’s fixed :slightly_smiling_face:

Of course if you’re not a programmer what it displays won’t likely be meaningful.

1 Like

Actually I am a programmer, but I was just too lazy to download an app to open it :smiley:.
But even if one is a programmer, most of the time the crashdump is only meaningful to the one who wrote the program.
In this case I choose to behave like a customer :rofl:

EDIT:
I can imagine this is tested by Damien with only a small music library on Windows. With a small library it probably succeeds, but after a certain amount of data it crashes. Memory leak??

1 Like

Andy,

You who are programmer, what do you think, why it is so difficult to deliver a working version of AS?

I had thought it might be, but I’m wondering. AS doesn’t crash for me, so I haven’t duplicated your conditions. But when it refuses to close with the X for me, it’s only using a couple hundred MB of RAM on my Win machine with 32GB. So the lack of responsiveness isn’t due to running out of RAM, I wouldn’t think.

1 Like

That is like asking an author why it is so difficult to write a good novel :grinning_face_with_smiling_eyes:
But basically this is quite a complex program which requires a lot of good planning, good preparation and good design. After that an extensive beta testing period with re-iterations of developing / testing / developing / testing etc.
It all depends on the size of the team, the project management and how the steps I mentioned before are taken.

1 Like

I asked you because I use a computer for 30 years, have probably 100 apps on my Mac, I participated twice in the public beta testing of macOS releases, and never saw so many problems in a release of an application.
Sure, it’s not a small utility, but it’s not a very complex application, like some professional applications that I use.

1 Like

You can be right. The strange thing is: I can close AS with the X button during analysis and others can not. I was just guessing about the memory leak, I did not really check how much memory AS was taking on my machine (NUC 16GB RAM). I have also seen that in the log file there are lots of errors about analysing files (error 4). Maybe it crashes on that somehow. Anyway I am just speculating, because I did not do a thorough research. The only one who has access to the source code and a debugger is Damien (and his team…).

Not at home at the moment. But RAM usage fluctuates a lot with AS. Anywhere from 1.5 to about 5 GB is wat I’ve seen here during analysis.