2.2.2 bug (Kernel streaming Extreme mode)

When moving to the next song, noise continues for about 0.2 seconds as if another song was playing.

wasapi and asio no problem

kernel streaming high mode is fine

The problem is Extreme mode

Moving to the next song is not smooth in Extreme mode

1 Like

I don’t think this is a bug. I don’t know what kind of PC you have, but I guess it is not powerful enough to handle extreme mode. In that case, stick to high mode.

I’ve had this issue for forever, with short bursts of white-noise or clicks between songs when using Kernel Mode in AS. Today, I tried it again and I’m able to reproduce the clicks in High mode as well as Extreme mode. Between the songs Time & Great Gig in the Sky on Dark Side of the Moon by Pink Floyd (24/96kHz on Qobuz), there is an audible click in both modes. This click isn’t present when using WASAPI or ASIO, and I’m guessing it’s system dependent.

Not sure if my current system will ever be able to do Kernel mode, but I was excited when I could faithfully reproduce the issue. :grin:

Edit to add: It hasn’t happened in Standard KS mode yet, but we’ll see how that goes.


Yep, that didn’t last too long. In Standard KS mode, there’s a click between “Shine On You Crazy Diamond (Pts. 1-5)” & “Welcome to the Machine” on Wish You Were Here by Pink Floyd (24/192kHz). Again, can reproduce and it doesn’t happen with WASAPI or ASIO.

Completely chuffed to bits by now one would think :thinking:

Similar to the really good toothache?

1 Like

I also have the same problem too. I want to reinstall version 1.9.But I do not know where can I download it?

I also have the same issue in every Kernel mode. Same annoying sound bite after a track. Especially annoying when I am playing easy listening music.

Can Development of Audirvana have a look at this now more and more listeners are experiencing this?

Exact same issue I am having, in every Kernel mode as well.
I am mostly using ASIO now because of this. Keep trying out Kernel though hoping this issue will be resolved.

We are a few versions of Origin further (currently2.3) and with each version I hoped that this issue was solved, but Development has still not solved this annoying issue.
Can Development have a look at this and solve it?

So, I had my C: drive crash several weeks ago, which forced me to install fresh Windows 11 bits (no clone backup, yet). When rebuilding Windows, I opted to not install the ASIO driver for my iFi Zen DAC, and since then Kernel mode is working fine.

I’ve heard that certain ASIO drivers might be causing issues with Kernel mode, and I don’t know if that was it or just the fresh Windows 11 bits that fixed it.

It solved my problem too.