3.1.4 crashing constantly

A+ 3.1.4 has been crashing constantly on one of my Macs for a number of days now. I start the application and it crashes after a few minutes, either as I am navigating through my library or as my library is syncing.

My library is large – 2.5GB. I have the library on two systems: one on an external HD on my laptop, and a clone of the first on a Drobo attached to my iMac. Both computers are running the 10.13 GM and Audirvana 3.1.4.The crashes occur on the Mackbook Pro but not on the iMac.

I have tried reinstalling the application normally, rebooting, repairing the filesystems on the boot SSD and on the external HD – no errors were found – and completely removing Audirvana (and deleting the SQLite database and any file with Audirvana in its name). The symptoms are unchanged A+ crashes after indexing for a few minutes.

I’ve put a couple of crash reports and a system report at https://www.dropbox.com/sh/1n9mo85ynwoaui7/AAA6ehad1z5E-GulHu9WI-5ua?dl=0



Try to do the 3 steps there before syncing…

I should have added that I tried that already.

The integrity check runs fine.

Indexes rebuild appears to fail – the Database maintenance and optimization window disappears immediately when I click on Start Indexes Rebuild.

Restart and defragment database runs for about 5 seconds before that window closes and the main window reopens.

By contrast, Index rebuild takes about 6 seconds on my iMac (duplicate of the same library) and Defragmentation takes several minutes (I gave up timing it after 2 min.)

Also, prior to my last installation I deleted the SQLite database as well as all application files, which would expect to have eliminated any database-related problems.

You can try starting over… i’ve put that many times here and elsewhere to help others:
Since one is working well, you could try copying the files i said to trash from the good mac to the other to see…

Start fresh A+ by deleting those files…

If you have Playlists that are important export them first to desktop and
save them in a folder… when A+ is reset, you can re-import them back.
sadly to this day, the folders they were in is not back, you have to do it again…

Before doing this, maybe you should not connect after deleting those files to Roon or others…
Install A+ alone with your database… if working, log to Roon or else after

Apple hide the Home Folder in User Library at some time depending on OS System… When you have clicked your Home Folder, and cannot see the Library Folder in there, just do a ‘‘cmd J’’ to show the folder settings preferences and see at the bottom… click Show Library Folder and then you’ll have access to the rest forever.

Starting for new A+:
Go to the Main Library Folder… PrivilegedHelperTools folder…
Trash All the files in that folder from A+ (that folder install SysOptimizer)
Go to the Main Library Folder… LaunchDaemons Folder…
Trash All the files in that folder from A+ (SystemOptimizer and prefs files)
Go to User… Home Folder… Library… Applications Support… Audirvana Folder…
Trash All the files in that folder (that is your database of music, back it up!)
Go to User… Home Folder… Library… Preferences…
trash com.audirvana.Audirvana-Plus.plist in that folder (those are A+ software preferences)
Go to User… Home Folder… Library… Caches… com.audirvana.Audirvana-Plus
trash the files in that folder

Restart MAC. This will reset pretty much Audirvana like new.

When choosing library at first it will sync in top right main window under the logo…
LET IT GO, even better don’t try to adjust windows or edit files, even playing music
while it is not finished… you’ll see the progress bar going… Could be long the first time
depending on how large your library is, and MAC is fast or not…

Well, I tried all of that. No joy.

Any other ideas?

You tried replacing the good ones files to the faulty mac…
Then you tried again by deleting all the files like i wrote, and starting from scratch…
still it doesn’t work. It loads but crash after a bit…

Nice bug :slight_smile:

Do you have a Fusion Drive in the Mac Pro? They have problems i’ve seen on forum.
if not, we know that your music is ok on the other mac… so is there something different in the macpro? you use a plugin or an external thing between your dac and the mac?

If A+ loads and play for a bit before crashing, i’ll try again deleting the database, and adding just bits at a time… like mine is 26 folders for all letters… so you can try putting a, b, c, d, e then sync… see if it crash… if not, add 5 more letters… and again. If it crash after the first 5, remove one by one still no crash… it may be just one faulty CD that cause that… Good luck :slight_smile:

I don’t have a Fusion drive. My boot device is a 500GB SSD and my music is on a 3TB USB 3 external HAD.

I have tried all of the above without success. In addition to the above suggestions I cloned my library to another HAD to rule out device related problems. No joy.

The last thing i have for you, is to reset the PRAM of your MAC, it does affect some of the sound component in it
and other things that might acted strangely since all is good on your other MAC… or return the faulty macpro if it is new :slight_smile:

Read this, easy and safe to do, pretty common things even on Apple site for MAC
you can also try resetting the SMC that is at bottom of page or like the guy says… do it first…


Thanks, I have done PRAM and SMC resets in the past.

I think that I will take a different approach now. It is probably time for a clean reinstall of the operating system and all my applications. It’s kind of a drag but I can partition my SSD and do it gradually until I am ready to move my data over.

Following up to close this out: I did a clean installation and fresh configuration of everything on my Mac from the OS up and the problem persisted in one of two forms: crashing, as initially reported, or hanging after a number of albums were added. I was finally able to get through adding my entire collection by starting Audirvana, letting it go until it failed, and starting where I left off. A painful process, but it worked.