3.1.5 Repeated Crash briefly after launch

I’m feeling pretty frustrated. I purchased an upgrade to V3.x and installed v 3.1.5. I have not yet been able to get it to run - initially in trial mode - for more than a few seconds.

I’ve tried all the suggested fixes - trashing the various files in the ~/Library restarting Mac etc, etc. I can’t get it to run.

I’m running High Sierra macOS 10.13 (17A365)

I’d really like a fix or a refund.

The same is occurring to me; but I’m a lucky man bc I’m in trial mode :slight_smile:

On High Sierra it looks like A+ is not able to manage a sqlite file bigger than 145-147MB.
A+ always crashes when building it and then crashes every time you launch it. Instead I can browse without problems its database with a SQLite browser

A temporary solution is :
• delete ~/Library/Application Support/Audirvana/AudirvanaPlusDatabase.sqlite
• keep the size of your A+ library under 145 MB (*)

This doesn’t happen on macOS High Sierra (installed from scratch, not an update) so I think that A+ is in troubles with the new macOS

Looking forward for 3.1.6


(*) I agree, it’s a really bad runaround…

Problem persists in 3.1.6

Have you tried to Optimize your Database?
Audirvana menu: File… Library… Optimize… Do the 3 steps there and see.

HighSierra has introduced a bug in the AudioFile services library of macOS, that crashes when trying to read some damaged audio files.
This has been observed with so called bookmark files created by another player. And this results in a crash at start when such a damaged audio file is in a synchronised folder.

I’ve made a workaround to avoid trigger this HighSierra bug in Audirvana Plus 3.1.7 I’ve just released.
Can you then download the trial version from audirvana.com (It is now the 3.1.7), and replace the application program with it.
Then you can launch normally Audirvana Plus.