5 files in folders, only two shows up in library

Hi, I have problems adding files in the library.

In the folders I have 5 songs in it, but after adding into the library only two shows up. Those didn’t show up are also .wav files, so file formats should not be the issues.

I have tried below method, but nothing improves.

"Go to User… Home Folder… Library… Applications Support… Audirvana Folder…
Trash All the files in that folder (that is your database of music, back it up! Or not)

Apple hide the Home Folder in User Library at some time depending on OS System… When you have clicked your Home Folder, and cannot see the Library Folder in there, just do a ‘‘cmd J’’ to show the folder settings preferences and see at the bottom… click Show Library Folder and then you’ll have access to the rest forever.

Restart MAC after, then Restart A+ and had a music folder… and let it load fully before trying somthimg else go to sleep if too long :grinning:"

Please kindly help how could I solve it. Thanks a lot.

Hello @ivanwing, can you run a test by drag and droping one of the missing file in the playqueue and check the metadata of it (label icon) to see if its look like the same as the 2 other songs.

hello, I open the missing file from the mac file, right click and open by Audirvana. And then I can just see the file playing at the bottom. I do not see anyway to click and see the metadata of it.

You don’t have to play the file, as i said earlier, you have to drag and drop the file in the play queue and click on the label icon (i squared it in the screenshot)

This is the missing file’s meta data

This is the file which could be added:

this is another missing file. But a few months ago I could add into folder. I just change a harddisk, and then these files could not be added.

When you go in the general section of your metadata, do you see something different between the missing files and the one that are synchronize by Audirvana?

For the general section, the only difference is:
For the missing file : ALBUM part i see nothing
Loaded file: ALBUM part I can see the path of the harddisk directory.

And I cannot mark 5 stars for the missing file, it said something like write/read authorization error.

You can then fill the Album part of the missing file with the same as the loaded file and it will be displayed in the same album.

I may find out why these files could not be added. When I wish to amend the tag, it shows as below:

For the added files, I do not have this issue, and these files are in the same directory. I put this directory both in my macbook’s harddisk, or in the external harddisk, it comes out with the same result.

How could I solve this problem?

I re-install back version 3.2.18 (3702), the mssing files are added successfully and work fine. So I think it is the newest version bug. Please help fix it. Thanks a lot.

Hello @ivanwing, can you run an integrity check your database? To do so you need to go to Audirvana Settings>Maintenance and click on Check

Yes, Integrity check is ok.

I also deleted the file AudirvanaPlusDatabaseV2.sqlite and restarted from scratch, but it’s still not ok.

And I just found out my another macbook, which runs 3.5.29 Audirvana and open the same folders, it shows up all the files on that macbook pro. Really do not know why this happens…

Your data are stored on a external USB drive or locally on your MAC?

I stored on an external Harddisk.

However, I also copied into my macbook’s harddisk, it’s still the same.

I just accidentally figured out how to fix the issue. I load all the files in the old version, and then reset my 3.5.29 and then migrate the database from old to new. All files show up now.

Please see if this may be a bug for your reference.

I think you just had to reset your preference so Audirvana would start clean but you fixed it by yourself, you made a good job :+1:

I reinstall my macOS again, and cannot find the file 3.5.29. Could you kindly provide a link for me to download? Thanks a lot for your help.


I think you have to check the integrity of the files not turning up in Audirvana. Download the programs “Audio File Health Check” and “Yale” and follow the instructions of locating and fixing file errors. (https://2manyrobots.com/plaster/ You download Yale from within AFHC.) Two very useful programs. You locate files with errors with AFHC and fix them in Yale. Sometimes you have to run the list of errors several times through Yale to fix them.

This helped me very much. I found a lot of files that showed up in iTunes but were missing in Audirvana. It seems like A is a lot more finicky about file errors than iTunes.

Hope this will help you too!

Hi, thanks a lot for your suggestion. I google Yale and AFHC but could not find where to download. Could you advise me where to download this software? Thanks a lot.