All local tracks greyed out after transfer to new SSD

My music has been stored on an external SSD connected by USB to the music pc.
Yesterday, I copied all files across to a new M.2 drive (which now has the same drive letter as the old one - D:)
Rescanning all files to the library took hours, but when I got up this morning, the process seemed to have finished. Now all my local files are greyed out, and do not turn up in searches on the device (only Tidal tracks are offered in search results).

The greyed out files play normally, with the Last Play field updating as expected, but they remain greyed out and do not appear in search results.

Hopefully there’s a simple fix for this, it’s obviously been caused by switching to a new music storage drive, even though the drive has the same drive letter and the same files as the old one.

I’ve also done all the database integrity checks, but this has not fixed the problem.

EDIT: some local tracks seem to be showing. All tracks that are in imported playlists display normally (not greyed out), some tracks in smart playlists created in AS are greyed out and some are white. It’s all a bit of a mess!

EDIT 2: I’m using AS on a Windows 10 Home laptop

UPDATE: the problem seemed to be a matter of duplicated tracks. All the duplicated tracks are greyed out, but they still play if you click on them.

I decided to just delete my database sqlite and start over. Process is under way now, but I am sure this is the best fix for me.

I also got duplicate tracks since the latest update…

Deleting the sqlite database file and starting over is actually pretty stress-free, as long as you remember to backup your favourites/etc using the option in the settings menu.

After doing that, which took relatively little time, the duplicate tracks have gone.

But this also means I’m losing the chronology, am I right ? It would be the third time for me, which makes it harder every time to remember which are the new additions to focus on in my library…

Yes, that is true, you do lose the chronology of Date Added, Last Played. For me, that was only a minor inconvenience, but it should be highlighted as some people will not like that at all.

@Antoine
I tried to rebuild the index using the maintenance tools of Audirvana (Origins) and I get “row 14735 missing from index tracks_parent_folder” error message… any clue ?

Greyed out tracks play just fine (which is the worst part because everything is played twice basically).

I tried to restore a 2-days old backup of the DB, problem is still here (I can’t remember when is the last time I launched Audirvana, but I remember a week ago it had a hard time to recognise new added titles and I had to sync the folder several times for the last addition to appear).

I sent you a message on it earlier this morning.

1 Like