Allow accents in files names

Currently Audirvana [Mac Version 3.5.39 (3569)] cannot add files with accents in the file name. This does not seem to be a problem for other players, and it would nice if it were not a problem for Audirvana.

How is formatted your hard drive, what type?

Mine on mac catalina 10.15.6 has many groups with accent, i’m french canadian, no problem

Good to know!

I’m using a nfs mount. I’ll try with a local directory.

EDIT. nfs not nsf

don’t know that format… but Damien is French from France so…
accent is logical to works i think :slight_smile:

1 Like

Mine is APFS Apple Format

I can add this local (on my Mac) folder

Ophélie Gaillard - Carl Philipp Emanuel Bach (Édition 5.1) (2014)

But the same (i.e., a copy) folder mounted with nfs fails to be added. I don’t have room for local copies.

Well, you can remove those accents…
or wait for @Damien3 to allow that on that format system…

Here is the nfs mount info

nfsstat -m
/Volumes/multichannel from 192.168.1.23:/raid/music/multichannel
-- Original mount options:
   General mount flags: 0x0
 NFS parameters: deadtimeout=45
 File system locations:
   /raid/music/multichannel @ 192.168.1.23 (192.168.1.23)
-- Current mount parameters:
   General mount flags: 0x4000018 nodev,nosuid multilabel
 NFS parameters: vers=3,tcp,port=2049,nomntudp,hard,nointr,noresvport,negnamecache,callumnt,locks,quota,rsize=32768,wsize=32768,readahead=16,dsize=32768,rdirplus,nodumbtimr,timeo=10,maxgroups=16,acregmin=5,acregmax=60,acdirmin=5,acdirmax=60,deadtimeout=45,nomutejukebox,nonfc,sec=sys
 File system locations:
   /raid/music/multichannel @ 192.168.1.23 (192.168.1.23)
 Status flags: 0x0

Hello @mkt, have you tried to use SMB instead of NFS?

I don’t think that I have SMB configured and running on the server.

I took a look at the nfs mount options and maybe nonfc is a problem.

Adding the line
nfs.client.mount.options = nfc
to /etc/nfs.conf seems to fix it :slight_smile: