An album cover bug plus solution

I had these four albums in different folders, with different artwork enclosed, and with different ‘album’ names in the tags, yet Audirvana was displaying them all with the same artwork from just one of the directories:

Blue Break Beats Vol. 1
Blue Break Beats Vol. 2
Blue Break Beats Vol. 3
Blue Break Beats Vol. 4

The artwork worked properly in another music player, so I was really baffled. I re-saved the JPGs, I re-tagged the files, double checked everything. Nothing worked.

Today, I decided to try removing the periods (’.’) from the directory names and … voilà! It suddenly worked. It seems that Audirvana stopped reading the directory names after the period when searching for artwork. This kind of bug can drive you crazy so I was very happy to finally solve it and to share it with others who might be experiencing a similar issue!

This issue also appears with two successive space characters. In general Audirvana does not like special characters either in folder names or in file names.

Well, I haven’t noticed that to be a problem. I have all sorts of special characters in file names and folder names and these don’t appear to cause any issues.

Examples:

Elīna Garanča - Romantique
Röyksopp - Melody A.M.
22. Cançó i Dansa No. 13 Cançó.flac
07 Elizete Cardoso - Eu não existo sem você.flac

Maybe because I use CUE sheet. For example this one doesn’t work (Audirvana PC):
FILE “Coldplay (2002) – A Rush Of Blood To The Head_Side 1.flac”

Perhaps. I have had so many problems with CUE sheets over the years (not just with Audirvana) that I have deleted them all and I am much happier without them :slight_smile:

That’s certainly true but I have so many CUE Sheets now that it would be hard to go back.