Apple AU presets not saving

Ok, this seems to be an old issue but for me, who only yesterday started using this fabulous feature, it’s a new issue.

I’m using Audirvana 3.5.44. I can configure AppleAU Graphic EQ and it’s working (i.e. it definitely makes a difference to the sound) but I can’t save it as a preset. I tried everything. No way will it save it. And as soon as I flip that switch to ‘no effect’ I lose the configuration and am back to a flat curve. The name on the preset list remains but the curve is flat again. I was so happy when I realised that the annoying idiosyncrasies of my headphones and my speakers can be cured by the subtle use of the AU equilizer - while completely preserving the SQ - but running into this glitch today totally brought me down.

I tested the AU extensively in version 3.2.8 and it worked perfectly.

Does anyone know any fix for this?

Damian, if you’re there, can this situation be improved, as it’s clearly a glitch that shouldn’t be allowed to persist for so long? People have been complaining of this going back to 2019, if I’m not wrong. Please, at least a workaround that doesn’t involve re-drawing of the curve every time I need to switch between two presets.

I can also add another aspect of the same AU glitch. When I try to open AUNBandEQ on the list of plugins it won’t open.

I’m on El Capitan 10.11.6.

I just added this link above in order to wake up this post with Audirvana 3.5.44 problem that remained unanswered for so long.

How I have used it;

Set the EQ as desired. Click on the ‘plus’ (+) so that you get the opportunity to give a name to the eq preset.

When this is done, select the preset and click on ‘save’. Then it is saved which preset should be used.

If you want to make an adjustment, click on the preset. Make the adjustment and for this you create a new preset. Then you save that this is the desired preset.

Maybe not obvious, but that’s how it worked for me.