ARC 3 plugin with Audirvana

I don’t know if this is the proper category for this issue but Im sure someone can enlighten me.
I have ARC 3 plugin setup on my Mac 10.15.6 with Audirvana, but it does not seem to be having any effect according to REW.
The Apple NBandequalizer works fine in Audirvana, but when I measure before and after with REW, setting the ARC plugin Correction switch to Off or On, the REW plot is the same.
As I mentioned. This experiment with other Apple AU plugins works properly.
The configuration/editing functions of the plugin seem to work fine in Audirvana, but they just have no effect on the ouput from the system. This is the case both using upnp to my Naim Nova or using headphone out of my Mac into the analog input of the Nova.
Any comments greatly appreciated. Thx

Further investigation shows it does work if you turn on Realtime control in AU section. However I then tested it with UPNP and The ARC plugin has no effect even when Realtime control is on. That us a real problem for me as thats how I connect to my Nova. @Damien3 is there any workaround for this? Thx

Hello @Moto,

I tried with the Apple AUDistortion with the real time control activated and the plugin is not activated. In fact UPNP with the real time control do not work because there is some latency if you change the settings in real time mode. We had some request about letting real time mode even if there is some latency to it, we will work on it but for the moment you need to configure your plugin before playing your track.

@Damien3 thx fir the response but here is what I find.

  1. Using Airplay or headphone out from my mac
    A. Realtime off then no effect from ARC plugin
    B. Realtime on then plugin works properly
  2. Using UPNP out from mac
    A. Realtime off then no effect from ARC plugin
    B. Realtime on then no effect from ARC plugin

In summary the ARC plugin has no effect with Realtime on or off when using UPNP but works properly with Realtime on and using headphone or Airplay output.

  1. The Apple NBand Equalizer plugin works properly with headphone or Airplay out whether Realtime is off or on.
    The NBand Equalizer works properly with UPNP with Realtime on or off.

Thus it appears that the only problem is with the ARC 3 plugin using UPNP not working whether Realtime is on or off.

Can you think of anyway that I can make ARC work in some way over UPNP? Thx

I don’t know how this plugin has been developed so can you try to contact them?

Well I contacted them and their answer was basically of no help at all. Anyone have any other ideas?

Thanks for your patience while we got back to you.

I am not sure about this, it sounds like a very specific setup and settings here. It would have to be fully tested, but I have tried it in many applicatons and it has worked.

We hope this response has sufficiently answered your questions. If you still have any question, interests, or concerns, please reply to this email and an agent will get back to you as soon as possible . Please make sure to reply to this email and do not open another support ticket.

So they clearly didn’t tried to reproduce your setup to understand where the issue might come from…

You have this displayed when you open the Audio Unit?

I have never seen that message

As I said above it works fine with airplay and headphone analog or toslink output from the mac. It just doesn’t work with upnp.

I use the Dirac VST plug-in. The plug-in is only working with realtime active. But in upnp realtime use of plug-ins is not possible.
So now I use USB to the Hegel and it works.

That’s interesting. So it is not just the ARC 3 plugin that doesn’t work with Audirvana over upnp. I wonder what it is about the way both of these plugins are written that causes them to fail with upnp.