AS 2.2.4 and Ventura 13.2.1 Sys Optimizer error returns

Since upgrading to 2.2.4 I’m getting the following:
There was an error executing SysOptimizer. Not all optimizations may be done.
Error = The operation couldn’t be completed. (OSStatus error -1.)
Different OSStatus error code than before.

Any advice as this is proving to a a real problem with my headless Mac Mini system

Hi @davidp

I get that every time there is an update.

But the is a button to press, either “OK” or something that updates the SysOptimizer Ki think) and then program operates normay.

Can you see that button when you load AO?



Hi Phil

I do get the OK button but it cannot be pressed from the Audirvana remote. I run a headless Mac MIni and so to get that OK button pressed I have to either launch a VPN viewer on my iPad; log-in to the Mac Mini using Screen Sharing from a second computer or reboot the Mac MIni with the connected TV set switched on. None of which I really think I should have to do every time I want to play music.

I don’t think this is the same fault (which threw a OSsystem error -22) that happened when folk updated to Ventura with AS version 2. There was a temporary workround and then a fix in version 2.2.3(?). Apple’s error messages are opaque but somewhere in the Apple Community there’s a suggestion that -1 means a network connection error even though your Internet is up and running.

1 Like

Hi David

Oh. Yes. I’ve had that problem in the past. I no longer use the Mac Mini… I had huge trouble getting the remote to work… Now works pretty well so I transferred my AO to my main Mac… but that’s no help to you.

This only happened to me (SysOptimizer issue) when AO updates. Is that the same for you. If so, you might have a screen read to use with MiniMac on those occasions.

Unless @Antoine can help.

Send a message to

Sorry I can’t solve your issue quickly. Very annoying.


Thanks Phil for the suggestions and sympathy - I was hoping to hear something from ‘the management’

Just spotted the 2.5.5 update - Updated and resynced all folders - still giving the same OSStatus error -1.

It’s possible that they are out of the office for a while :man_facepalming:t2:

They are usuay pretty good but this problem is a problem with a headless system.

Hopefully, not sure how though, they can add a fix to the app.

But app has to connect to the program. Program can’t start without that fix.



Have you tried using disk utility and running the first aid option on your disk? OSStatus error 1 is often associated with file/disk permissions errors from past experience.

Thanks for the suggestion - I’ll give it a try and report back


I’ve run Disk Utility on all three partitions (Macintosh HD, Macintosh HD Data and Mac OS Base system). No errors reported all clean. Restarted the MacMini - launched AS and as yet no OSStatus error code - again I’ll se what happens when I switch the DAC back on later tonight.

2.2.5 is the latest version.

FWIW I run a mac mini headless and I don’t get that error with updates. I’m on the same version of Ventura.

I’ve updated to 2.2.5 and got the same error - so far this evening there has been no return problem but I’ll wait till I switch back to the DAC for another listening session before claiming things are fixed.

Another clear day and no return of the OSStatus error. Looks like the restart was all that was needed.

1 Like

Hi @davidp,

I wasn’t here for some time so couldn’t answer you (no, Audirvāna is not on strike @OffRode :stuck_out_tongue: ).

So the ‘restart your computer’ thing worked in your case, good to know that. If you have this error again, please come back here and I will help you find what is going on :wink:

1 Like

I figured you either headed for the ranch or optionally were out on the streets causing mayhem :wink:
Good to see you made bail :stuck_out_tongue_closed_eyes:

Many thanks - working fine for last two days

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.