AS and Remote not sharing a correct App status

Dear all,
Here is my issue, easy to reproduce:

  • First, I use AS to play an album through the main interface using a remote access to my Mac Mini (Headless one).
  • Then, later on, I switched to my Ipad and tried to change the audio device:
    • First, sometimes, instead of having the list of devices on my iPad, I get an empty window
    • Then, when I get the list of devices, it’s impossible to change the audio device
  • In that case, I have to move back to another room to use the AS main IF and release the audio device so that I can change it via my iPad
  • What could happen also, is the impossibility to play a track because there is an error (Such us this recurrent thing about SysOptimiser failure) only visible through the main Interface.

My understanding is that AS and Remote are not able to share the same application status and Remote is not able to show the reason why an action is not possible.

To change settings, the audio player must be stopped. You can also stop the player with the remote. So don’t pause, but really stop. Then it should be possible to select a different output.

Thanks Jacob,
But thing is that as seen from the remote perspective, the audio device is not locked. It is reported to be locked only from the main IF from AS. Which may me think that the correct status of the audio device is not reported to the remote.
So, in that case, after having played a track from the main IF without unlocking the device, you cannot unlock it from the remote as I reported.

I don’t use a studio, but I think if you hold down the pause button longer, this becomes the option to stop. And so unlock. Please correct me if I’m wrong.

You mean you don’t use remote I presume. Yes normally, if you click on stop on the remote then you have the option to unlock the device. But thing is that playing was started from the AS main IF and not from the remote, so there is no Pause button active from the remote.
Anyway, I’m going to see if I can reproduce the problem and see if I can solve it from the remote without using the main IF.

I stopped using Audirvana Studio. I only used it the first year. In the meantime, I’m using Audirvana 3.5 and use the forum to monitor how Studio develops and testing with alternatives. The messages on the forum are not very positive about studio.

1 Like

OK, I just tried it again: started to play from AS then stopped, and the status is correctly reported on the remote and I can unlock the device.
Anyway, after unlocking the device via the remote, changing the audio device is not easy: empty window first when opening the devices list, then very slow change to a new device.

OK, I will try to build a full and easy to reproduce sequence leading inevitably to the issue. because, what I know is that issue occured several times…

1 Like

Similar to me. What do you think about the SQ of Studio vs 3.5?


1 Like

In my memory, studio sounded a bit better than 3.5 at the time. My situation was a Hegel Röst over USB. I think it was a bit more relaxed/cleaner.

1 Like

Hi @patifr,

Thank you for sharing your thought about this. Once the beta for the next iOS beta update will be available, maybe you can try to reproduce this behavior?

Bonjour @Antoine,
Yes, with pleasure.