Audirvana 3.5.50 can't stream from Qobuz

Yesterday Qobuz files began to struggle to load and play. Today, disconnecting and reconnecting Qobuz in preferences seemingly solved the issue. But a few hours later the problem returned and now the streaming of Qobuz files won’t happen at all. Very strange. Switching off upsampling in Sox makes no difference. I’ve no idea where to start to troubleshoot.
I’m using a MacMini running on El Capitan which worked flawlessly until yesterday.
After trying to play an album from Qobuz favourites what happens is that the play queue is created but the first track doesn’t load and no sound comes out. From this point on even local file play back is impossible until a bit later when local music play back can resume.
Internet connection is via Ethernet measuring over 250mbps. I’ve performed a restart tens of times. In many instances I had to force quit Audirvana because it would be non responsive.
Any good suggestion is welcome.

I’m gonna reply to my own query. :slight_smile: because I think I figured it out.

I’m a Qobuz Studio Solo subscriber and I have the Qobuz app on my phone as well as on the MM. Well, apparently with Solo you can only stream on one device; which either wasn’t the case in the past, or they allowed streaming on a mobile device and desktop. That’s my guess. What I know is that up until yesterday I could have Q on both devices but, apparently, not anymore. I’ve just logged out of mobile Q and tried to stream it on MM and voila, it works again!

From Qobuz small print:

Which all means that if I want to continue to enjoy Q stream on both my phone and my desktop I need to up my subscription from £13 to £18 (for Duo monthly), which works out 40% more!

1 Like

Hi S.Magus.

I’m also a Qobuz user. You shouldn’t need to upgrade your sub, Qobuz should stop streaming on any previous device when you start on an new one.

Hi pjmorley,

Yes, you’re probably right. Because the problem came back the next day. This time I looked a bit closer at the memory allocation slider in Audirvana’s prefs. It turned out the track preload was limited by the slider position that’s always been in the same place (around the middle). Recently I started upsampling to the max. I had added more ram (16GB) to make this work. But I left the max memory allocated slider in the old position. That wasn’t a problem with short and medium length tracks. But with longer tracks it simply stopped the preload. Maybe there’s an additional problem with memory purge not quite happening with a restart. I don’t know about these things enough to be sure. But now the slider is maxed up and the long tracks preload without a hitch. Apparently with my 16gb RAM at 384kHz rate of upsampling I get maximum of 58min. long track preload?

Problem still persists. Obviously, it’s unrelated to memory allocation slider. Track pre-load gets stuck as soon as it the play back starts, sometimes later, in the middle of a track.

Internet connection is solid and download speed is big. This started happening out of the blue. There were no recent updates to cause it. Activity monitor is showing nothing unusual. I’m stumped.

Sorry I can’t help more - you’ve tried everything I could think of.

Hi @S.Magus,

Given the recent issue, Qobuz experienced with their DDoS attack that, in the end, impacted the older version of Audirvāna, do you now still have your issue?

Hi Antoine,
I haven’t experienced the issue in the past 2 or 3 days, no.
This was definitely Qobuz related, as I was led to conclude in the end.
Thank you for taking interest in it, all is good now, enjoying Audirvana as usual.

1 Like

Thank you for trying to help pjmorley. It was Qobuz related as we figured out in the end.
All the best,