Audirvana 3.5 not recognizing local MQA file

I just checked a local MQA file with Audirvana. Audirvana did not recognize the file as MQA; Audirvana treated the music file as an ordinary 24/48 file.

Then, I renamed the music file from “01 Take It Easy.flac” to “01 Take It Easy.mqa.flac” (this is the name format used when purchasing MQA downloads). Now, Audirvana recognizes this as MQA. Quirky. Yet my less than $10 Android app (USB Audio Player Pro) recognizes either file as MQA.

I wonder if it is the same situation for Studio?

[Audirvana 3.5.46, Windows 10]

It should be the same. Just keep the MQA extension and you‘re good. If your DAC is MQA decoder it doesn’t matter anyway. It will recognise the stream as MQA.

1 Like

What is weird is that Audirvana must read the control stream in the MQA file to determine that it is MQA 192, However, Audirvana only does this after it determines the file is an MQA file via the filename.

I disabled MQA in my DAC so that I can select the filter for PCM files. With MQA enabled, all PCM files use the MQA filter.

That’s a known flaw with some DACs. It’s not a fatal issue as there is a reason why MQA insists on minimum phase filter. It’s suppose to sound more natural. Others complain that is somehow creates time domain issues. Jury is still out on that one.

With my Dac too, enabling MQA provokes changes that I don’t want. So I disabled it.
As I’m not a Tidal user, I have just a few MQA albums that I bought out of curiosity to see how MQA sounds.

1 Like

@OldHardwareTech has tested this in Studio and the behavior is the same.

Here is an explanation of the process from @Antoine:

I have to disagree. The software only need check a few bits at the front of the file. The software doesn’t have to begin decoding. I do not see much savings doing it the Audirvana way. Also, you could check the file just once and have the MQA marker saved in Audirvana’s database. Indeed, USB Audio Player Pro (a cheap Android app) doesn’t exhibit any delays by skipping steps 1 and 2 in Damien’s post.

I should also note that Roon, unlike Audirvana, doesn’t require the MQAENCODER and/or ORIGINALSAMPLERATE file tags nor “mqa” appended to the file name in order to correctly identify the file as MQA 192 (or whatever).

Also, note what Damien says about Qobuz in his post:

That’s why as these are not present [i.e. “metadata hints”] in the files streamed by Qobuz, such MQA-CD track is played as normal PCM track.

Very interesting.

2 Likes

Interesting, never tried to check for MQA tracks on Qobuz. It’s a good news for Qobuz users with MQA capable DACs and DAPs.