Audirvana interface is not particularly smooth

I use standard 100% scaling in Windows

OK, but did you try changing the zoom-slider in Audirvana itself? See the red marking in the picture in my previous post. Does that make a difference in the smoothness of scrolling?

Just for reference, a 6K screen set to 4K resolution. Screenshot of AS. Smooth scrolling for me on a Mac. What graphics capabilities does your PC have? If you are running an older Intel machine with integrated graphics I can imagine trying to push a lot of pixels it might struggle. I have noticed when running scrolling at 4K resolution the % system resource usage increases significantly (basically one core maxes out). So maybe this is also occurring on your PC, have you checked this?

And in extremis, running at native 6K, best performance as to get the 4K resolution I use a third party app Better Display to overcome some of the resolution limitations of Apple’s resolution settings for the display. Display only runs at 60 Hz so not the fastest. Maybe I’m just lucky…

Scrolls also fine on my Windows PC in 4k.
My Windows 11 PC is a NUC (8th generation) i5, 16GB RAM with internal Intel graphics, running as a dedicated music computer on my 4k Samsung television. My local music library is connected via a external USB drive to the NUC.

@GucciBoss can you give some more information about your computer (processor, RAM, graphics card)?
Also how is your pc connected to your music library (Ethernet, WiFi, NAS etc.)?

Audirvana caches the images from the disk/NAS/streaming service where the library files are. If that connection is (relatively) slow it can happen that you see some delay while the images are loading. I had Roon for a year and (in my case on the same NUC) Roon was slower in this aspect than Audirvana.

I use i5 8400 , gtx 950 and 16 gb RAM with ssd and still have some problems

I have an older Macbook Pro. no scrolling issues at all.

Similar to @AndyLubke, I also have an Intel NUC (8th gen), although i7 with 32Gb of RAM.
No scrolling issues whatsoever, although when clicking on an artist with a few albums this may take a couple of seconds to load.

This is how it looks on my end : kDrive
Everything is located on an external SSD (clocked at 950MB/s), most artworks are 500KB and below.
M2 Pro, 16GB of RAM, running 14.4 (Sonoma).

I see your issue! Nothing like the performance I see.

As such I would suspect that you should focus on the external disk operations. Not aware of your external disk manufacturer/model/format etc. However seeing as you are getting 950 MB/sec I would infer it is a USB drive

Sonoma has a serious problem with USB drives formatted as ExFat. Apple changed significantly how it handles ExFat drives in Sonoma moving it from kernel level function to a user level function which has resulted in many performance issues. If your drive is formatted as ExFat I would move your files temporarily then partition as a GUID Partition and format as APFS then copying back.

Only thing I can think of as your Mac should not behave this way with AS. Other things that may impact your issue could be screen capabilities/connection etc but again not sure what you have. I should state I use Thunderbolt SSD’s with my Mac to avoid the many issues reported since Ventura with some USB disc controllers to avoid random disconnect/performance issues.


I should also add that updating to 14.4.1 is a good idea. 14.4 was acknowledged in the Mac media as one of the worst updates Apple has put out (largely due to a rush to meet the EU DMA compliance deadline or face massive fines). Probably won’t resolve your issue but a good idea anyway as the 14.4 release had some significant issues.

1 Like

I appreciate but I think you are missing a point here as I have to repeat myself, I have this type of performance since 7 years, it never improved. The data was externalised only a year ago.
It was the same on a MacBook Pro Intel i7 Touch Bar 16GB of RAM with SSD (local)
It was the same on a MacBook Air M1 8GB of RAM (local, totally different and smaller library)
It’s the same on my MacBook Air M2 16GB of RAM (external)

This drive is a 1TB Samsung 980 Pro NVMe M.2 in a Sabrent case. USB 3.2 Gen 2 connected with the appropriate cable, APFS. I measured the performance through BlackMagic’s speed test tool. It also hosts my photography RAW files (and all datas including high res thumbnails) and, as you can expect, scrolling in CaptureOne is smooth like butter.
I’m using the latest OS (so yes it’s 14.4.1, I didn’t think it was relevant).
Scrolling is smooth as expected on (datas are located on the same external drive, and to avoid any sort of conflict, wasn’t running when I took the capture).

I’m really curious to see how different it is on your end (including clicking on an album and going back to the list). I know Audirvana doesn’t read the artwork directly, it even seldom updates it (some people complained, if you fix a cover art, Audirvana will keep the old one for a long time, weeks or even more). Maybe there’s also something about that cover art database ?

Will try and capture a video and post. Away from my desk at the moment.

Here you go. This is what I see when scrolling moving around in AS. To try and simulate yours it is running on the MPB screen set at 2056 x 1360. To simulate your experience I switched my library to a connected Thunderbolt SSD. The only other thing taxing my computer is that, funnily enough, Capture One Pro is batch processing some images on an attached Apple Pro XDR display (6K)

Thank you for sharing :slight_smile:
So, you still get the blinking when switching from one view to another, but scrolling, although doesn’t seem to be the smoothest, is much smoother than mine. I wonder why. I’m thinking, could this be an input behaviour ? I’m using a magic trackpad (and have always been using a trackpad), while your scrolling seems to be from a mouse. Maybe Audirvana has a hard time with the inertial scrolling of trackpads (I don’t have a mouse to test) ?
That wouldn’t address the loading, but the choppiness could be from that. I remember a very long time ago, when inertial scrolling was introduced in macOS, Firefox wasn’t working well with trackpads and it used to be very choppy compared to Safari (of course it’s been fixed by Mozilla).

[edit] So I disabled inertia from the Accessibility tools of macOS, and it shows that Audirvana’s inertial scrolling is “emulated”. While I disabled it systemwide, it remained in Audirvana (choppy as usual, but still here). That could explain why scrolling feels different in Audirvana from the rest of the OS and apps.

1 Like

The blinking if you look closely let’s say on going back to the album view is not a lag. It shows the top of the album list then loads the last view. You can, as it flashes, see the 1975 and Adele albums (the first page of album view) for a split second before it loads the last album view page which was at Simply Red. This is further illustrated in that when I click on say DSD albums or Recently Added there is no “blink” as the number of albums in these views do not exceed one page. Scrolling is fine for me. The only lagginess I see is if I am connected to a streaming service where it will delay loading a local album until it has loaded the additional “Albums by this artist” from Qobuz. It is why I disconnect Qobuz and only connect when I am looking at a discovery session.

My scrolling is with the MacBook Pro trackpad but the sensitivity I set to fast so can seem a bit jerky. I do this to navigate the 32.5 inch Apple display quickly. The inertial scrolling is clearly not optimised in AS compared to some other apps I.e Capture One, on that I can agree.

I should add that at the time as taking the screenshot I was batch processing raw files taken with a Sony A7R mk IV (64 megapixel full frame) to get a worst case view with the system being under load.

Apparently everything works much better for you than for me on Windows, maybe I need to reinstall everything, since my interface seems to run at 30 fps while everything is much smoother with you, I also constantly receive a message that Audirvana is running as administrator, but I don’t know if this affects the results

To fix this enable UAC. Set UAC to low If you want to avoid annoying messages. You need to restart your computer.

Unfortunately my last experience with Windows was Windows XP so I can not offer any advice. I, like you and @Yohmi, do think there are optimisations Audirvana can do in terms of scrolling and loading of previous views to optimise the appearance of “smoothness”. Hopefully future updates will improve the situation for everybody. :crossed_fingers:

Yes it would be nice since everything regarding sound output suits me completely

1 Like

Hi guys, I do have a 144hz display at home and will try to check the smoothness while I scroll as soon as I can.

1 Like

okay that good idea