Audirvana linux not seeing DAC

I have just installed audirvana linux on an ubuntu server (minimised), walking in the steps of Jud. This has been a bit of a challenge, my experience with Linux going back to the late 90s.

At this stage audirvana is up and running, and my remote app can connect to it, however, my DAC is not recognised. Under Configuration > Audio > output device, I get : Error: no device selected.

My DAC is an OPPO HA-1. Is there something I should do on the server to get things going ?

Hi @parnaud,

What do you see in the logs of Audirvāna?

~/.local/share/audirvana

Hello Antoine,

here the content of the log:

parnaud@musicserver:~/.local/share/audirvana$ cat audirvana_studio.log
2024-04-19 09:47:34.894 [info]: ============= Started Logging, Audirvana Studio 2.8.1.3 linux =============
2024-04-19 09:47:34.897 [info]: No language set in settings, using system language: en_US.UTF-8
2024-04-19 09:47:34.971 [warning]: EULA not accepted yet, showing it
2024-04-19 09:47:34.979 [info]: RemoteServer: Server started and advertised on port 37959
2024-04-19 09:48:31.544 [error]: Not logged to Audirvana account: need to sign in

Not much to read !!!

Just a bit of additional info. It seems that linux “sees” the device:

parnaud@musicserver:~/.local/share/audirvana$ lsusb

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Bus 001 Device 002: ID 22d9:0416 OPPO Electronics Corp. OPPO HA-1 USB AUDIO 2.0 DAC

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

So I would suspect it’s Audirvana not connecting to the DAC. When I run Audirvana from my macbook, it detects the DAC just fine.

When you connect to the computer running Audirvāna with your phone, were you asked on the phone to accept the license and then to click OK in two messages to indicate you are logging off of one computer/OS and logging into another?

Hi Jud,

I definitely received the message indicating I was logging off of one computer and logging to another.

regarding the license message, I seem to remember that I did have that message

OK, good. And then the Oppo isn’t showing up in the list of outputs you can select, even though your computer running Linux sees it, I gather. You’ve tried stopping and restarting Audirvāna? What about stopping and disabling it, then enabling it under your username?

(BTW, which distro is this?)

Followed your steps ! Using Ubuntu server minimised, same version as yours.

I’m going to try stop and restart.

Not sure how to disable audirvana.

In the folder with the service file (/opt/audirvana/studio), issue the commands:

sudo ./setAsService.sh stop
sudo ./setAsService.sh disable
sudo ./setAsService.sh enable [your Linux username]

Thanks for the info. I stopped and restarted audirvana, no improvement. here’s the feedback

parnaud@musicserver:/opt/audirvana/studio$ ./audirvanaStudio
2024-04-19 13:57:26.528 [info]: ============= Started Logging, Audirvana Studio 2.8.1.3 linux =============
2024-04-19 13:57:26.528 [info]: No language set in settings, using system language: en_US.UTF-8
2024-04-19 13:57:26.539 [info]: RemoteServer: Server started and advertised on port 41703
2024-04-19 13:57:27.497 [info]: UPnP stack initialized using default interface
2024-04-19 13:57:27.697 [info]: UPnP web server started on 192.168.1.67:49152

Port has changed from the first start.

I’m going to try what you suggest above.

I have just disabled and enabled audirvana under my linux username, to no avail.

I’m starting audirvana from the command line. Should I be using the setAsService script ? If so, how ?

@Jud,

I tried everything you suggested without any luck. Another problem I have is Seem unable to mount the synology smb share where my local music is. I’m mentioning this as I did a minimised install, and am wondering wether I might be missing some packages causing both problems.

The commands you’re issuing are using the script (the script is just the setAsService.sh file), so there’s nothing else I know to try along those lines. Hopefully someone who knows more than I do can help!

Thanks a lot for your help. Just one more question. I am laughing the audirvanaStudio executable directly from the command line, not using the script. Should I use the script instead to launch, and in that case, what syntax should I use ?
Maybe @Antoine will a a brilliant idea regarding my issue !
Have a good day !

Well, I believe my issue was trivial : I was starting Audirvana from the command line, launching the executable with : ./audirvanaStudio, bypassing the sh script. Launching it with sudo ./setAsService.sh start has solved my issue. Audirvana now connects to my external DAC just fine.

I guess the lesson here is : RTFM !

@Jud, many thanks again for your kind help.

Time tio listen to some music, finally !

2 Likes

Yay!:+1: