Audirvana Not playing w Tidal

Got trial version and trial version of Tidal to test it out - Have MacPro running High Sierra - Apple merge of iTunes worked great BUT Tidal not working. Spend entire Sunday morning trying to correct and see if the problem has been addressed by all of the knowledgeable people associated with this app - it has not worked and no answers are in the chats. I really expected so much more from this. Thanks and Goodbye. Shame

It says “Unable to open for playback” - seems like many people have had this problem. Surprising that it’s not corrected.

You’re a bit hasty. It’s a recent issue, and it appears to be on the Tidal side. Stick around, you might still enjoy your Audirvana experience.


You must be more patient. A Sunday morning is nothing.
Trey with another Mac, try with Qobuz…

1 Like

Thanks for very prompt reply. I will stick around - the UI is nice and a huge improvement over Apple content. Will try Quboz instead and stick around. Thx

This topic was automatically closed 375 days after the last reply. New replies are no longer allowed.