Audirvana not taking exclusive control of audio?

I’m pretty sure nothing else should play on my speakers while Audirvana is playing? If so, that is not happening. If I open the browser, go to youtube and start a video, both music and the video’s audio come out of my speakers.

I’m using Kernel Streaming btw. I think something on my PC overrides audio drivers because on my previous music player, WASAPI exclusive or ASIO would also not be exclusive at all.

Should I bother with this and, if so, what can I do?

Did you check the settings in Windows itself for your soundcard? You need to allow in Windows that the soundcard can be accessed exclusively.

  1. Press Windows+R
  2. Type mmsys.cpl into the run prompt, then press Enter
  3. Right click the speakers or headset you use with Audirvana and select Properties
  4. Click the Advanced tab
  5. Check the box for Allow applications to take exclusive control of this device
  6. Click Apply, then OK
  7. Repeat steps 3-6 for all the soundcards you want to be exclusively accessed.

You need to do the above for the soundcard you use with Audirvana.

Below is a screenshot of the setting. Sorry it is in Dutch, but you should get the point. Both check boxes should be ticked. If you do not have those checked a program (like Audirvana) will not be able to take exclusive access and bit perfect play is not possible.


To answer your last question: If you want to have the best (and bit perfect) sound quality from Audirvana (or any music player): Yes you should bother with this :wink:


Thanks Andy, I’ve checked and the DAC had both ticks already. So did all the other audiodevices so I turned those off. But I still get the same behaviour… :person_shrugging:

You checked here?

Sorry to hear that. But you need to turn those check boxes on again anyway, otherwise exclusive access will not work for sure.

Hi @RunHomeSlow, I don’t even get those options in whatever driver I try. But I’m on a Windows PC, so could be that…

@AndyLubke I turned off those boxes for the internal board and the headphone DAC I also have plugged in. Just so I have Audirvana as the only one with exclusive access.

Hi @Kutusov I believe the options @RumHomeSlow showed are only available on the Mac.

Am I understanding correctly that Audirvana now has exclusive access with the boxes turned off? Or am I missing something?

No, sorry, I wasn’t clear enough. When I went to the sound definitions like you recommended, every single device had both boxes ticked, so I assume every single one had exclusive mode accessibility. I turn that off for every device except the DAC Audirvana uses.

And Audirvana is still not locking everything out, eventhough it says it is.

1 Like

Hi @Kutusov

You’ll hate me but…

At this stage I turn everything off (including the fridge), go for a swim, do the shopping, mow the lawn and sweep the yard.

(I don’t clean the pool. I gave a pool boy for that thank you.)

Then, I turn on the amps, DACs, and computers. Haven’t they gotten the message YET? Do WHAT I WANT.

If that fails I come back to @AndyLubke and ask him and the others. There will be a solution.




At the moment I am out of thoughts as well… On my system (NUC, Windows 11, Audirvana Origin) exclusive mode works fine with the same settings as @Kutusov described. I would not know what to advice at this moment.

1 Like

Ahaha, that solution seems about right to me :grin:

I’ll be going away from home for 2 months starting today anyway so, when I get back, I’ll just uninstall and reinstall everything back again. I’ll tell you how it goes…


Hi @Kutusov

Having a holiday or a break is highly recommended for good health (body and mind operati g optimally) so… you are likely to cone home refreshed.

Luckily I live in a small garden flat that has a loverly outlook… just glancing at the garden is refreshng, let alone sitting under the shade and having a read.

Nature restores us. Deep reading informs us. Going slowly allows us to think widely.

That’s why I say to turn everything off and take a break might just reset everything, including your mind.

{On a beautiful Sydney Sunday morning in the garden.)

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.