Audirvana not working with Aggregate Devices

Hi everyone,

I’m trying out the latest version of Audirvana on Mac OS High Sierra and it gives me an error when using an Aggregate Device.

I’ve tried swapping the audio kext thing with the old one which brought back Integer Mode but still didn’t fix the Aggregate Device issue.

I’ve found other reports of Audirvana not working with Aggregate Devices, most of them refer to the impossibility of using Aggregate Devices with Exclusive Mode.
Just to make it clear: I’m not using Exclusive Mode nor Integer Mode with my Aggregate Device.

Is this ever going to be fixed or is there a workaround?


Aggregate device is just a trick of CoreAudio to use different devices as if it was the same one.
This is not working with low level optimisations such as the ones used by Audirvana Plus, as aggregate device is mixing different devices.

Screen Shot 2019-10-14 at 12.04.29 pm

Hi I cant get Aggregate device to work with Audirvana Mac Version 3.5.23 (3553)
macOS 10.14.6 with 16384MB RAM
Can this be fixed?

I’m using an aggregate device for Atmos playback, and reply wish Audirvana worked with these devices. The aggregate is only for a single device.

If Audirvana worked with aggregate devices, I could play all my Atmos content from a Mac. Now, I have to use the Mac for Apple Music, and Windows PC for local Atmos content through Audirvana.


This is the first time chris has posted — let’s welcome them to our community!

Hi Chris, welcome to the Audirvāna community. Glad to have you onboard!

1 Like