Audirvana Remote connection issue to Windows 10

Hi Antoine,

I thought I would give the trial version of A Studio a try. However I see that the connection to Remote still requires that the firewall be off. I had hoped this would be fixed in the newer versions? I’m really not keen to live with my firewall down!

Thanks
Zane

Hi everyone,

I’ve been confronted to the same connection problem with my audirvana Remote application.
I tried to disable the firewall to see if it was really a blocking rule that was the cause.

So I decided to check what was the port called by my android to reach my windows computer.

It’s the 51140 Port.

So I just open this TCP port 51140, ensure all others incoming rules are opened too.
The connection can now be established for me.

Hope this can help!

Hello, I have everything configured as you describe, I use a PC with Windows 11 where Studio runs and I use an Android Nothing Phone One with Android 13 for Remote and I can’t get Remote to recognize my PC, I have sent you several emails but I have no response and I think that having paid the subscription to Studio for a year it would be nice if they gave me a solution.

Check the windows pc network type, it should be Private and not Public as in this case Windows firewall will deny any incoming connection

Thank you very much, but everything is configured as recommended, but it does not work.

Is your smartphone on the same network ? The smartphone network should be on the same subnet of the Audirvana pc (for example: the subnet should be 192.168.1 , pc ip address should be 192.168.1.xxx and the smartphone 192.168.1.yyy)

Thanks again, but yes, the IPs are the same on both.

Hello Jose,

like Stefano said, both devices have to be in the same subnet (ex: 192.168.1.0/24).
But each device needs a separate IP address to communicate.

For example :

Your computer :

IP : 192.168.1.12
Gateway : 192.168.1.1
DNS : your DHCP choice

The smartphone :

IP : 192.168.1.13
Gateway : 192.168.1.1
DNS : your DHCP choice

If you haven’t touched your network configuration on your devices, they should be in DHCP mode. So, it’s an automatic configuration applied by your router on your devices. If this router configuration is OK, you don’t need to worry about it.

It’s pretty sure it’s your firewall that blocks the communication.

Try this : (Sorry for the French Screenshots ^^ )

  1. Make sure that the notification parameter is correctly checked.
    (parameter > Confidentiality & security > Windows Security > Firewall and network protection > Firewall notification parameters)

  2. Delete all the inbound and outbound “audirvana” firewall rules
    (parameter > Confidentiality & security > Windows Security > Firewall and network protection > Advanced settings)

  3. After that, open Audirvana, your computer should ask you again the permission for the firewall.
    Firewall rules needed will be recreated.

image

  1. Test again :slight_smile:

Try not to have your library update automatically.

Hello, I use beta Remote on iOS.
When I open iPad from after certain time of sleep(i.e. an hour) by open cover, and touch app to open which is already running on background, it try to reconnect my Audirvana on Windows 10, endless waiting and on remote said “Trying to reconnect…”, I just touch connected device name and it start work properly.
Perhaps Remote app disconnect with Audirvana because iPad status is change to sleep by closing cover, but why it does not reconnect automatically when iPad is wake up from sleep mode? Windows Audirvana is running always, 24/7 without stop.
Firewall is ok because just manual reconnect or new connect is no problem… anyone knows why?



This is my last try on Lenovo phab 2 pro with windows 10 audirvana comp,what shoud i do next cos waiting leeds nowhere .It woks fine on my othet smartphone wich is way younger ,but the idea is to yus lenovo as remote to all audio ,and it works fine with yamaha sony and DGM remote swiches. iave tried to check the option given above and have no clue what is wrong ,mayby android is too old werion 6.0.1. ?? any help apreciated.

Are you using the latest version of Audirvāna Studio and the Remote app?

audirvana 2.8.1

app just downloaded an hour ago. but android is 6.0.1

Can you go in Audirvāna Studio Appearance settings and disable the option “Ask for a pairing code” and click on “Disconnect All”?

Do you still have your issue after doing this?

unfortunately yes, i have disconnected all my devices ,2, and reinstalled audirvana remote app on Lenovo and tryied to connect it with no success it is still giving this info on the screen: Error Version of the server is invalid. And then when i press OK its loading something …
My other phone connected with no issues.

Can you check if you can see Audirvāna using this app?

https://play.google.com/store/apps/details?id=com.druk.service

Do you see a service _audirvana-ap._tcp protocol in the app when Audirvāna is opened on your computer?

no,no see this service_audirvana-ap._tcp in the app but plenty of others