Audirvana starts before avahi-daemon and I can't connect using remote

Hi,

Audirvana starts before avahi-daemon and I can’t connect using remote. I have to add a delay in the service configuration:

[Service]
ExecStartPre=/bin/sleep 30

I’m using Ubuntu Server 22.04.

Is there a more elegant way to fix the problem? This change is reverted in each audirvana update.

In the latest update (Studio 2.8.1.5 and Origin 2.5.12.5), the service now waits for avahi-daemon before starting.
You may want to update.

Yes, now I can connect after reboot but in offline mode:

2024-05-13 16:13:21.338 [info]: ============= Started Logging, Audirvana Studio 2.8.1.5 linux =============
2024-05-13 16:13:21.338 [info]: No language set in settings, using system language: es_ES.UTF-8
2024-05-13 16:13:21.345 [info]: RemoteServer: Server started and advertised on port 41793
2024-05-13 16:13:22.484 [info]: UPnP stack initialized using default interface
2024-05-13 16:13:22.685 [info]: UPnP web server started on 192.168.1.100:49152
2024-05-13 16:13:22.714 [error]: UPnP Error 401 getting audio dB volume
2024-05-13 16:13:25.253 [error]: Chromecast device scanner: client failure
2024-05-13 16:13:25.255 [error]: Avahi Client failure: Daemon connection failed
2024-05-13 16:13:25.774 [error]: HTTP request error (7) Failed to connect to 192.168.1.41 port 8443 after 3067 ms: No route t>
2024-05-13 16:13:25.774 [warning]: Chromecast device added: error getting device capabilities: 0 for device: TV del Jordi add>
2024-05-13 16:14:08.912 [info]: ============= Started Logging, Audirvana Studio 2.8.1.5 linux =============
2024-05-13 16:14:08.916 [info]: No language set in settings, using system language: es_ES.UTF-8
2024-05-13 16:14:09.000 [info]: Entering offline mode
2024-05-13 16:14:09.042 [critical]: UPnP Unable to initialize UPnP stack at all: no network interface

If I manually restart the service, everything is working again.

Can you try to edit the service configuration, and to have the After= line be:

After=network.target avahi-daemon.service

Still not working:

2024-05-13 19:20:42.086 [info]: ============= Started Logging, Audirvana Studio 2.8.1.5 linux =============
2024-05-13 19:20:42.088 [info]: No language set in settings, using system language: es_ES.UTF-8
2024-05-13 19:20:42.787 [info]: RemoteServer: Server started and advertised on port 44475
2024-05-13 19:20:43.194 [info]: UPnP stack initialized using default interface
2024-05-13 19:20:43.394 [info]: UPnP web server started on 192.168.1.100:49152
2024-05-13 19:20:43.418 [error]: UPnP Error 401 getting audio dB volume
2024-05-13 19:20:46.646 [error]: HTTP request error (7) Failed to connect to fd6a:b84e:214c:2347:9c8:aa8a:7b4a:3db6 port 8443 after 3056 ms: No route to host for URL https://[fd6a:b84e:214c:2347:9c8:aa8a:7>
2024-05-13 19:20:46.646 [warning]: Chromecast device added: error getting device capabilities: 0 for device: TV del Jaume adding it anyway
2024-05-13 19:21:43.670 [error]: HTTP request error (7) Failed to connect to 192.168.1.41 port 8443 after 3048 ms: No route to host for URL https://192.168.1.41:8443/setup/eureka_info?params=multizone.grou>
2024-05-13 19:21:43.670 [warning]: Chromecast device added: error getting device capabilities: 0 for device: TV del Jordi adding it anyway
2024-05-13 19:22:22.031 [error]: Chromecast device scanner: client failure
2024-05-13 19:22:22.031 [error]: Avahi Client failure: Daemon connection failed
2024-05-13 19:23:06.602 [info]: ============= Started Logging, Audirvana Studio 2.8.1.5 linux =============
2024-05-13 19:23:06.607 [info]: No language set in settings, using system language: es_ES.UTF-8
2024-05-13 19:23:06.698 [info]: Entering offline mode
2024-05-13 19:23:06.745 [critical]: UPnP Unable to initialize UPnP stack at all: no network interface

I have tried several modifications to the service file and audirvana always starts too early. The only thing that has worked is delaying the start of the service:

[Service]
ExecStartPre=/bin/sleep 15

A 15 second delay seems sufficient.

Has anything changed in version x.6? The audirvana service starts correctly after rebooting the computer.

When you do the apt-update, you may have other packages being updated, which would explain why you do not have the behavior anymore, as we have not made any change regarding this issue on the Linux version.