Audirvana stopped seeing uPnP/DLNA speakers

I have been trialing Audirvana. Through the past week it was playing nicely through to my KEF LSX speakers on my network. Then yesterday I started having hiccups: Audirvana would play a track but not advance to the next one. Restarted the mac and tried again but same result. Then I restarted Audirvana and after relaunching it could no longer see the KEF speakers. I have changed nothing in my set up.

Unfortunately, there is not much you can do about it. Check if there are networking issues. This is a typical UPnP issue.

Well, looks like all these apps are such a disappointment. Audirvana can’t advance to the next track or can’t see the uPnP speakers; Roon keeps dropping connection, making for an infuriating listening experience; JRiver MC works without a problem but has a user interface from 1982. I think I may end up simply get a USB DAC like dragonfly, connect to the speakers directly and just use Vox.

1 Like

Hello @Brian, this is an issue that have been reported to KEF, their LSX doesn’t correctly implement UPnP standard and the command used to get to the next track. You need to contact them to let them know you have this issue so they can provide a fix for it.

Hi Damien - thanks for your message. Just shot an email to KEF. Fingers crossed! Will let you know when they get back.

To the original poster, may I ask if there has been response from Kef? I am also trialling Audirvana with a pair of LS50 Wireless speakers and I am seeing exactly the same symptoms you describe.

Hi DCOne
No, nothing from KEF, who’ve been as quiet as a church mouse!
But I did discover one thing, quite by accident: if I restart my router, then Audirvana is able to see my speakers on the network again! The problem with this though is that I have to restart the router every day or Audirvana loses sight of my speakers.
It might work for you too or may not, but worth a try.
Good luck.

Thanks for the response Brian. Audirvana always ‘finds’ my speakers on the network, but only plays one track before quitting. Neither a router restart nor a speaker restart does anything to help. I wonder if the difference in our speaker models is a factor?
In any event, have you tried entering a manual IP address for your speakers? You can do this by browsing to the IP address of the Kefs. Maybe that would help?
I’ll bang off and email to Kef myself, from your experience, it probably won’t make a difference but worth a try.

This is a UPnP implementation that lacks the proper settings to go to the next track. I sent a ail to KEF regarding this but never got a reponse form them since the answer i sent.

Hi DCOne again. You may be right, our different results maybe due to difference in speaker model. Or maybe even difference of router brand/model.
Yes, I did try a manual IP address but did not have any joy. That was before I found out restarting the router temporarily resolves the issues.
The problem with Audirvana does still come back but whenever that happens it is now a signal for me to restart the router or the app will soon stop seeing the speakers altogether. After router restart, everything is resolved for about 24hrs.
Another extra detail about my set up, if it helps: though my macbook (OS X 10.15.4) is wirelessly connected to the network, the speakers themselves are connected to the router via ethernet cable.
Anyway, good re a response from Kef. Do let us know if they respond.

To provide an update. I received a response from Kef this morning.
The support team member has replied that he has no experience of using Audirvana but would pass my request for assistance on to the development team.
Any further updates from Kef, I will post here.

I had the same issue when I got my KEF LS50 wireless and set them up. However, I switched computers and now my Audirvana license isn’t working, so I stopped trying to make this all work…